Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [Solved] libffi8: Broken on multiarch systems  (Read 308 times)

Offline finotti

  • User
  • Posts: 226
[Solved] libffi8: Broken on multiarch systems
« on: 2022/09/22, 15:43:41 »
I could not DU my system this morning (with new plasma).  The system is currently broken...

Here is the only bug report I've found: https://groups.google.com/g/linux.debian.bugs.dist/c/05do3LZB67k

Code: [Select]
# apt -f install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  kdeplasma-addons-data kwin-data libcolorcorrect5 libkfontinst5 libkfontinstui5
  libkwineffects13 libkwinglutils13 libkwinxrenderutils13 libkworkspace5-5
  libnotificationmanager1 libplasma-geolocation-interface5 libtaskmanager6abi1
  libweather-ion7 plasma-dataengines-addons plasma-runners-addons
  plasma-wallpapers-addons plasma-widgets-addons
Suggested packages:
  quota
Recommended packages:
  qml-module-qtquick-virtualkeyboard plasma-systemmonitor
The following packages will be upgraded:
  kdeplasma-addons-data kwin-data libcolorcorrect5 libkfontinst5 libkfontinstui5
  libkwineffects13 libkwinglutils13 libkwinxrenderutils13 libkworkspace5-5
  libnotificationmanager1 libplasma-geolocation-interface5 libtaskmanager6abi1
  libweather-ion7 plasma-dataengines-addons plasma-runners-addons
  plasma-wallpapers-addons plasma-widgets-addons
17 upgraded, 0 newly installed, 0 to remove and 433 not upgraded.
11 not fully installed or removed.
Need to get 0 B/7,260 kB of archives.
After this operation, 174 kB of additional disk space will be used.
Do you want to continue? [Y/n]
dpkg: dependency problems prevent configuration of libffi8:amd64:
 libffi8:i386 (3.4.3-1) breaks libffi8ubuntu1 and is unpacked but not configured.
  libffi8:amd64 (3.4.3-1) provides libffi8ubuntu1.

dpkg: error processing package libffi8:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libffi8:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code: [Select]
# dpkg --configure -a
dpkg: dependency problems prevent configuration of kde-cli-tools:
 kde-cli-tools depends on libkworkspace5-5 (>= 4:5.25.5~); however:
  Version of libkworkspace5-5 on system is 4:5.25.4-3.

dpkg: error processing package kde-cli-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kwin-x11:
 kwin-x11 depends on libkwineffects13 (= 4:5.25.5-1); however:
  Version of libkwineffects13 on system is 4:5.25.4-2.
 kwin-x11 depends on libkwinglutils13 (= 4:5.25.5-1); however:
  Version of libkwinglutils13 on system is 4:5.25.4-2.
 kwin-x11 depends on libkwinxrenderutils13 (= 4:5.25.5-1); however:
  Version of libkwinxrenderutils13 on system is 4:5.25.4-2.

dpkg: error processing package kwin-x11 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kwin-addons:amd64:
 kwin-addons:amd64 depends on kdeplasma-addons-data (= 4:5.25.5-1); however:
  Version of kdeplasma-addons-data on system is 4:5.25.4-1.
 kwin-addons:amd64 depends on kwin-x11 (>= 4:5.25) | kwin (>= 4:5.25); however:
  Package kwin-x11 is not configured yet.
  Package kwin is not installed.
  Version of kwin on system, provided by kwin-x11:amd64, is <none>.

dpkg: error processing package kwin-addons:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plasma-workspace:
 plasma-workspace depends on libcolorcorrect5 (= 4:5.25.5-1); however:
  Version of libcolorcorrect5 on system is 4:5.25.4-3.
 plasma-workspace depends on libkfontinst5 (= 4:5.25.5-1); however:
  Version of libkfontinst5 on system is 4:5.25.4-3.
 plasma-workspace depends on libkfontinstui5 (= 4:5.25.5-1); however:
  Version of libkfontinstui5 on system is 4:5.25.4-3.
 plasma-workspace depends on libkworkspace5-5 (= 4:5.25.5-1); however:
  Version of libkworkspace5-5 on system is 4:5.25.4-3.
 plasma-workspace depends on libnotificationmanager1 (= 4:5.25.5-1); however:
  Version of libnotificationmanager1 on system is 4:5.25.4-3.
 plasma-workspace depends on libplasma-geolocation-interface5 (= 4:5.25.5-1); however:
  Version of libplasma-geolocation-interface5 on system is 4:5.25.4-3.
 plasma-workspace depends on libtaskmanager6abi1 (= 4:5.25.5-1); however:
  Version of libtaskmanager6abi1 on system is 4:5.25.4-3.
 plasma-workspace depends on libweather-ion7 (= 4:5.25.5-1); however:
  Version of libweather-ion7 on system is 4:5.25.4-3.

dpkg: error processing package plasma-workspace (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kwin-common:
 kwin-common depends on kwin-data (= 4:5.25.5-1); however:
  Version of kwin-data on system is 4:5.25.4-2.
 kwin-common depends on libkwineffects13 (= 4:5.25.5-1); however:
  Version of libkwineffects13 on system is 4:5.25.4-2.
 kwin-common depends on libkwinglutils13 (= 4:5.25.5-1); however:
  Version of libkwinglutils13 on system is 4:5.25.4-2.

dpkg: error processing package kwin-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libffi8:amd64:
 libffi8:i386 (3.4.3-1) breaks libffi8ubuntu1 and is unpacked but not configured.
  libffi8:amd64 (3.4.3-1) provides libffi8ubuntu1.

dpkg: error processing package libffi8:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libffi8:i386:
 libffi8:amd64 (3.4.3-1) breaks libffi8ubuntu1 and is unpacked but not configured.
  libffi8:i386 (3.4.3-1) provides libffi8ubuntu1.

dpkg: error processing package libffi8:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libffi-dev:amd64:
 libffi-dev:amd64 depends on libffi8 (= 3.4.3-1); however:
  Package libffi8:amd64 is not configured yet.

dpkg: error processing package libffi-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 kde-cli-tools
 kwin-x11
 kwin-addons:amd64
 plasma-workspace
 kwin-common
 libffi8:amd64
 libffi8:i386
 libffi-dev:amd64
« Last Edit: 2022/09/23, 10:55:16 by finotti »

Offline qord

  • User
  • Posts: 33
Re: libffi8: Broken on multiarch systems
« Reply #1 on: 2022/09/22, 18:29:03 »
Same here.
I installed both packages with dpkg and --force which made it possible to use apt full-upgrade again and /so far/ the system did not go up in smoke, but I wouldn't recommend that solution...

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.213
    • Land of the Buckeye
Re: libffi8: Broken on multiarch systems
« Reply #2 on: 2022/09/22, 18:29:53 »
I don't know, finotti -- I cannot find any problem here.

Code: [Select]
don@dibl-HP350:~$ sudo apt policy libffi8
libffi8:
  Installed: 3.4.3-1
  Candidate: 3.4.3-1
  Version table:
 *** 3.4.3-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy kwin-common
kwin-common:
  Installed: 4:5.25.5-1
  Candidate: 4:5.25.5-1
  Version table:
 *** 4:5.25.5-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy libkwineffects13
libkwineffects13:
  Installed: 4:5.25.5-1
  Candidate: 4:5.25.5-1
  Version table:
 *** 4:5.25.5-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy libkworkspace5-5
libkworkspace5-5:
  Installed: 4:5.25.5-1
  Candidate: 4:5.25.5-1
  Version table:
 *** 4:5.25.5-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy kde-cli-tools
kde-cli-tools:
  Installed: 4:5.25.5-1
  Candidate: 4:5.25.5-1
  Version table:
 *** 4:5.25.5-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy kwin-x11
kwin-x11:
  Installed: 4:5.25.5-1
  Candidate: 4:5.25.5-1
  Version table:
 *** 4:5.25.5-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Online GoinEasy9

  • User
  • Posts: 528
Re: libffi8: Broken on multiarch systems
« Reply #3 on: 2022/09/22, 18:49:09 »
My full-upgrade finished leaving 2 not fully installed. I update every day on this machine, so, I'm not having problems updating, it just leaves the 2 in limbo. My adding Steam brought in many :i386 apps, I just figured it would fix itself after a few days.

Code: [Select]
apt full-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
dpkg: dependency problems prevent configuration of libffi8:amd64:
 libffi8:i386 (3.4.3-1) breaks libffi8ubuntu1 and is unpacked but not configured.
  libffi8:amd64 (3.4.3-1) provides libffi8ubuntu1.

dpkg: error processing package libffi8:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libffi8:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Linux Counter number 348347

Offline unklarer

  • User
  • Posts: 680
Re: libffi8: Broken on multiarch systems
« Reply #4 on: 2022/09/22, 19:16:08 »
Quote from: dibl
I don't know, finotti -- I cannot find any problem here.

Same here.

Offline finotti

  • User
  • Posts: 226
Re: libffi8: Broken on multiarch systems
« Reply #5 on: 2022/09/22, 19:36:44 »
Thanks for all the replies!

I don't know, finotti -- I cannot find any problem here.

Quote from: dibl
I don't know, finotti -- I cannot find any problem here.

Same here.

Do you have multiarch (i386 and amd64 packages) in your systems?

My full-upgrade finished leaving 2 not fully installed. I update every day on this machine, so, I'm not having problems updating, it just leaves the 2 in limbo. My adding Steam brought in many :i386 apps, I just figured it would fix itself after a few days.

I wonder if it happened because it was a large update (I hadn't DU in a little while) and the broken package just broke the whole process.

Same here.
I installed both packages with dpkg and --force which made it possible to use apt full-upgrade again and /so far/ the system did not go up in smoke, but I wouldn't recommend that solution...

That is a bit extreme, but I need that system running soon...  If I find no other fix, I might try that.  Thanks for letting me know.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.213
    • Land of the Buckeye
Re: libffi8: Broken on multiarch systems
« Reply #6 on: 2022/09/22, 20:11:30 »
Quote from: finotti
Do you have multiarch (i386 and amd64 packages) in your systems?

Not here -- this laptop is amd64 only.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.645
Re: libffi8: Broken on multiarch systems
« Reply #7 on: 2022/09/22, 21:20:10 »
Dirty workaround:

Code: [Select]
mkdir ~/debfix \
cd ~/debfix \
apt update \
apt download libffi8 libffi8:i386 \
for d in libffi8*.deb; do
  dpkg-deb -x $d $d.dir;
  dpkg-deb -e $d $d.dir/DEBIAN;
  sed -i '/Breaks: libffi8ubuntu1/d' $d.dir/DEBIAN/control;
  sed -i '/Replaces: libffi8ubuntu1/d' $d.dir/DEBIAN/control;
  sed -i '/Provides: libffi8ubuntu1 .*/d' $d.dir/DEBIAN/control;
  dpkg-deb -b $d.dir $d;
done
sudo dpkg -i libffi8*.deb \
sudo apt-mark hold libffi8 \
sudo apt -f install \
sudo apt full-uphgrade \

Given, you have sudo configured, if not, do all as root, remove the sudo from the commands.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1020488#10

Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline finotti

  • User
  • Posts: 226
Re: libffi8: Broken on multiarch systems
« Reply #8 on: 2022/09/23, 00:33:43 »
Thanks, towo!  It worked.  You are a life saver! :-)

Offline qord

  • User
  • Posts: 33
Re: libffi8: Broken on multiarch systems
« Reply #9 on: 2022/09/23, 09:11:41 »
New version of libffi8 came in with d-u this morning, installed (here) without problems.

Offline finotti

  • User
  • Posts: 226
Re: libffi8: Broken on multiarch systems
« Reply #10 on: 2022/09/23, 10:55:02 »
Confirmed: I removed the hold and installed 3.4.3-2 without problems.