Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  PC boots into BIOS, How to full/dist-upgrade EN / DE  (Read 14233 times)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
Re: PC boots into BIOS, How to full/dist-upgrade EN / DE
« Reply #30 on: 2024/02/07, 20:11:19 »
I ran into this months old issue the same day you did on my wife's PC, that had not been updated in six months or so.I had totally forgotten about this issue, since i did not run into it in the first place on my devices.

So, thanks to your report, I threw siduction image and boot-repair-disk on my Ventoy stick and had at it. Fortunately, chrooting in and taking care of GRUB2 was enough. But good to know, boot-repair-disk sorts it out with a click if needed.

Offline Spike_DE

  • User
  • Posts: 56
Re: PC boots into BIOS, How to full/dist-upgrade EN / DE
« Reply #31 on: 2024/02/11, 19:50:59 »
hey, joined the group of affected users today with my mum's notebook... Now downloading the repair-tool ;) Thank you for the hint!

(somehow i have to manage to look into "upgrade warnings" before hitting "apt-get dist-upgrade"...)

type cat /vmlinuz > /dev/audio to hear the voice of god.

Offline ratamahatta

  • Newbie
  • Posts: 1
Re: PC boots into BIOS, How to full/dist-upgrade EN / DE
« Reply #32 on: 2024/02/29, 12:15:40 »
Hello everyone!

Just registered to describe what I experienced/did.

Did a dist-upgrade and lost all grub boot screen decoration, only ASCII art now. But that would have been fine if the system would boot. Which it didn't.
So I used a live medium to boot (still wintersky, maybe that is another problem), chrooted, grub-install, update-grub: No dice. Still not booting.

I'll have tell some background on me: I started using Linux with SuSE 8.0 (now called openSUSE), had to deal with Ubuntu Desktops and "Servers" at work (Their server distributions don't really serve a purpose in my opinion) and then switched to Aptosid. - Took me a few releases to get that they are really unfriendly (I just agreed to my posts not being insulting... >:( ). Finally found out that there was a certain fork focusing on the wishes and problems of the community. Absolutely loved PaintItBlack! So here I am.

Now I'm a freak and occasionally back up my system partition. (Call it "System Restore Point" if you like. Some of it may be related to bad experiences in the past.) In any case it just takes a boot from a live medium and like 10 more Minutes of extracting a tarball, chrooting, grub installing and updating and I'm back to some working state.

Found the forum and read the Install Warning. (Never got the hint to look this up before... :o) ) The additional grub-install; update-grub after the dist-upgrade showed no errors but the system still did not boot.

So I did that: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1051271 In my case there were six grub packages that I downgraded. Since in chroot the resolution of the packages failed for some reason, I just got dem directly from the debian repo to the partition and used dpkg to install them, grub-install; update-grub and I was back to a booting system.

Currently, the system is up to date except for grub.

Maybe that will help somebody else. Used this manual to chroot: https://wiki.ubuntuusers.de/GRUB_2/Reparatur/#chroot-Methode (Their server distributions are no good but their manuals definitely are.) Since /etc/mtab is a link, I moved it to /etc/mtab.lnk before the cp command and back before rebooting.
« Last Edit: 2024/02/29, 12:21:21 by ratamahatta »