Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] PC boots into BIOS  (Read 8551 times)

Offline ro_sid

  • User
  • Posts: 227
[EN] Re: PC boots into BIOS
« Reply #30 on: 2023/09/06, 20:20:56 »
Hello @sotnik

You seem to have have a strange partitioning:

Quote
Device             Start       End   Sectors   Size Type
/dev/nvme0n1p1      2048   1023999   1021952   499M Windows recovery environment
/dev/nvme0n1p2   1024000   1228799    204800   100M EFI System
/dev/nvme0n1p3   1228800   1261567     32768    16M Microsoft reserved
/dev/nvme0n1p4   1261568 368642047 367380480 175,2G Microsoft basic data
/dev/nvme0n1p5 368642048 369256447    614400   300M EFI System
/dev/nvme0n1p6 369256448 493160447 123904000  59,1G Linux filesystem
/dev/nvme0n1p7 493160448 909664255 416503808 198,6G Linux filesystem
/dev/nvme0n1p8 909664256 976773119  67108864    32G Linux swap

There are two(!) partitions marked "EFI" on the same drive-device (p2 and p5). I'm not even sure, if this is "allowed", but it sure makes the choice difficult. Only one of them can be used for booting. Most likely the UEFI-boot-system will select the first one. And I don't think, Linux will make an automatic choice here, which it otherwise does.
Normally the partition to mount as EFI-partition on Linux is an entry in /etc/fstab.

Offline Teriarch

  • User
  • Posts: 49
Re: PC boots into BIOS
« Reply #31 on: 2023/09/06, 20:28:38 »
@sotnik

Since /dev/nvme0n1p6 is mounted as root partition you somehow managed
to boot into the system (or used chroot?), how? Did you change your bios
settings to do so and is it an uefi boot (efivars are not mounted, though)?

This information is critical, since advice resulting from guessing games can
worsen the situation.


Offline sotnik

  • User
  • Posts: 110
Re: PC boots into BIOS
« Reply #32 on: 2023/09/06, 21:11:59 »
Hello @ro_sid
Before the problem with grub I had no entry in fstab and I had no issues at all.
Any way, I removed the efi partition /dev/nvme0n1p2 since it is not needed

@Teriarch
I booted in the system using super grub2, therefore chroot is not necessary
Yes, I selected uefi in bios

I don’t think it can be worse than the current state :)

I provide some further information for my system

I have two efi directories

/boot/efi/
and
/efi/EFI/

The /boot/efi/ is empty

The EFI directory contains the following directories:

Quote
ls /efi/EFI/ -l
total 8
drwxr-xr-x 2 root root 4096 Νοε  13  2018 boot
drwxr-xr-x 2 root root 4096 Νοε  13  2018 siduction_2018.3.0

Quote
# ls /efi/EFI/boot/ -l
total 120
-rwxr-xr-x 1 root root 121856 Νοε  13  2018 bootx64.efi

Quote
# ls /efi/EFI/siduction_2018.3.0/ -l
total 120
-rwxr-xr-x 1 root root 121856 Νοε  13  2018 grubx64.efi

Where I have to mount /dev/nvme0n1p5 ?

Thank you

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: PC boots into BIOS
« Reply #33 on: 2023/09/06, 21:16:50 »
/efi/EFI/

is absolutely wrong!

the efi partition has to be mountet as /boot/efi!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline sotnik

  • User
  • Posts: 110
Re: PC boots into BIOS
« Reply #34 on: 2023/09/06, 21:30:20 »
Thank you towo
Problem solved.
I post here what I did just for the case it might be useful to someone else.

Quote
# mount /dev/nvme0n1p5 /boot/efi/

Quote
# grub-install
Installing for x86_64-efi platform.
Installation finished. No error reported.

Quote
# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/patience/theme.txt
Found linux image: /boot/vmlinuz-6.4.0-4-amd64
Found initrd image: /boot/initrd.img-6.4.0-4-amd64
Found linux image: /boot/vmlinuz-6.4.0-3-amd64
Found initrd image: /boot/initrd.img-6.4.0-3-amd64
Found memtest86+ 64bit EFI image: /boot/memtest86+x64.efi
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done

Reboot and everything work as normal

Thank you again!!!

Offline Teriarch

  • User
  • Posts: 49
Re: PC boots into BIOS
« Reply #35 on: 2023/09/07, 00:03:34 »
@sotnik

glad your problem got solved! And just in case you like to dual boot your system,
uncomment line

#GRUB_DISABLE_OS_PROBER=false

in file /etc/default/grub and run update-grub again.

Offline sotnik

  • User
  • Posts: 110
Re: PC boots into BIOS
« Reply #36 on: 2023/09/07, 00:20:32 »
Thank you @Teriarch, I use only siduction in this PC.

Offline cliff6056

  • User
  • Posts: 21
Re: PC boots into BIOS
« Reply #37 on: 2023/09/07, 16:27:15 »
Holding off on upgrade since before this issue started, will there be a time when a regular DU will just work without intervention?  Thanks. 

Cliff

Offline Taliesin

  • User
  • Posts: 74
Re: PC boots into BIOS
« Reply #38 on: 2023/09/07, 22:58:20 »
Once again I'm grateful to the Siduction community, and the advice given to read the Upgrade Warnings before doing an upgrade.
Which thankfully, I always do.
The recent upgrade of Grub, in particular is a classic example of why this is important.
To that end after running
Code: [Select]
apt update
apt full upgrade
at run level 3
I followed the advice on regarding the installation and upgrading of grub, before rebooting.
You folks are legends.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: PC boots into BIOS
« Reply #39 on: 2023/09/08, 18:28:32 »
Holding off on upgrade since before this issue started, will there be a time when a regular DU will just work without intervention?  Thanks. 

Cliff

You can full-upgrade, dist-upgrade or nala upgrade, depends on what you prefer!
But, if you have the btrfs-filesystem in use, first do

Code: [Select]
apt update
apt install siduction-scripts

after it you can run

Code: [Select]
apt full-upgrade (or what you prefer)
Maybe you need afterwards an "apt -f install" if something went wrong!

Do not reboot yet!

Before rebooting, please run

Code: [Select]
grub-install /dev/foo (foo= your Harddisk like sda or what ever)
update-grub

On an UEFI systems you do not need to address the device!

Now you should be on the save side to reboot!

Good luck!