Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: vayu on 2013/07/18, 20:03:45

Title: Current fglrx status?
Post by: vayu on 2013/07/18, 20:03:45
I want to install Firestarter on a computer with an AMD Radeon HD6870 video card that I would like to use fglrx/catalyst.

Does anyone know specifically if this will work or will not work both as a fresh install from Firestarter and also if it is working or not working from a current dist-upgrade?

In the past I've had to get the right combination of Xorg, Kernel and fglrx versions and I don't want to go through installing only to find it can't currently work.
Title: RE: Current fglrx status?
Post by: timc on 2013/07/18, 20:20:42
I am told that it works at the current time. Good luck!

Tim
Title: Current fglrx status?
Post by: orinoco on 2013/07/24, 19:25:33
My setup works fine

Code: [Select]
orinoco@jake:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 6770]
orinoco@jake:~$ uname -a
Linux jake 3.10-0.towo-siduction-amd64 #1 SMP PREEMPT Wed Jul 3 10:08:02 UTC 2013 x86_64 GNU/Linux
orinoco@jake:~$ dpkg -l | grep -i fglrx-driver
ii  fglrx-driver                              1:13.4-2.c0.siduction.2           amd64        non-free ATI/AMD RadeonHD display driver
Title: Current fglrx status?
Post by: vayu on 2013/07/26, 08:02:59
Orinoco, thanks that listing is just what I need.  Would you mind also showing what version of xorg you're using?  apt-cache policy xserver-xorg-core
Title: Current fglrx status?
Post by: musca on 2013/07/26, 14:54:07
hi vayu,
in the meantime fglrx-driver 1:13.4-3 is available in unstable.
It suits the 3.10 kernel.

cheers
musca
Title: Current fglrx status?
Post by: vayu on 2013/07/27, 01:47:26
Musca, what repository is that in, mine only shows 1.12:
Code: [Select]
$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.12.4-6
  Candidate: 2:1.12.4-6.1
  Version table:
     2:1.12.4-6.1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
 *** 2:1.12.4-6 0
        100 /var/lib/dpkg/status
Title: Current fglrx status?
Post by: ayla on 2013/07/27, 02:59:45
Quote
apt-get update
apt-cache policy fglrx-driver
...Installationskandidat: 1:13.4-3
  Versionstabelle:
     1:13.4-3 0
        500 http://ftp.de.debian.org/debian/ unstable/non-free amd64 Packages
   


greets ayla
Title: Current fglrx status?
Post by: vayu on 2013/07/27, 19:29:37
Quote from: "ayla"
fglrx-driver


greets ayla[/quote]

Thanks, sometimes one needs a little boldface.
Title: Current fglrx status?
Post by: tuxic on 2013/08/03, 22:31:09
I have a dual ATI Radeon HD 4850 but now I'm using the free (as freedom) xorg-radeon driver.  Is the fglrx-driver from experimental compatible with this twin headed dinosaur?
Title: Current fglrx status?
Post by: tuxic on 2013/08/03, 22:31:46
The result from terminal
Quote
oscar@sidx-box:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4850]
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4850]
Title: Current fglrx status?
Post by: seasons on 2013/08/03, 23:07:24
^You would need to use the fglrx-legacy-driver package.
Title: Current fglrx status?
Post by: musca on 2013/08/09, 13:03:08
hello vayu,

today new firmware packages for Kernel 3.10 have been uploaded in debian unstable. Kernel, firmware, xorg and even fglrx have now lined up for full functionality. But I don't own a radeon card, so please give feedback.

I suggest to replace the word "current" by "[solved]" in the title and set the green checkmark as symbol.

greetings
musca
Title: Current fglrx status?
Post by: tuxracer on 2013/08/10, 02:32:42
I hope he tries it, too.   I was wondering if a Radeon HD 6570 card (used) for $20 is a good deal (and how it'd be in Debian sid).

I read that running fglrxinfo is a good test (sometimes?) since it could reveal some useful info?
Title: Current fglrx status?
Post by: vayu on 2013/08/12, 18:55:14
Quote from: "musca"
hello vayu,

today new firmware packages for Kernel 3.10 have been uploaded in debian unstable. Kernel, firmware, xorg and even fglrx have now lined up for full functionality. But I don't own a radeon card, so please give feedback.

I suggest to replace the word "current" by "[solved]" in the title and set the green checkmark as symbol.

greetings
musca


Musca thanks.  This is what I was looking for.  I hope it stays like this for the next week.  I won't have time to test for a while, but will try to report back when I do.
Title: Current fglrx status?
Post by: thx-1138 on 2013/08/13, 20:19:09
Its works for me.  But I downgraded xorg.  While installing the fglrx-driver I also had to install the dkms package and fglrx-modules-dkms.

I am using kernel-3.10.  The card is amd turks pro [radeon hd 6570/7750] as reported by lspci.