Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] (gelöst mit mc) gelegentlicher datenaustausch im Home-LAN  (Read 7164 times)

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
[DE] (gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #15 on: 2011/10/01, 01:05:47 »
der mc - Midnight Commander ist ja "nur" ein dateimanager. Mit avahi stellst du recht unkompliziert die verbindung her, danach kannst du mc, dolphin etc verwenden. Einfach mal meinen link oben folgen.

hefee

  • Guest
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #16 on: 2011/10/01, 04:48:22 »
nein avahi hilft dir nur dass du dir keine IP-Adressen merken musst und in dolphin oder ähnlichen Dateimanagern angezeigt bekommst, das ein rechner scp, samba o.ä. kann.

michaa7 hat ja die IP-Adressen und weiß welche Protokolle auf welchem läuft -> avahi hilft hier erstmal nicht :)
@michaa7: mach mal ein 'ssh -vvvvv', dann gibt er mehr Infos raus, wo es hackelt - ich vermute mal /etc/hosts.deny bzw. /etc/hosts.allow - Schon mal compress ausprobiert ('-C'), damit wird das ganze schneller :)

Für die Harten im Garten gibt es ja netcat - (schnell und sehr geekig):
für die Empfängerseite:
Code: [Select]

# netcat -l -p 7000 | tar x


Für die Senderseite
Code: [Select]

# tar cf - * | netcat otherhost 7000

Offline Lizard

  • User
  • Posts: 27
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #17 on: 2011/10/01, 09:04:15 »
blockiert vielleicht eine Firewall auf dem Laptop den ssh-Port?

holgerw

  • Guest
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #18 on: 2011/10/01, 10:01:57 »
Hallo,

mögliche Fehler, die bei mir mit ssh im Lan schon passiert sind:
- geschlossener ssh Port durch Firewall
- Fehlende Einträge in /etc/hosts
- ssh nicht installiert
- ssh nicht aktiviert

Vieleb Grüße,
  Holger

Offline gerd

  • User
  • Posts: 147
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #19 on: 2011/10/01, 10:13:58 »
So lange der Datenaustausch nur im lokalen Netz stattfindet, kann auch nfs benutzt werden. Wundere mich, dass das noch nicht genannt wurde..

Offline michaa7

  • User
  • Posts: 2.304
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #20 on: 2011/10/02, 15:41:14 »
Quote from: "vibora"
läuft auch der ssh server auf beiden kisten?
greetings
vibora


Wie stelle ich das fest? Jedoch ist meiner erinnerung nach bei *nicht* laufendem sshd die fehlermeldung eine andere, irgendwas mit "connection not availabel", dennoch, ne erklärung wär's
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.304
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #21 on: 2011/10/02, 15:44:00 »
Quote from: "hefee"
nein avahi hilft dir nur dass du dir keine IP-Adressen merken musst und in dolphin oder ähnlichen Dateimanagern angezeigt bekommst, das ein rechner scp, samba o.ä. kann.

michaa7 hat ja die IP-Adressen und weiß welche Protokolle auf welchem läuft -> avahi hilft hier erstmal nicht :)
@michaa7: mach mal ein 'ssh -vvvvv', dann gibt er mehr Infos raus, wo es hackelt - ich vermute mal /etc/hosts.deny bzw. /etc/hosts.allow - Schon mal compress ausprobiert ('-C'), damit wird das ganze schneller :)

Für die Harten im Garten gibt es ja netcat - (schnell und sehr geekig):
für die Empfängerseite:
Code: [Select]

# netcat -l -p 7000 | tar x


Für die Senderseite
Code: [Select]

# tar cf - * | netcat otherhost 7000



der netcat kram, taugt der zur analyse oder zum übertragen?
BTW, am liebsten wäre mir immer noch, ich bekäme das über mc hin.

Hier der output über ssh -vvvvv ...
Quote
$ ssh -vvvvv mh@192.168.x.x
OpenSSH_5.9p1 Debian-1, OpenSSL 1.0.0e 6 Sep 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.x.x [192.168.x.x] port 22.
debug1: connect to address 192.168.x.x port 22: Connection refused
ssh: connect to host 192.168.x.x port 22: Connection refused
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.304
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #22 on: 2011/10/02, 16:01:41 »
Quote from: "michaa7"
Quote from: "vibora"
läuft auch der ssh server auf beiden kisten?
greetings
vibora


Wie stelle ich das fest? Jedoch ist meiner erinnerung nach bei *nicht* laufendem sshd die fehlermeldung eine andere, irgendwas mit "connection not availabel", dennoch, ne erklärung wär's


OMG, der kandidat hat 100 punkte, sshd läuft gar nicht  :oops:

Nur, warum sehe ich in rcconf ssh weder aktiviert noch deaktiviert? Wie aktiviere ich sshd nun?

EDIT:// ok, ssh ist aktiviert, nur es geht immer noch nicht (beide maschinen neu gebootet!
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

hefee

  • Guest
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #23 on: 2011/10/02, 16:25:15 »
der netcat kram taugt zum übertragen, es verschlüsselt halt nicht und hat auch sonst nur tcp overhead, weswegen es seehr schnell ist, das ist die Variante die ich verwende wenn ich mir sicher bin, das das lokale Netz sicher ist und ich viele Daten rüberschafeln will.

@michaa7: Du hast ein aptosid? Mit /etc/init.d/ssh start kannst du ssh sofort anmachen. Ansonsten bei rcconf bei ssh einen Hacken und neustarten. Oder hast du vlt. gar keinen ssh Server installiert?

Code: [Select]

 apt-cache policy openssh-server
openssh-server:
  Installiert: 1:5.9p1-1
  Kandidat:    1:5.9p1-1
  Versionstabelle:
 *** 1:5.9p1-1 0
        500 http://cdn.debian.net/debian/ sid/main amd64 Packages
        500 http://cdn.debian.net/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
     1:5.5p1-6 0
        500 http://cdn.debian.net/debian/ stable/main amd64 Packages

Offline michaa7

  • User
  • Posts: 2.304
(gelöst mit mc) gelegentlicher datenaustausch im Home-LAN
« Reply #24 on: 2011/10/02, 17:05:57 »
klar ist das ein aptosid auf beiden rechnern, ssh-server ist installiert (gleiche version wie von dir oben angezeigt) systeme sind up-to-date, /etc/ssh/sshd_config zum soundsovielstem mal verglichen, ich habe keine plan was ich sonst noch nachschauen, vergleichen oder testen könnte.

ping zum rechner funktioniert
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.304
gelöst
« Reply #25 on: 2011/10/02, 17:57:22 »
ein reinstall auf dem läptop (sshd war zuvor installiert und aktiviert) brachte dann die (er-) lösung.

BTW: ich erinnere mich, dass ich bei der aptosid installation vor 2 monaten die frage nach der aktivierung des ssh-server verneinte! Das nachträgliche aktivieren scheint fehlzuschlagen ... wie man hier sieht.

Die verbindung mit mc werde ich später noch testen, da habe ich im mom keinen nerv zu ...
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

hefee

  • Guest
RE: gelöst
« Reply #26 on: 2011/10/02, 21:30:16 »
öhm also ssh server nachinstallien sollte klappen wie jedes andere Paket auch, wenn nicht wäre das ein bug des ssh Paketes!

Offline michaa7

  • User
  • Posts: 2.304
RE: gelöst
« Reply #27 on: 2011/10/02, 21:56:44 »
das geht an meiner aussage vorbei, du hast es nicht verstanden:

sshd server war immer schon installiert, aber seit der installtion durch den aptosid installer *de-* aktiviert. Das *nachträgliche* aktivieren brachte ihn aber *nicht* in einen funktionsfahigen zustand. Das geschah erst mit dem *re-* install.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.304
RE: gelöst
« Reply #28 on: 2011/10/02, 22:08:44 »
BTW: mc funḱtioniert nun auch, lag also am ssh-server.

Und diese methode ist einfach super, danke towo für den tipp!
Ok, you can't code, but you still might be able to write a bug report for Debian's sake