Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] wine auf hold  (Read 7001 times)

mylo

  • Guest
[EN] wine auf hold
« on: 2012/06/19, 20:10:32 »
Hallo,

wine ist seit längerer Zeit bei mir auf "hold".
Wo kann man erfahren, was da los ist und wie/wann es weitergeht?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
wine auf hold
« Reply #1 on: 2012/06/19, 20:44:11 »
apt-mark showhold

greetz
devil

Offline Geier0815

  • User
  • Posts: 588
wine auf hold
« Reply #2 on: 2012/06/19, 20:57:17 »
Take a look in this thread

By the way: You are in the wrong forum or using the wrong language.
« Last Edit: 2013/11/10, 11:40:57 by melmarker »
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

mylo

  • Guest
wine auf hold
« Reply #3 on: 2012/06/19, 22:24:03 »
sorry for that

mylo

  • Guest
Re: wine auf hold
« Reply #4 on: 2012/06/19, 22:26:38 »
Quote from: "devil"
apt-mark showhold

greetz
devil


shows nothing here, however

Code: [Select]
hängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete sind zurückgehalten worden:
  wine
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.


Is that a contradiction? Is it just my box concerned?

Offline michaa7

  • User
  • Posts: 2.302
Re: wine auf hold
« Reply #5 on: 2012/06/19, 23:50:32 »
Code: [Select]
apt-mark showhold

shows holds by user interaction. It does not show holds by maintainers.

But it is strange. When I do (on a 64 bit installation):

Code: [Select]
apt-get install wine -s

I get the following output:
Quote
# apt-get install wine -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  wine64-bin
Die folgenden Pakete werden ENTFERNT:
  lmms wine-bin
Die folgenden NEUEN Pakete werden installiert:
  wine wine64-bin
0 aktualisiert, 2 neu installiert, 2 zu entfernen und 0 nicht aktualisiert.
Remv lmms [0.4.10-2.2]
Remv wine-bin [1.2.3-0.3]
Inst wine64-bin (1.4.1-1 Debian:unstable [amd64])
Inst wine (1.4.1-1 Debian:unstable [amd64])
Conf wine64-bin (1.4.1-1 Debian:unstable [amd64])
Conf wine (1.4.1-1 Debian:unstable [amd64])


Nothing on hold. Try to purge your old win installation (1.2.x) and install wine again.

I have no clue what prevents wine from being upgraded on your system.

Did you "apt-get update" before?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline cryptosteve

  • User
  • Posts: 675
Re: wine auf hold
« Reply #6 on: 2012/06/20, 05:25:13 »
It's not a good idea to upgrade wine these days, cause:

Code: [Select]
This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.

The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):

  # dpkg --add-architecture i386
  # sed -i 's/deb\ /deb\ [arch=amd64,i386]\ /g' /etc/apt/sources.list
  # apt-get update
  # apt-get install wine-bin:i386

Be very careful as spaces matter above.  For kfreebsd systems, replace i386
and amd64 with kfreebsd-i386 and kfreebsd-amd64.  Note that this package
(wine64-bin) will be removed in the process.  For more information on the
multiarch conversion, see:
http://wiki.debian.org/Multiarch/HOWTO


and

Code: [Select]
[root@shangrila:~]# LANG=C apt-get install wine-bin:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-bin:i386 : Depends: libwine-bin:i386 (= 1.4.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Edit: Hmm, maybe I'm to stupid?! :) What are these held packages? Nothing at showhold, removed all old *wine* packages.
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline michaa7

  • User
  • Posts: 2.302
Re: wine auf hold
« Reply #7 on: 2012/06/20, 14:39:17 »
@cryptosteve

where do you have defined your debian mirror, in /etc/apt/sources.list or in /etc/apt/sources.list.d/debian.list?

Maybe

Code: [Select]
# sed -i 's/deb\ /deb\ [arch=amd64,i386]\ /g' /etc/apt/sources.list

does not cover your variation properly?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline cryptosteve

  • User
  • Posts: 675
Re: wine auf hold
« Reply #8 on: 2012/06/20, 16:42:08 »
Good one, michaa7. I fixed that but I get the same error.

Code: [Select]
[root@shangrila:~][root@shangrila:~]# dpkg -l | grep wine                  
ii  libkwineffects1abi3  

# LANG=C apt-get install wine-bin:i386  
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-bin:i386 : Depends: libwine-bin:i386 (= 1.4.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline Geier0815

  • User
  • Posts: 588
Re: wine auf hold
« Reply #9 on: 2012/06/20, 16:47:47 »
What happens if you try "apt-get install wine-bin:i386 libwine-bin:i386"?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline cryptosteve

  • User
  • Posts: 675
Re: wine auf hold
« Reply #10 on: 2012/06/20, 17:03:31 »
Strange stuff :)

Code: [Select]
[root@shangrila:~]# LANG=C apt-get install wine-bin:i386 libwine-bin:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine-bin:i386 : Depends: libwine:i386 (= 1.4.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline Geier0815

  • User
  • Posts: 588
Re: wine auf hold
« Reply #11 on: 2012/06/20, 20:23:41 »
Ok, then try "apt-get install wine-bin:i386 libwine-bin:i386 libwine:i386" you see what's to do if there are more unsolved dependencies? I think it only will work if all packages from wine in i386 are installed.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline cryptosteve

  • User
  • Posts: 675
Re: wine auf hold
« Reply #12 on: 2012/06/20, 20:30:58 »
Hmm ... other output but still strange

Code: [Select]
[root@shangrila:~]# LANG=C apt-get install wine-bin:i386 libwine-bin:i386 libwine:i386              
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
                Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not going to be installed
                Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not going to be installed
                Depends: libxml2:i386 (>= 2.7.4) but it is not going to be installed
                Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline cryptosteve

  • User
  • Posts: 675
Re: wine auf hold
« Reply #13 on: 2012/06/20, 20:38:46 »
Well,
another apt-get update at 20:35 this evening fixed this problem. With the following dist-upgrade I installed

Code: [Select]
[root@shangrila:~]# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  kcalc kcharselect lib32z1 libxvidcore4 php5-cgi php5-common zlib1g
7 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.


Now I can reinstall wine

Code: [Select]
[root@shangrila:~]# LANG=C apt-get install wine-bin:i386 libwine-bin:i386 libwine:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libfreetype6:i386 libpng12-0:i386 libssl1.0.0:i386 libwine-gecko-1.4 libxml2:i386 zlib1g:i386
Suggested packages:
  wine-doc:i386 libwine-cms:i386 libwine-sane:i386 libwine-ldap:i386 libwine-print:i386 libwine-openal:i386 libwine-gphoto2:i386
Recommended packages:
  libgsm1:i386 ttf-liberation:i386 libwine-gl:i386 libwine-alsa:i386 libwine-oss:i386 xml-core:i386
The following NEW packages will be installed:
  libfreetype6:i386 libpng12-0:i386 libssl1.0.0:i386 libwine:i386 libwine-bin:i386 libwine-gecko-1.4 libxml2:i386 wine-bin:i386 zlib1g:i386
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 91.1 kB/54.4 MB of archives.
After this operation, 139 MB of additional disk space will be used.
Do you want to continue [Y/n]?
- born to create drama -
CS Virtual Travel Bug: VF6G5D

mylo

  • Guest
Re: wine auf hold
« Reply #14 on: 2012/06/20, 22:00:34 »
Quote from: "Geier0815"
What happens if you try "apt-get install wine-bin:i386 libwine-bin:i386"?


Hi Geier0815,
did you ask me? cryptosteve did hijack my thread.