Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Älteren Kernel installieren - keine linux-headers für 2.6.  (Read 2983 times)

kj

  • Guest
Hallo zusammen ich bräuchte da mal Hilfe.

Ich habe aktuell den 2.6.36 und würde jetzt gerne auf den letzten 2.6.35 zurückgehen den finde ich auch über apt-cache nur halt die headers nicht:

Code: [Select]

apt-cache search aptosid-amd64
linux-image-2.6-sidux-amd64 - transitional dummy package
linux-headers-2.6-sidux-amd64 - transitional dummy package
linux-headers-2.6.36-0.slh.5-aptosid-amd64 - Header files for Linux 2.6.36-0.slh.5-aptosid-amd64
linux-headers-2.6-aptosid-amd64 - Linux image for aptosid on 64-bit PCs
linux-image-2.6-aptosid-amd64 - Linux image for aptosid on 64-bit PCs
linux-image-2.6.36-0.slh.5-aptosid-amd64 - Linux 2.6.36 for 64-bit PCs
linux-headers-2.6.36-0.slh.3-aptosid-amd64 - Header files for Linux 2.6.36-0.slh.3-aptosid-amd64
linux-image-2.6.35-7.slh.1-aptosid-amd64 - Linux 2.6.35 for 64-bit PCs
linux-image-2.6.36-0.slh.3-aptosid-amd64 - Linux 2.6.36 for 64-bit PCs


Kann mir jemand helfen wie ich die headers für 2.6.35-7.slh.1-aptosid-amd64 bekomme - das müßte doch der letzte 35 sein oder?

Danke und falls einer fragt warum: meine dvb test treiber kann ich nicht mehr mit dem 2.6.36 bauen ngene-test2 wegen einer iotcl Änderung.

DANKE - kai

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Älteren Kernel installieren - keine linux-headers für 2.6.
« Reply #1 on: 2010/11/18, 22:00:45 »
wir bewahren keine älteren kernel auf, das solltest du selbst tun, heisst, immer ein oder zwei ältere als fallback behalten.
kannst du das problem mit dvb etwas ausführen, vll. finden wir eine lösung.

greetz
devil

kj

  • Guest
Älteren Kernel installieren - keine linux-headers für 2.6.
« Reply #2 on: 2010/11/18, 23:16:27 »
Mystique SaTiX-S2 V2 CI Dual

Ich benutze die mit dem v4l-dvb Treiber
http://linuxtv.org/hg/~endriss/ngene-test2/

und Firmware
ngene_18.fw

Wenn ich den Treiber erstelle kommt folgender Fehler:

Code: [Select]

 make -j2
make -C /usr/src/dvb/ngene-test2/v4l
make[1]: Entering directory `/usr/src/dvb/ngene-test2/v4l'
scripts/make_makefile.pl
./scripts/make_myconfig.pl
make[1]: Leaving directory `/usr/src/dvb/ngene-test2/v4l'
make[1]: Entering directory `/usr/src/dvb/ngene-test2/v4l'
perl scripts/make_config_compat.pl /lib/modules/2.6.36-0.slh.5-aptosid-amd64/build ./.myconfig ./config-compat.h
creating symbolic links...
ln -sf . oss
make -C firmware prep
make[2]: Entering directory `/usr/src/dvb/ngene-test2/v4l/firmware'
make[2]: Leaving directory `/usr/src/dvb/ngene-test2/v4l/firmware'
make -C firmware
make[2]: Entering directory `/usr/src/dvb/ngene-test2/v4l/firmware'
  CC  ihex2fw
Generating vicam/firmware.fw
Generating dabusb/firmware.fw
Generating dabusb/bitstream.bin
Generating ttusb-budget/dspbootcode.bin
Generating cpia2/stv0672_vp4.bin
Generating av7110/bootcode.bin
make[2]: Leaving directory `/usr/src/dvb/ngene-test2/v4l/firmware'
Kernel build directory is /lib/modules/2.6.36-0.slh.5-aptosid-amd64/build
make -C /lib/modules/2.6.36-0.slh.5-aptosid-amd64/build SUBDIRS=/usr/src/dvb/ngene-test2/v4l  modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.36-0.slh.5-aptosid-amd64'
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tuner-xc2028.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tuner-simple.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tuner-types.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/mt20xx.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tda8290.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tea5767.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tea5761.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/tda9887.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/xc5000.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/mt2131.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/mc44s803.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/dvbdev.o
  CC [M]  /usr/src/dvb/ngene-test2/v4l/dmxdev.o
/usr/src/dvb/ngene-test2/v4l/dmxdev.c:1142: error: unknown field 'ioctl' specified in initializer
/usr/src/dvb/ngene-test2/v4l/dmxdev.c:1142: warning: initialization from incompatible pointer type
/usr/src/dvb/ngene-test2/v4l/dmxdev.c:1211: error: unknown field 'ioctl' specified in initializer
/usr/src/dvb/ngene-test2/v4l/dmxdev.c:1211: warning: initialization from incompatible pointer type
make[3]: *** [/usr/src/dvb/ngene-test2/v4l/dmxdev.o] Fehler 1
make[3]: *** Warte auf noch nicht beendete Prozesse...
make[2]: *** [_module_/usr/src/dvb/ngene-test2/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.36-0.slh.5-aptosid-amd64'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/usr/src/dvb/ngene-test2/v4l'
make: *** [all] Fehler 2



Das kommt wohl durch Änderungen an ioctl im 2.6.36 - leider wurde das noch nicht in v4l-dvb nachgezogen.

Lokal habe ich nur noch die 34 header, sollte ich den dann besser wieder nehmen?
linux-headers-2.6.34-0.slh.5-sidux-amd64

Vielen Dank schon mal für die schnelle Antwort und der Nachfrage. -kai

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Älteren Kernel installieren - keine linux-headers für 2.6.
« Reply #3 on: 2010/11/19, 00:43:40 »
Quote

Das kommt wohl durch Änderungen an ioctl im 2.6.36 - leider wurde das noch nicht in v4l-dvb nachgezogen.


da liegst du richtig. ich würde erst mal nachfragen wie der stand ist bei v4l. leider sind die notwendigen änderungen oft alles andere als trivial.

greetz
devil

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Älteren Kernel installieren - keine linux-headers für 2.6.
« Reply #4 on: 2010/11/21, 20:24:24 »
kj,
du solltest mal linux-image-2.6.36-0.slh.8-aptosid-amd64 testen wegen deinem dvb treiber. berichte bitte obs wieder geht.

greetz
devil

kj

  • Guest
Älteren Kernel installieren - keine linux-headers für 2.6.
« Reply #5 on: 2010/11/22, 22:16:38 »
Hi devil danke für den tip aber leider noch immer der gleiche Fehler.