Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Fehlermeldung nach du  (Read 9054 times)

Offline michaa7

  • User
  • Posts: 2.319
[DE] Re: Fehlermeldung nach du
« Reply #30 on: 2013/12/10, 02:38:52 »
...Ah, my bad, you would need 

apt-get install adequate
...
no, no, what I posted was the output *after* I installed it ;-)
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: Fehlermeldung nach du
« Reply #31 on: 2013/12/10, 03:28:33 »
Quote from: michaa7
Quote from: piper on Today at 07:26:17 PM...Ah, my bad, you would need 

apt-get install adequate
...no, no, what I posted was the output *after* I installed it ;-)
For you, that is fine, normal

manilg's will probably look like

Code: [Select]
adequate vlc-data
vlc-data: obsolete-conffile /etc/vlc/lua/http/.hosts
vlc-data: obsolete-conffile /etc/vlc/lua/http/dialogs/.hosts

give or take some lines

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #32 on: 2013/12/11, 06:20:35 »
Code: [Select]
apt-cache policy libvlccore5
N: Paket libvlccore5 kann nicht gefunden werden.

und

Code: [Select]
adequate vlc-data
adequate: error: no packages to check


manilg

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: Fehlermeldung nach du
« Reply #33 on: 2013/12/11, 12:18:20 »
manilg, have you tried reinstalling from the deb-multimedia repo ?
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline michaa7

  • User
  • Posts: 2.319
Re: Fehlermeldung nach du
« Reply #34 on: 2013/12/11, 14:00:35 »
naja, ganz offensichtlich hat es vlc-data noch nicht auf deine platte geschafft, zumindest nicht in funktionierendem zustand. Und zu libvlccore5 hätte ich natürlich noch dazuschreiben können, dass sich auch eine libvlccore4 auf meinen system herumgetrieben hat.
Eines scheint klar: dein vlc ist durch irgendein unpassendes paket in einen derart verwurstelten zustand gelangt, das apt das nicht so ohen weiteres schafft das zu entwirren.
Vermutlich hast du bislang ja kein
Code: [Select]
apt-get purge *vlc* durchgeführt. (Merke "remove" ist in situationen wie dieser eine ganz schlechte option!).


Dann zeig mal:
Code: [Select]
dpkg -l | grep vlcexact so!
Ich möchte nun wirklich mal klar sehen welche vlc pakete alles installiert sind (vor allem ob das nur die sind, die eben upgedatet werden sollen, was ich bezweifle). Und dann könntest du noch ein
Code: [Select]
apt-cache policy <alle-pakete-die-"dpkg_-l_|_grep_vlc"-gefunden-hat>[code]
Und dann bitte den output von beiden zeigen.
« Last Edit: 2013/12/11, 16:36:41 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #35 on: 2013/12/11, 22:34:38 »


Code: [Select]
apt-get purge *vlc*
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Note, selecting 'vlc-plugin-zvbi' for regex '*vlc*'
Note, selecting 'vlc-plugin-jack' for regex '*vlc*'
Note, selecting 'remuco-vlc' for regex '*vlc*'
Note, selecting 'vlc-plugin-sdl' for regex '*vlc*'
Note, selecting 'python-vlc' for regex '*vlc*'
Note, selecting 'phonon-backend-vlc' for regex '*vlc*'
Note, selecting 'phonon-backend-vlc-dbg' for regex '*vlc*'
Note, selecting 'browser-plugin-vlc' for regex '*vlc*'
Note, selecting 'libvlc5' for regex '*vlc*'
Note, selecting 'vlc-plugin-svg' for regex '*vlc*'
Note, selecting 'libvlccore-dev' for regex '*vlc*'
Note, selecting 'vlc-plugin-vlsub' for regex '*vlc*'
Note, selecting 'vlc-plugin-notify' for regex '*vlc*'
Note, selecting 'vlc-dbg' for regex '*vlc*'
Note, selecting 'vlc' for regex '*vlc*'
Note, selecting 'vlc-plugin-fluidsynth' for regex '*vlc*'
Note, selecting 'libvlc-dev' for regex '*vlc*'
Note, selecting 'libvlc0-dev' for regex '*vlc*'
Note, selecting 'libvlccore7' for regex '*vlc*'
Note, selecting 'vlc-plugin-pulse' for regex '*vlc*'
Note, selecting 'mozilla-plugin-vlc' for regex '*vlc*'
Note, selecting 'vlc-data' for regex '*vlc*'
Note, selecting 'vlc-nox' for regex '*vlc*'
Package 'python-vlc' is not installed, so not removed
Package 'mozilla-plugin-vlc' is not installed, so not removed
Package 'libvlc0-dev' is not installed, so not removed
Package 'browser-plugin-vlc' is not installed, so not removed
Package 'phonon-backend-vlc' is not installed, so not removed
Package 'phonon-backend-vlc-dbg' is not installed, so not removed
Package 'remuco-vlc' is not installed, so not removed
Package 'libvlc-dev' is not installed, so not removed
Package 'libvlccore-dev' is not installed, so not removed
Package 'vlc-dbg' is not installed, so not removed
Package 'vlc-plugin-fluidsynth' is not installed, so not removed
Package 'vlc-plugin-jack' is not installed, so not removed
Package 'vlc-plugin-notify' is not installed, so not removed
Package 'vlc-plugin-pulse' is not installed, so not removed
Package 'vlc-plugin-sdl' is not installed, so not removed
Package 'vlc-plugin-svg' is not installed, so not removed
Package 'vlc-plugin-zvbi' is not installed, so not removed
Package 'vlc-plugin-vlsub' is not installed, so not removed
Die folgenden Pakete werden ENTFERNT:
  libvlc5* libvlccore7* vlc* vlc-data* vlc-nox*
0 aktualisiert, 0 neu installiert, 5 zu entfernen und 1 nicht aktualisiert.
5 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 43,8 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
(Lese Datenbank ... 352808 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von vlc (2.1.1-1) ...
Löschen der Konfigurationsdateien von vlc (2.1.1-1) ...
Entfernen von vlc-nox (2.1.1-1) ...
Entfernen von libvlc5 (2.1.1-1) ...
Löschen der Konfigurationsdateien von libvlc5 (2.1.1-1) ...
Entfernen von libvlccore7 (2.1.1-1) ...
Löschen der Konfigurationsdateien von libvlccore7 (2.1.1-1) ...
Entfernen von vlc-data (2.1.1-1) ...
Löschen der Konfigurationsdateien von vlc-data (2.1.1-1) ...
Trigger für man-db (2.6.5-2) werden verarbeitet ...
Trigger für mime-support (3.54) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1) werden verarbeitet ...
Trigger für menu (2.1.46) werden verarbeitet ...
Trigger für libc-bin (2.17-97) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.12-1) werden verarbeitet ...

Code: [Select]
apt-get install vlc
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libvlc5 libvlccore7 vlc-data vlc-nox
Vorgeschlagene Pakete:
  videolan-doc
Empfohlene Pakete:
  vlc-plugin-notify vlc-plugin-pulse
Die folgenden NEUEN Pakete werden installiert:
  libvlc5 libvlccore7 vlc vlc-data vlc-nox
0 aktualisiert, 5 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
Es müssen noch 0 B von 8.952 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 43,8 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] y
dpkg-preconfigure: kann Stdin nicht wieder öffnen: Datei oder Verzeichnis nicht gefunden
Vormals nicht ausgewähltes Paket vlc-data wird gewählt.
(Lese Datenbank ... 352060 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../vlc-data_2.1.1-1_all.deb ...
Entpacken von vlc-data (2.1.1-1) ...
Vormals nicht ausgewähltes Paket libvlccore7 wird gewählt.
Vorbereitung zum Entpacken von .../libvlccore7_2.1.1-1_i386.deb ...
Entpacken von libvlccore7 (2.1.1-1) ...
Vormals nicht ausgewähltes Paket libvlc5 wird gewählt.
Vorbereitung zum Entpacken von .../libvlc5_2.1.1-1_i386.deb ...
Entpacken von libvlc5 (2.1.1-1) ...
Vormals nicht ausgewähltes Paket vlc-nox wird gewählt.
Vorbereitung zum Entpacken von .../vlc-nox_2.1.1-1_i386.deb ...
Entpacken von vlc-nox (2.1.1-1) ...
Vormals nicht ausgewähltes Paket vlc wird gewählt.
Vorbereitung zum Entpacken von .../archives/vlc_2.1.1-1_i386.deb ...
Entpacken von vlc (2.1.1-1) ...
Trigger für hicolor-icon-theme (0.12-1) werden verarbeitet ...
Trigger für man-db (2.6.5-2) werden verarbeitet ...
Trigger für menu (2.1.46) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1) werden verarbeitet ...
Trigger für mime-support (3.54) werden verarbeitet ...
vlc-data (2.1.1-1) wird eingerichtet ...
rmdir: konnte „/etc/vlc/lua/http/dialogs“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua/http“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten des Paketes vlc-data (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlccore7:
 libvlccore7 hängt ab von vlc-data (= 2.1.1-1); aber:
  Paket vlc-data ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libvlccore7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlc5:
 libvlc5 hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libvlc5 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc-nox:
 vlc-nox hängt ab von libvlc5 (>= 2.1.0); aber:
  Paket libvlc5 ist noch nicht konfiguriert.
 vlc-nox hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes vlc-nox (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc:
 vlc hängt ab von vlc-nox (= 2.1.1-1); aber:
  Paket vlc-nox ist noch nicht konfiguriert.
 vlc hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes vlc (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 vlc-data
 libvlccore7
 libvlc5
 vlc-nox
 vlc
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code: [Select]
dpkg -l | grep vlc
iU  libvlc5                                          2.1.1-1                          i386         multimedia player and streamer library
iU  libvlccore7                                      2.1.1-1                          i386         base library for VLC and its modules
iU  vlc                                              2.1.1-1                          i386         multimedia player and streamer
iF  vlc-data                                         2.1.1-1                          all          Common data for VLC
iU  vlc-nox                                          2.1.1-1                          i386         multimedia player and streamer (without X support)

Code: [Select]
apt-cache policy libvlc5
libvlc5:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
root@charon:/home/manfred# apt-cache policy libvlccore7
libvlccore7:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
root@charon:/home/manfred# apt-cache policy vlc
vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
root@charon:/home/manfred# apt-cache policy vlc-data
vlc-data:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
root@charon:/home/manfred# apt-cache policy vlc-nox
vlc-nox:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

@ piper
no, I didn´t

manilg

Offline michaa7

  • User
  • Posts: 2.319
Re: Fehlermeldung nach du
« Reply #36 on: 2013/12/11, 22:57:25 »
Code: [Select]
mkdir -p /etc/vlc/lua/http/dialogs

apt-get install --reinstall vlc  libvlc5 libvlccore7 vlc-data vlc-nox


sollte funktionieren.


Im paket vlc-data gab  es bereits bugs wegen des nicht-löschens von ordnern. Ausgerechnet version 2.1.1.1 sollte dies beheben. Man scheint jedoch vergessen zu haben dafür zu sorgen dass das conffile nicht hängen bleiben sollte wenn die ordner wie bei dir garnicht da sind.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703750
Falls es mit eigens angelegten ordnern klappt wäre ein bugreport mit lösung angebracht, sonst ohne ;-)
« Last Edit: 2013/12/12, 00:26:57 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.319
Re: Fehlermeldung nach du
« Reply #37 on: 2013/12/26, 22:27:03 »
auf meinem 64bit laptop habe ich nun das gleich problem. Habe nen bugreport abgesetzt.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.319
Re: Fehlermeldung nach du
« Reply #38 on: 2014/01/01, 14:43:06 »
der bugreport hat zu version 2.1.2-2 geführt welche hier das problem löst.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake