Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] Unable to Autostart Compton  (Read 2817 times)

UP2L8

  • Guest
[EN] [SOLVED] Unable to Autostart Compton
« on: 2013/12/18, 09:49:45 »
I can start compton from the command line using the following command:
Code: [Select]
compton -cC -i 0.7 -e 0.7 -m 0.7 -r 4 -l -4 -t -4
However, I've tried a variety of methods to get compton to start when I boot my computer and have been unsuccessful.  I've added the aforementioned command in the following files:

/etc/xdg/lxsession/LXDE/autostart
/etc/xdg/openbox/autostart
~/.config/openbox/autostart (with a space, "&", and carriage return following the command)

I've also tried the following alternate commands in the aforementioned files:
Code: [Select]
compton -bcC -i 0.7 -e 0.7 -m 0.7 -r 4 -l -4 -t -4
@compton -cC -i 0.7 -e 0.7 -m 0.7 -r 4 -l -4 -t -4
@compton -bcC -i 0.7 -e 0.7 -m 0.7 -r 4 -l -4 -t -4

What am I doing wrong?
« Last Edit: 2013/12/28, 03:31:39 by UP2L8 »

UP2L8

  • Guest
Re: Unable to Autostart Compton
« Reply #1 on: 2013/12/28, 03:31:13 »
I went back and looked over the guide I was using; https://sites.google.com/site/debianinstallnotes/lxde/set-up.  Turns out the instructions in the guide are either wrong or do not work for my setup.


I came across this thread http://ubuntuforums.org/showthread.php?t=2144468, and modified the original poster's guide to work with LXDE by adding the compton command to the ~/.configure/lxsession/LXDE/autostart file.  I then rebooted and now I have some basic compositing under LXDE-Openbox.