Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [Gelöst]KDE - Keine Arbeitsflaecheneffekte  (Read 8627 times)

Offline Hanisch

  • User
  • Posts: 455
[DE] [Gelöst]KDE - Keine Arbeitsflaecheneffekte
« on: 2011/01/09, 12:19:07 »
Hallo,
bei mir funktionieren die Arbeitsflächeneffekte unter KWin nicht.
Systemeinstellungen -> Arbeitsflächeneffekte -> Arbeitsflächeneffekte aktivieren

Keine Mausspur, keine wabernden Fenster, kein Würfel.

Wenn ich mit fusion-icon auf compiz umschalte funktioniert es einigermaßen.

Wo muß ich da bei KWin noch was einstellen?

Gruß
Ch. Hanisch

Offline OppaErich

  • OLE
  • User
  • Posts: 381
KDE - Keine Arbeitsflächeneffekte
« Reply #1 on: 2011/01/09, 16:50:08 »
grafikkarte, treiber, kde version ?

Offline Hanisch

  • User
  • Posts: 455
Re: KDE - Keine Arbeitsflächeneffekte
« Reply #2 on: 2011/01/09, 17:20:33 »
Quote from: "OppaErich"
grafikkarte, treiber, kde version ?

Grafikkarte:
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8600M GS] (rev a1)
Treiber: wahrscheinlich NVIDIA (recommended) - Wie stelle ich das fest?
KDE-Version: 4.4.5

Gruß
Ch. Hanisch

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #3 on: 2011/01/09, 17:42:48 »
Quote
Treiber: wahrscheinlich NVIDIA (recommended) - Wie stelle ich das fest?

Na Du mußt doch wissen, ob Du den Treiber installiert hast!
Von Alleine isser das nämlich nicht!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Hanisch

  • User
  • Posts: 455
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #4 on: 2011/01/09, 18:44:37 »
Quote from: "towo"
Quote
Treiber: wahrscheinlich NVIDIA (recommended) - Wie stelle ich das fest?

Na Du mußt doch wissen, ob Du den Treiber installiert hast!
Von Alleine isser das nämlich nicht!

Bitte, wie stelle ich fest, welchen NVIDIA-Treiber ich installiert habe bzw. wie installiere ich den recommended NVIDIA-Treiber?

Gruß
Ch. Hanisch

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #5 on: 2011/01/09, 18:50:23 »
Schonmal gesehen, daß es ein Handbuch gibt?

infobash -v2

zeigts auch an.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Hanisch

  • User
  • Posts: 455
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #6 on: 2011/01/09, 18:58:18 »
Quote from: "towo"
Schonmal gesehen, daß es ein Handbuch gibt?

infobash -v2

zeigts auch an.

So, das haben wir:
Code: [Select]
# infobash -v2
Host/Kernel/OS  "aptosid" running Linux 2.6.37-0.slh.1-aptosid-686 i686 [ sidux 2009-01 Ουρανός - kde-full - (200902151348) ]
CPU Info        (1) Intel Core2 Duo T5450 @ clocked at [ 1667.000 MHz ]                                                                                                              
                (2) Intel Core2 Duo T5450 @ clocked at [ 1667.000 MHz ]                                                                                                              
Videocard       nVidia G86 [GeForce 8600M GS]  X.Org 1.7.7  [ 1440x900@50.0hz ]                                                                                                      
Network cards   Realtek RTL8101E/RTL8102E PCI Express Fast                                                                                                                            
                Intel PRO/Wireless 3945ABG [Golan]                                                                                                                                    
Processes 171 | Uptime 2:39 | Memory 584.8/2025.0MB | HDD WDC WD2500BEVS-2,EARS-00Y5B1 Size 1250GB (11%used) | GLX Renderer GeForce 8600M GS/PCI/SSE2 | GLX Version 3.2.0 NVIDIA 195.36.31 | Client Shell | Infobash v3.34


Und nun zurück zu meiner Ausgangsfrage!

Gruß
Ch. Hanisch

Offline Lizard

  • User
  • Posts: 27
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #7 on: 2011/01/10, 18:20:05 »
Hi,
was sagt denn
Code: [Select]
apt-cache policy nvidia-glx

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #8 on: 2011/01/10, 18:48:14 »
Naja, das Einfachste wäre ja, mal in /var/log/Xorg.0.log zu gucken, ob irgendwas hakt.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Hanisch

  • User
  • Posts: 455
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #9 on: 2011/01/10, 19:02:46 »
Quote from: "towo"
Naja, das Einfachste wäre ja, mal in /var/log/Xorg.0.log zu gucken, ob irgendwas hakt.

Also erst mal:
Code: [Select]
~$ apt-cache policy nvidia-glx
nvidia-glx:
  Installiert: 195.36.31-6
  Kandidat:    195.36.31-6
  Versionstabelle:
 *** 195.36.31-6 0
        500 http://ftp.de.debian.org/debian/ sid/non-free i386 Packages
        100 /var/lib/dpkg/status


Vielleicht kann jemand was finden.

Gruß
Ch. Hanisch

Offline Lizard

  • User
  • Posts: 27
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #10 on: 2011/01/10, 21:06:40 »
o.k. scheint als wäre der prop. Nvidia-Treiber installiert. Bist Du nach Anleitung vom Handbuch vorgegangen oder wie hast du ihn installiert?

Ich habe in der Xorg.0.log nichts auffälliges entedecken können, aber da soll besser noch mal jemand reinschauen, der sich mit sowas auskennt  :wink:

Wie sieht denn Deine /etc/X11/xorg.conf bzw. /etc/X11/etc/X11/xorg.conf.d/20-nvidia.conf aus?

Offline Hanisch

  • User
  • Posts: 455
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #11 on: 2011/01/11, 11:47:19 »
Quote from: "Lizard"
o.k. scheint als wäre der prop. Nvidia-Treiber installiert. Bist Du nach Anleitung vom Handbuch vorgegangen oder wie hast du ihn installiert?

Kann mich nicht erinnern, daß ich den installiert habe, war wohl schon so dabei.

Quote
Wie sieht denn Deine /etc/X11/xorg.conf bzw. /etc/X11/etc/X11/xorg.conf.d/20-nvidia.conf aus?

/etc/X11/xorg.conf.d/20-nvidia.conf gibt es bei mir nicht!
Habe aber entsprechend Handbuch das alles nachgeholt - ohne sichtbaren Erfolg.
/etc/X11/xorg.conf :
Code: [Select]
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder63)  Wed May 27 03:16:54 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Wed May 27 03:15:36 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
Driver "nvidia"
Option      "Coolbits" "1"
Option      "AddARGBGLXVisuals" "true"
Option      "TripleBuffer" "false"
#BusID "PCI:1:0:0"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600M GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
# Option      "Composite" "disable"
# Option      "RENDER" "disable"
EndSection


Gruß
Ch. Hanisch

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #12 on: 2011/01/11, 13:47:42 »
Änder mal
Code: [Select]

Section "Extensions"
#   Option      "Composite"   "disable"
#   Option      "RENDER"   "disable"
EndSection

in
Code: [Select]
Section "Extensions"
   Option      "Composite"   "enable"
#  Option      "RENDER"   "disable"
EndSection
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Hanisch

  • User
  • Posts: 455
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #13 on: 2011/01/11, 15:38:22 »
Quote from: "towo"
Änder mal
Code: [Select]
Section "Extensions"
   Option      "Composite"   "enable"
#  Option      "RENDER"   "disable"
EndSection

Das hat nichts gebracht.
Wenn ich auf compiz umstelle (das muß ich mit fusion-icon zweimal machen, damit auch vier Arbeitsflächen erscheinen), dann funktioniert es.

Gruß
Ch. Hanisch

Offline OppaErich

  • OLE
  • User
  • Posts: 381
[Gelöst]KDE - Keine Arbeitsflaecheneffekte
« Reply #14 on: 2011/01/11, 16:05:40 »
Kann es sein dass Compiz als Fenstermanager eingetragen ist statt kwin ? Ich habe mit Compiz keine Erfahrungen.