Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] konsole/terminal fontsize  (Read 9370 times)

Offline michaa7

  • User
  • Posts: 2.304
[EN] [SOLVED] konsole/terminal fontsize
« on: 2014/10/02, 16:44:39 »
As I am going to in stall to a new computer, I want to know how I can configure the *size* of the font used in terminal (not xterm and the like VTs, but real konsole).

Currently when I start an ISO from USB, the first few lines are in big letters, then the boot process switches to letters which for my taste (and eyes and glasses) are too tiny.

I know, there are those magic numbers one may append to the kernel command line. Where do I get an overview? How would I configure it *after* install?
« Last Edit: 2014/10/17, 12:11:54 by dibl »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

farinet

  • Guest
Re: konsole/terminal fontsize
« Reply #1 on: 2014/10/04, 17:24:19 »
dpkg-reconfigure console-setup - eventually ... ;)

ghettoblaster

  • Guest
Re: konsole/terminal fontsize
« Reply #2 on: 2014/10/04, 18:46:41 »
My solution is to set resolution manually in /etc/default/grub:

Code: [Select]
GRUB_GFXMODE=1280x1024                                                                                                                                                 
GRUB_GFXPAYLOAD_LINUX=keep

just my 2 cents ;)

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: konsole/terminal fontsize
« Reply #3 on: 2014/10/04, 21:36:23 »
ghettoblaster: Will work until next update - one should consider to use /etc/default/grub.d/$foo iirc.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

ghettoblaster

  • Guest
Re: konsole/terminal fontsize
« Reply #4 on: 2014/10/05, 08:18:30 »
melmarker: thanx for the hint, corrected my setup and set the values in /etc/default/grub.d/siduction.cfg

Offline michaa7

  • User
  • Posts: 2.304
Re: konsole/terminal fontsize
« Reply #5 on: 2014/10/15, 21:40:24 »
I wonder whether or not you understand what I am talking about:

When *you* boot, do you have big/normal fonts and then wit switches to tiny fonts after the kernel is loaded beginns scann for devices ...

Is that how it works for you?

This is how all live.ISOs work here, too.

But this is what I do not want, because after the switch the fonts too small. Here on this system set up years ago I do ***not*** have this change from normal to tiny. This is what I want on new installations, too (which is why I keep asking). But my /etc/default/grub has no setting related to fonts/vga/resolution.

Quote
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
#GRUB_DISTRIBUTOR=`awk -F '(' '{ print $1 }' /etc/siduction-version`
GRUB_DISTRIBUTOR=`cut -d'-' -f1 /etc/siduction-version 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_TERMINAL=console does not influence the fonts in tty. As far as I can see it only makes a difference for the Grub menu where you select the kernel to boot. Couldn' observe other differences.

There ***must be*** an other way to  set the fonts for tty as here with the above settings I have big fonts.
« Last Edit: 2014/10/15, 21:43:35 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline absolut

  • User
  • Posts: 455
Re: konsole/terminal fontsize
« Reply #6 on: 2014/10/15, 22:04:22 »
remove GRUB_TERMINAL=console


find out the resolution in grub with vbeinfo

uncomment and add resolution, for example:
GRUB_GFXMODE=1280x800

add new line:
GRUB_GFXPAYLOAD_LINUX=keep

save file, run update-grub

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
Re: konsole/terminal fontsize
« Reply #7 on: 2014/10/15, 22:34:01 »
I have been doing some experiments on my Dell E6500 which runs the nouveau driver.  It also provides an extremely small 1600x1200 console screen/font.  I always wondered what it would take to make it easier to read.

Based on what I read in the arch wiki, it is not done in /etc/default/grub at all.  It is done by changing the default console font to a larger size.

You have /usr/share/consolefonts and if you take a look in there, you can see your choices.  So, you open /etc/default/console-setup with your favorite editor.  On my laptop, it was set to Uni2, VGA, and 8x16.  I only changed the size to 32x16 and rebooted.  I was happy to see a much larger and more readable console. If that is not enough for you, I think you have to find a font in /usr/share/consolefonts that is bigger than 32x16.
« Last Edit: 2014/10/15, 22:37:39 by dibl »
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: konsole/terminal fontsize
« Reply #8 on: 2014/10/16, 00:27:01 »
@dibl: no need to go low level - dpkg-reconfigure console-setup may help
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline michaa7

  • User
  • Posts: 2.304
Re: konsole/terminal fontsize
« Reply #9 on: 2014/10/16, 00:38:17 »
@ absolute

That's not the solution. Re-read my posting, please.



@ dibl

Thanks.

That's the content of "nano /etc/default/console-setup"

Quote
ACTIVE_CONSOLES="/dev/tty[1-6]"
CHARMAP="UTF-8"
CODESET="Uni2"
FONTFACE="VGA"
FONTSIZE="8x16"


And I have BIG fonts. So the question is: How do I have big fonts in this installation ***without*** any of the recommended settings although each new installation or live-system on the same computer changes to smaller fonts during boot-up.

@ melmaker

If you have this change to smaller fonts, please show me:
/etc/default/console-setup
« Last Edit: 2014/10/16, 00:43:10 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: konsole/terminal fontsize
« Reply #10 on: 2014/10/16, 02:02:07 »
ich versteh das immer so fürcherlich schlecht, um was es geht - michaa7 - versuch terminus oder lass das System die Schrift aussuchen, für Dich sind nur frame-buffer-Sachen interessant glaube ich.

EDIT: Die nächste Frage wäre: Wie konfiguriere ich den Frambuffer richtig, und das sollte dann eventuell nicht mit keep funktionieren, sondern mit der gewünschten, vom Framebuffer unterstützten Auflösung. Wenn Du nicht weiterkommst, dann sollten wir das mal im IRC durchspielen.

@all: it isn't unkind to write in german in that case - please use the online-Translator (built into this Forum with a reason :) )
« Last Edit: 2014/10/16, 02:05:09 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline michaa7

  • User
  • Posts: 2.304
Re: konsole/terminal fontsize
« Reply #11 on: 2014/10/16, 02:47:12 »
ich versteh das immer so fürcherlich schlecht, um was es geht - michaa7 -

What is difficult to understand, when I ask:
Quote
If you have this change to smaller fonts, please show me:
/etc/default/console-setup

And now I add, please show me the output of /etc/default/console-setup and tell me whether or not you have a change of fontsize during boot-up. Do you have a clue what I am talking about when I say: fontsize changes during boot (and maybe I am wrong and it is actually not the fontsize but the resolution which changes after kernel is loaded. Do you understand what I am talking about here? Does anyone?

Quote
versuch terminus oder lass das System die Schrift aussuchen, für Dich sind nur frame-buffer-Sachen interessant glaube ich.
prankster (tramslation for melmaker: witzbold)

I think using framebuffer would result in having a penguin (ore more) sitting in the upper left corner. I don't have one. Does anybody here understand what I am talking about?

Quote
@all: it isn't unkind to write in german in that case

Yes, it is unkind. There is no reason to treat this posting differently.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

reinob

  • Guest
Re: konsole/terminal fontsize
« Reply #12 on: 2014/10/16, 10:33:36 »
@michaa7,

What you want depends on which graphics card and driver you're using. If NVIDIA/AMD with proprietary drivers then the virtual console will stay a text mode (see note below). If Intel or NVIDIA/AMD-with-open-source-drivers then KMS will set the graphics mode to the native resolution of your display.

-- side note
saying "not xterm and the like VTs, but real konsole" makes your question highly confusing. konsole is KDE. VT is the kernel virtual terminal which is actually what you are asking for, so don't complain that people don't understand you. You are not making it understandable.
--

-- another note
the resolution (i.e. your font size) changes (to small) as soon as the KMS module is loaded. This can be done by initramfs or later by init, depending on how you've configured it. I load i915 first thing in initramfs to have some consistency while booting.
--

You can try, as mentioned repeatedly here, using setfont (look in /usr/share/consolefonts for suggestions) and hopefully you find one that is big enough for you.

Alternatively, you could add "nomodeset" to your kernel command line. This should prevent KMS, but then X may or may not work.

It would help if you posted which graphics card you have and which driver you intend to use.
Cheers.

Offline ayla

  • User
  • Posts: 1.744
Re: konsole/terminal fontsize
« Reply #13 on: 2014/10/16, 10:46:27 »
Hi michaa7,

intel HD3000 grafics.

I played around a few hours ago. Sorry, my bootup is to fast, I cant see whether I have a change in fontsize when my system changes to KMS, my console-setup is showing exaktly the same as yours do. Changing it to 8x8 is resulting in smaller fonts, but not during boot, only the console fonts (tty) are getting tiny -or larger changing to 16x32 and wasn't that what you are asking for?

Changing /etc/default/grub
Quote
GRUB_GFXMODE=1980x1020
GRUB_PAYLOAD_LINUX=1980x1020
to other valid resolutions -according to vbeinfo- does only effekt the bootscreen itself, the fonts during boot are the same, as far as I can see in less then a second :) And yes, I have removed "quiet" from kernel command line.

hth
ayla

Offline michaa7

  • User
  • Posts: 2.304
Re: konsole/terminal fontsize
« Reply #14 on: 2014/10/17, 02:07:21 »
@michaa7,

What you want depends on which graphics card and driver you're using. If NVIDIA/AMD with proprietary drivers then the virtual console will stay a text mode (see note below).

In the meantime I found out the same fact with the help from guys at debianforum.de . And this is the answer of all my questions. Here on my WS I use nvidia prop. driver, on my laptop with AMD/ati I use OS driver. And when booting live.ISO, obviously it's used OS drivers.

I wasn't aware the prop. drivers don't support KMS, I even though the graphik drivers would only be loaded *shortly* befor switching to X. So I the whole time was looking for a non existing setting. It's the prop. drivers which stay in text mode as you say. And that's how I like it, but didn't know how this worked.

...

Quote
-- side note
saying "not xterm and the like VTs, but real konsole" makes your question highly confusing. konsole is KDE. VT is the kernel virtual terminal which is actually what you are asking for, so don't complain that people don't understand you. You are not making it understandable.

Thanks for clarifying this. Yes, I was confused about the terminology, and I thought VT refers to all the various terminals running in X. Now I learn VT is the one I called the "real terminal". OTOH, I made it clear that what I was looking for was to understand what causes the change form big to small fonts *during boot*, *after loding the kernel*, so, yes, my terminology was confusing, but "booting" and "loding kernel" should be clear. Anyway thanks for the side note!
--
Quote
-- another note
the resolution (i.e. your font size) changes (to small) as soon as the KMS module is loaded. This can be done by initramfs or later by init, depending on how you've configured it. I load i915 first thing in initramfs to have some consistency while booting.
--

Yes, now I am aware that it was not some font setting I was searching for but to understand what causes the resoulution change. That's clear now.

Quote
You can try, as mentioned repeatedly here, using setfont (look in /usr/share/consolefonts for suggestions) and hopefully you find one that is big enough for you.

Yes, now it is clear that using non-prop. drivers I need to change fonts (which I don't with the nvidia driver).

Quote
Alternatively, you could add "nomodeset" to your kernel command line. This should prevent KMS, but then X may or may not work.

Quote
It would help if you posted which graphics card you have and which driver you intend to use.
Cheers.

Here, were I have the font size I like, I use the nvidia proprietary driver. Obviously on the same HW I have different font size when booting a live.ISO . This was the cause for my confusion, as I didn't relate it to the drivers.

Now it's clear. Thanks to you, thanks to all.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake