Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] Sound card issues after recent upgrade  (Read 2161 times)

Archie

  • Guest
[EN] [SOLVED] Sound card issues after recent upgrade
« on: 2016/07/07, 16:30:46 »
I have been running siduction for about a month now, and everything has been great! However, 3 days ago after running a dist-upgrade, I ran into some issues with pulseaudio/alsa. I first noticed that I had no sound coming from the headphone jack. Then, I tried hdmi, but found I couldn't change the audio device, as no sound cards are available for configuration. As well as this, alsamixer only shows the master control. I have a Lenovo B590, with standard intel hardware. From 'lspci -vvv':

Code: [Select]
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: Lenovo 7 Series/C210 Series Chipset Family High Definition Audio Controller
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 28
    Region 0: Memory at f0610000 (64-bit, non-prefetchable) [ size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

The laptop's internal speakers still work perfectly.
During the update, various pulsaudio packages were upgraded, and afterwards I removed an 'obsolete' package (using synaptic). Silly me didn't check what it was first, and I have a felling that this had something to do with it.

Help would be much appreciated... many thanks,
                                                           Archie  8)

EDIT: Codetags zur besseren Lesbarkeit gesetzt (bluelupo, Moderator)
« Last Edit: 2016/07/08, 16:22:56 by Archie »

Offline musca

  • User
  • Posts: 725
  • sid, fly high!
Re: Sound card issues after recent upgrade
« Reply #1 on: 2016/07/07, 16:54:58 »
Hello Archie,

pulseaudio 9.0 introduced a new recommends: pulseaudio-module-udev.
Issue will be solved with
Code: [Select]
apt-get dist-upgrade pulseaudio-module-udev+
greetings
musca
β€žEs irrt der Mensch, solang er strebt.β€œ  (Goethe, Faust)

Offline absolut

  • User
  • Posts: 455
Re: Sound card issues after recent upgrade
« Reply #2 on: 2016/07/07, 19:34:52 »
i am able to confirm both, the issue as well as the solution!

Archie

  • Guest
Re: [SOLVED] Sound card issues after recent upgrade
« Reply #3 on: 2016/07/08, 16:24:22 »
Thank you. I have marked the thread as solved.

                                                                    Archie 8)