Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved]Latest updates and now accented letter aren't working  (Read 1256 times)

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
So with the same keyboard layout (tried changing it with others) on non-KDE applications the accented letters are not printed.
Instead with any KDE application they are printed but with Firefox or Thunderbird, Electron apps when I do Alt+e as example nothing happens.

I have no idea where to check in the system as it is very strange.


EDIT:I reopened the thread and marked it as solved, , hendrikL
« Last Edit: 2024/03/22, 13:31:08 by hendrikL »

Offline minixjr

  • User
  • Posts: 14
Re: Latest updates and now accented letter aren't working
« Reply #1 on: 2024/02/14, 12:04:11 »
There was an update of xkeyboard-config, maybe it have something to do with your problems?
But I don't use accented letters, so I don't know if this is the reason.
Quote
xkeyboard-config (2.41-2) unstable; urgency=medium

  * Several old remappings got removed between 2.38..2.41, so beware for
    instance if you relied on "dvorak" variant with us layout. (#1063725)

  * The extended variant for Greek was removed, as it was actually less
    extended than the "basic" variant. (#1063702)

 -- Timo Aaltonen <tjaalton@debian.org>  Tue, 13 Feb 2024 09:57:30 +0200

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Latest updates and now accented letter aren't working
« Reply #2 on: 2024/02/14, 13:05:06 »
I checked those tickets and I don't see anything that could case those problems.

The package involved is https://packages.debian.org/sid/xkb-data

My /etc/default/keyboard

Code: [Select]
# KEYBOARD CONFIGURATION FILE
   2   │
   3   │ # Consult the keyboard(5) manual page.
   4   │
   5   │ XKBMODEL="pc105"
   6   │ XKBLAYOUT="gb"
   7   │ XKBVARIANT="extd"
   8   │ XKBOPTIONS="lv3:ralt_switch,compose:lwin,terminate:ctrl_alt_bksp"
   9   │
  10   │ BACKSPACE="guess"

I tried also dpkg-reconfigure keyboard-configuration the issue is strange as Qt application works but not the others.
I change that layout manually as root at every update to add the accented letter since years.

Code: [Select]
GTK_IM_MODULE=ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
rules:      evdev
model:      pc105
layout:     gb
variant:    extd
options:    lv3:ralt_switch,eurosign:5,grp:lalt_lshift_toggle,compose:rwin,grp_led:scroll,altwin:meta_alt
« Last Edit: 2024/02/14, 18:42:34 by Mte90 »

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: Latest updates and now accented letter aren't working
« Reply #3 on: 2024/02/15, 16:54:33 »
What kind of accent do you aspect to see if you press <Alt>+<e> (it doesn't work here either)?

Code: [Select]
~$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
hhl@localhost:~$ é è ê

I use the accent and then the letter to print them out like, "Ê ê or é, è", and this works also with in GTK-Applications. But that are mostly French accents.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=994026 or .... is that the problem?

Edit, Edit: alt+e should be the € euro sign? I press <Alt Gr>+<e> for it and <Alt gr>+<q> for @, but as you see, it is a German keyboard.

.
« Last Edit: 2024/02/15, 17:18:01 by hendrikL »

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Latest updates and now accented letter aren't working
« Reply #4 on: 2024/02/16, 10:19:32 »
I should get the  é but doesn't work.

From the ticket you mentioned `ralt_switch_multikey` doens't exists anymore and that part didn't changed.
The issue is with any keyboard so it is something elsewhere, considering that on QT works.
I was thinking that is ibus but I have no clue.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: Latest updates and now accented letter aren't working
« Reply #5 on: 2024/02/16, 13:34:51 »
Did you try to type first the accent like ´  (only one time, if typing that accent a second time it should be shown like here) and then the e for example, the outcome should be é.

Maybe you need to reconfigure your keyboard to no "dead keys" or similar.

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Latest updates and now accented letter aren't working
« Reply #6 on: 2024/02/16, 13:39:33 »
I am not using a keyboard with dead keys but your trick to press the ` symbol works.

Wondering how I can change it to the alt button as behavior.

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Latest updates and now accented letter aren't working
« Reply #7 on: 2024/02/16, 14:21:59 »
So tried with:
Code: [Select]
setxkbmap -option compose:ralt
setxkbmap -option compose:lwin

The first one should set the right alt button and doesn't work, but the second one let's to use the ` and also the alt on Qt apps.

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Latest updates and now accented letter aren't working
« Reply #8 on: 2024/02/19, 16:52:27 »
So now seems that works everywhere but I didn't nothing, just some electron apps aren't detecting the accented letters with alt.