Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Vorsicht, etliche Pakete sollen gelöscht werden. Attention ...  (Read 4010 times)

Offline Jan46

  • User
  • Posts: 15
[DE] Re: Vorsicht, etliche Pakete sollen gelöscht werden. Attention ...
« Reply #15 on: 2024/06/11, 17:58:53 »
@dibi
I did the dist-upgrade on my other machine again and this time all went well.

BTW:
after a reboot the active screen windows are no longer remembered!

Offline samoht

  • User
  • Posts: 483
Quote
after a reboot the active screen windows are no longer remembered!
Please also  see
https://forum.siduction.org/index.php?topic=9365.msg74517#msg74517

Offline harley-peter

  • User
  • Posts: 1.038
Ich wollte heute nach einem längeren Urlaub meine Systeme mit einem apt update && apt full-upgrade upgraden und bekomme ebenfalls die Meldung, dass viele Pakete gelöscht werden sollen:
Code: [Select]
REMOVING:
  audacious            libqt6network6t64        libqt6test6t64                            libqt6wlshellintegration6   qt6-gtk-platformtheme
  audacious-plugins    libqt6opengl6t64         libqt6waylandclient6                      libqt6xml6t64               qt6-image-formats-plugins
  calibre              libqt6openglwidgets6t64  libqt6waylandcompositor6                  mkvtoolnix-gui              qt6-qpa-plugins
  calibre-bin          libqt6printsupport6t64   libqt6waylandeglclienthwintegration6      polkitd-pkla                qt6-wayland
  insserv              libqt6qml6               libqt6waylandeglcompositorhwintegration6  pyqt6-dev-tools             startpar
  libfilezilla43t64    libqt6qmlmodels6         libqt6webchannel6                         python3-pyqt6               sysv-rc
  libgnustep-base1.29  libqt6quick6             libqt6webenginecore6                      python3-pyqt6.qtqml         sysv-rc-conf
  libpoppler-qt6-3t64  libqt6quickwidgets6      libqt6webenginecore6-bin                  python3-pyqt6.qtquick       sysvinit
  libqt6dbus6t64       libqt6sql6t64            libqt6webenginequick6                     python3-pyqt6.qtsvg         wireshark
  libqt6gui6t64        libqt6svg6               libqt6webenginewidgets6                   python3-pyqt6.qtwebchannel
  libqt6multimedia6    libqt6svgwidgets6        libqt6widgets6t64                         python3-pyqt6.qtwebengine

Ohne entsprechende Neuinstallationen. Auf meinem neueren Rechner sind es zwar nicht ganz so viele aber immer noch 23 Pakete.

Ein apt upgrade gibt mir eine ganz seltsame Fehlermeldung:
Code: [Select]
apt update && apt upgrade
OK:1 https://packages.siduction.org/extra unstable InRelease                                                                                         
OK:2 https://packages.siduction.org/fixes unstable InRelease                                                                                         
OK:3 https://linux.teamviewer.com/deb stable InRelease                                                                                               
OK:5 https://brave-browser-apt-release.s3.brave.com stable InRelease                                                                                 
OK:6 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                           
OK:7 http://ftp.de.debian.org/debian unstable InRelease                                                                                               
OK:8 https://apt.enpass.io stable InRelease                                                                                                           
OK:9 https://wire-app.wire.com/linux/debian stable InRelease                                                                                         
Ign:4 https://repo.vivaldi.com/stable/deb stable InRelease                                         
OK:10 https://www.deb-multimedia.org sid InRelease
OK:11 https://repo.vivaldi.com/stable/deb stable Release
Aktualisierung für 698 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Unsatisfied dependencies:
 gnustep-base-runtime : Hängt ab von: gnustep-base-common (= 1.30.0-4) aber 1.29.0-7 soll installiert werden
 libgnustep-base1.30 : Hängt ab von: gnustep-base-common (= 1.30.0-4) aber 1.29.0-7 soll installiert werden
Error: Beschädigte Pakete

Ist da irgendeine Transition im Gange oder wie bekomme ich meine Kisten wieder aktuell?

Offline edlin

  • User
  • Posts: 595
Eigentlich sollte wieder Ruhe sein. Was sagt denn der neue Solver dazu?
Code: [Select]
apt update && apt --solver 3.0 full-upgrade
edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline harley-peter

  • User
  • Posts: 1.038
Neben vielen Updates folgendes:
Code: [Select]
Installing dependencies:
  firmware-carl9170    libgtkmm-4.0-0            libpython3.12-dev     libqt6sql6              libxcb-cursor0
  libaudgui6           libjxl-gdk-pixbuf         libpython3.12t64      libqt6test6             linux-headers-6.9.7-1-siduction-amd64
  libaudqt3            libjxl0.9                 libqt6dbus6           libqt6webchannelquick6  linux-image-6.9.7-1-siduction-amd64
  libavif-gdk-pixbuf   libnghttp3-9              libqt6gui6            libqt6widgets6          python3.12-dev
  libcairomm-1.16-1    libngtcp2-16              libqt6network6        libqt6xml6              systemd-cryptsetup
  libfilezilla44       libngtcp2-crypto-gnutls8  libqt6opengl6         libroc0.4
  libglibmm-2.68-1t64  libpangomm-2.48-1t64      libqt6openglwidgets6  libshaderc1
  libgnustep-base1.30  libplacebo349             libqt6printsupport6   libsigc++-3.0-0

Vorgeschlagene Pakete:
  linux-doc-6.9

Not upgrading:
  libc-dev-bin  libc6  libc6-dev  systemd-sysv  sysv-rc-conf

REMOVING:
  libfilezilla43t64    libqt6gui6t64      libqt6openglwidgets6t64  libqt6test6t64                            libqt6widgets6t64
  libgnustep-base1.29  libqt6network6t64  libqt6printsupport6t64   libqt6waylandeglclienthwintegration6      libqt6xml6t64
  libqt6dbus6t64       libqt6opengl6t64   libqt6sql6t64            libqt6waylandeglcompositorhwintegration6  polkitd-pkla

Summary:
  Upgrading: 693, Installing: 37, Removing: 15, Not Upgrading: 5

Auf meinem neuen Rechner sind es nicht ganz so viele, die neu installiert bzw. gelöscht werden sollen aber das Bild sieht ähnlich aus.
Vor einiger Zeit wurden viele Pakete durch ....t64 Versionen ersetzt. Geht das Ganze jetzt wieder rückwärts (Beispiel  libqt6dbus6t64)?
Code: [Select]
apt policy libqt6dbus6t64
libqt6dbus6t64:
  Installiert:           6.4.2+dfsg-21.1+b1
  Installationskandidat: 6.4.2+dfsg-21.1+b1
  Versionstabelle:
 *** 6.4.2+dfsg-21.1+b1 100
        100 /var/lib/dpkg/status
root@master:/home/peter# apt policy libqt6dbus6
libqt6dbus6:
  Installiert:           (keine)
  Installationskandidat: 6.6.2+dfsg-9
  Versionstabelle:
     6.6.2+dfsg-9 500
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages

Offline edlin

  • User
  • Posts: 595
Das sieht doch schon viel besser aus. Neuere libs haben das t64 nicht mehr im Namen. Das ist Anfangs etwas irritierend. Beispiel bei dir: libfilezilla43t64 wird durch die neue Version libfilezilla44 ersetzt. Und libqt6dbus6t64 ist jetzt wieder libqt6dbus6.
Anwendungen werden ja keine mehr ins Grab gezerrt, so dass ich den Vorschlag vom Solver 3 akzeptieren würde. polkitd-pkla ist auch nur ein veraltetes Paket, welches nicht mehr benötigt wird.
Nach dem Upgrade kannst du ja in Ruhe schauen, warum noch ein paar Pakete zurückgehalten werden.

edlin

Nachtrag: Der Bösewicht sollte polkitd-pkla sein. Wenn du das Paket nicht nutzt, dann einfach löschen und die restlichen zurückgehaltenen Pakete sollten aktualisiert werden.
« Last Edit: 2024/07/05, 13:27:15 by edlin »
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline michaa7

  • User
  • Posts: 2.327
Eventuell zunächst ein
Code: [Select]
apt install apt weil die neueste Version kleinere Bugfixes für den neuen solver hat, nichts superkritisches aber vielleicht wichtig für ein paar corner cases. Danach wie von edlin vorgeschlagen das full-upgrade mit dem neuen solver.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline harley-peter

  • User
  • Posts: 1.038
Das Upgrade mit dem neuen Solver hat geklappt, alles scheint normal zu funktionieren. Danke für die Unterstützung.

Offline Isegrimm666

  • User
  • Posts: 110
[Off-Topic]

Moin ...

Ich habe das mit dem solver noch nicht so ganz begriffen. Wenn ich edlins Zeile eingebe, sehe ich - in der Ausgabe - keinen Unterschied zu einer Ausgabe ohne solver.

Bisher dachte ich, es wäre eine 'upgrade-simulation' und eine Quittung der Abfrage am Ende ([J/n]) würde dieses 'test-upgrade' beenden ... auch wenn ich mit 'J' antworte.

Is'n Denkfehler, hmm?

Offline edlin

  • User
  • Posts: 595
@Isegrimm666
Zum neuen Solver 3.0 kannst du dich unter https://blog.jak-linux.org/2024/05/14/solver3/ einlesen, aber ich denke, das hilft dir nicht weiter.
Im Prinzip kannst du
Code: [Select]
apt update && apt --solver 3.0 full-upgrade genau wie
Code: [Select]
apt update && apt full-upgrade benutzen. Und nein, es ist keine Simulation! Und in „friedlichen“ Zeiten (es sollen keine Pakete gelöscht werden) wirst du wohl auch keine Unterschiede feststellen.
Insbesondere unter Unstable haben wir regelmäßig die Situation, dass eine Reihe von Paketen entfernt werden sollen, darunter auch Pakete, die essentiell für das System sind oder Anwendungen, die wir ungern gehen lassen wollen. Bisher haben wir das Problem entweder mit apt upgrade umschifft, haben aptitude benutzt, haben eine händische Lösung versucht oder, bei Unachtsamkeit, unser System ruiniert.
Und u. a. hier greift wohl der neue Solver. Ich nutze ihn schon ein paar Wochen, auch wenn er noch nicht fertig ist. Es handelt sich schlicht um neue Algorithmen, die im Hintergrund versuchen, die bestmögliche Lösung für eine Aktualisierung zu liefern. Nach meinen bisherigen Beobachtungen gelingt es mit dem neuen Solver, Kollateralschäden zu vermeiden. Es werden in der Regel nur Pakete zum Löschen vorgeschlagen, die keine essentiellen Pakete oder Anwendungen mit ins schwarze Loch ziehen. In diesen Fällen werden halt ein paar Aktualisierungen zurückgehalten. Es ergibt sich dann so eine Situation zwischen upgrade und full-upgrade.
Wenn du die Vorschläge mit „J“ bestätigst, wird genau so die Aktualisierung durchgeführt. Natürlich muss man sich darüber im Klaren sein, dass der Solver noch in der Entwicklung ist und die Ausgaben kritisch beäugen (das machen wir aber ohnehin, hoffe ich).
Bisher sind meine Erfahrungen positiv. Wenn es weiter so funktioniert, dann sollten damit Probleme wie „ich habe mein KDE gelöscht“ hoffentlich eines Tages der Vergangenheit angehören.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Isegrimm666

  • User
  • Posts: 110
bei mir zickt noch ein Paket:

Code: [Select]
freecad: error while loading shared libraries: libpyside2.cpython-311-x86_64-linux-gnu.so.5.15: cannot open shared object file: No such file or directory

Hat jemand 'ne Idee?

Offline michaa7

  • User
  • Posts: 2.327
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline Isegrimm666

  • User
  • Posts: 110
Danke ...

Also noch warten *g

Offline hasan

  • User
  • Posts: 25
apt update && apt --solver 3.0 full-upgrade

alles in ordnung

danke @edlin!

Offline edlin

  • User
  • Posts: 595
@Isegrimm666
Habs gerade probiert und festgestellt, dass FreeCAD wieder funktioniert. Kannst also nach einem full-upgrade wieder den Restsonntag für deine Konstruktionen nutzen.

Schönes Restwochenende, edlin

Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates