Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] System Went down  (Read 722 times)

Offline Ze_Mind

  • User
  • Posts: 8
[EN] System Went down
« on: 2024/06/21, 15:30:33 »
Sorry this isn't Siduction, but this is just Debian Testing.

Running Sparky. fork of Debian Testing Branch. Latest version.

I had to install a dependency, so after that, everything just started to go wonky. Some icons weren't on my desktop panel. Some programs just plain stopped working.

So I restart my system, thinking that might fix it.

But after restart, it took me to the login screen. I never saw this, as I set it to login automatically. I tried to put in my username and password, did flat out nothing. Didn't print out an error that I mistyped it.

I then thought of going into TTY1. All I see is a blinking "_" So I could never log into it.

I DO have timeshift backups, but the thing is, I cant even get into the system. TTY1 or TTY2.

If any of you can help with this, I'd be grateful. I might just need to reinstall. I've been wanting to for ages, but been pushing it off until now.

I looked around the net, there's nothing that I find that can help. :(

Edit: I'm just running Siduction off a USB stick. So I haven't written anything to the M.2 SSD yet. (been wanting to try it out)

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 1.000
Re: System Went down
« Reply #1 on: 2024/06/21, 16:20:29 »
First of all. there are more tty than 1 and 2.

Second you can try to chroot into your system with the chroot-helper, click the icon.
Then maybe you can start a timeshift rollback, or look into the apt log what has been removed or changed so you can undo it.
Sorry never used testing, so I can't help you much!

Offline Ze_Mind

  • User
  • Posts: 8
Re: System Went down
« Reply #2 on: 2024/06/21, 16:51:25 »
My friend did say this:

Quote
I recently had a MESA driver update go wrong and my system booted into a blank screen. I was able to get to a command-line login prompt with the following:

At the grub menu hit e to edit the boot parameters.

Add a 3 to the end of the line that starts with linux.

Hit F10 to boot with the modified parameters.

Maybe this will help you get to Timeshift (I've never used this).

And I tried TTY1, 2, 3, 4.. all are the same.

Offline ro_sid

  • User
  • Posts: 261
Re: System Went down
« Reply #3 on: 2024/06/21, 17:16:31 »
I have experienced such a situation, when the video-driver could not handle my video-card and the "proprietary" one was not working properly (any longer) [Nvidia: nouveau vs. nvidia-proprietary], and also when the proprietary one was "too old" to properly support my video-card. Any such problem?

Anyhow, (successfully) booting a live system - Siduction, but in your case it might also be a Debian-Live or even Debian-Rescue - should enable you to analyze your situation and also to (re-)install packages.

Good luck!

Offline Ze_Mind

  • User
  • Posts: 8
Re: System Went down
« Reply #4 on: 2024/06/21, 17:23:51 »
 I just looked at the apt logs. At /var/log/apt/term.log (on my M.2 SSD)

I found something freaky. I deleted everything having to do with KDE. I had no knowledge of this.

Well, guess it's time to back everything up. and reinstall.