Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  Upgrade from 2014.1?  (Read 2056 times)

Offline jaegermeister

  • User
  • Posts: 222
Upgrade from 2014.1?
« on: 2016/11/04, 01:36:04 »
Hello,

I was away from siduction for several months (last time around summertime), by then my box (KDE4, 2014.1) still showed a viable path with du. Till that time just did some manual packages updates (mostly CLI stuff and some GUI programs).

Today I finally switched on the machine in its new "office" and du shows a much different story:

Code: [Select]
dolphin4 : Rompe: dolphin (< 4:15.08) ma la versione 4:4.14.2-1 sta per essere installata
 kactivitymanagerd : Rompe: plasma-desktop (< 4:5.8) ma la versione 4:4.11.13-2.1 sta per essere installata
 libkf5networkmanagerqt6 : Rompe: plasma-nm (<= 4:5.6~) ma la versione 0.9.3.6-1+b1 sta per essere installata
 libkf5screen7 : Rompe: kscreen (< 4:5.8) ma la versione 1.0.2.1-1 sta per essere installata
 libkworkspace5-5 : Rompe: plasma-desktop (< 4:5.8) ma la versione 4:4.11.13-2.1 sta per essere installata
 libtaskmanager6 : Rompe: plasma-desktop (< 4:5.8) ma la versione 4:4.11.13-2.1 sta per essere installata
 oxygen-sounds : Rompe: plasma-desktop (< 4:5.8) ma la versione 4:4.11.13-2.1 sta per essere installata
 polkit-kde-agent-1 : Rompe: plasma-desktop (< 4:5.8) ma la versione 4:4.11.13-2.1 sta per essere installata
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.

I am afraid I lost the train to Plasma5; catching up through the forum I read that there's also SDDM transition from lightdm and some other (unknown) manual config to do.

1. is there an upgrade guide for the manual interventions (besides fixing apt conflicts) to arrive at current version from 2014.1 or 2015.1?
2. considering 2016.1 is almost one year old, would it be better to wait for some 2017.1 (I don't know if it's due yet) and do a fresh install?

THX
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.749
Re: Upgrade from 2014.1?
« Reply #1 on: 2016/11/04, 06:24:13 »
Right now we are in the middle of a transition of Qt, so with KDE, stuff gets removed. Other than that, you should be able to upgrade, if your status is ~ 1 year old. Make sure you update apt and dpkg and maybe perl manualy before doing the dist-upgrade.


Should you prefer a fresh install, come to IRC and we will hand you a recent build of the  KDE flavour.

Offline jaegermeister

  • User
  • Posts: 222
Re: Upgrade from 2014.1?
« Reply #2 on: 2016/11/04, 13:39:33 »
Thank you very much for the useful explanation!


Maybe, considering all the sddm and further changes, it would be better going for a fresh install.
I think it would be best to reinstall after this qt transition is over, so that I can install packages without any trouble: is there some rough timeline available about this?


Also, when qt transition is over I would happily come to IRC to fetch the latest KDE flavour, anyway, just for the sake of curiosity, is there a plan about when next release should be due?


THX
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.749
Re: Upgrade from 2014.1?
« Reply #3 on: 2016/11/04, 13:44:16 »
The qt-transition might last another few days. If you visit us at IRC after the transition, you can have a build from the same day. A regular release should (™) be released before the year is over. Tomorrow the transition-freeze for Stretch will set in, so at least there is no more transitions block us.

Offline jaegermeister

  • User
  • Posts: 222
Re: Upgrade from 2014.1?
« Reply #4 on: 2016/11/04, 14:14:01 »
So if this means December for release, I can live with that for this month and a half.


It's not to avoid the work (which would be just postponed) but rather to benefit of an officially supported release without daily compile mishaps.
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------