Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] KDE does not remember last dektopsession  (Read 4490 times)

Offline Jan46

  • User
  • Posts: 11
[EN] KDE does not remember last dektopsession
« on: 2023/10/27, 12:35:00 »
Since several updates KDE does not remember the last desktopsession and starts with a clean screen.

I had some other problems as well  so decided to do a fresh install with
siduction-2023.1.1-Standing_on_the_Shoulders_of_Giants-kde-amd64-202309091853.iso

Unfortunately this did not solve this so probably this is a bug in KDE or is it fixable?

Offline edlin

  • User
  • Posts: 539
Re: KDE does not remember last dektopsession
« Reply #1 on: 2023/10/27, 12:41:49 »
Wayland or X11? X11 works fine for me and restore the desktop.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #2 on: 2023/10/27, 18:00:57 »
X11,

I have a 3 monitor setup, the left-one used as dolphin display in portrait mode, middle-one landscape and right-one for a konsole window, gkrellm window and kcalc. But every time i start the computer i have to open all of the above programs.
It used to work months ago but afer updates......  and the fresh install doesn't help either.

Offline thomv

  • User
  • Posts: 20
Re: KDE does not remember last dektopsession
« Reply #3 on: 2023/10/28, 18:57:34 »
Maybe a silly question: did you check in kde-settings menu to open the apps that were open when logging out?
(In German it is: "Starten und Beenden" > "Arbeitsflächensitzung" > "Sitzungswiederherstellung": check "Bei letzter Abmeldung geöffnete")

Offline eriefisher

  • User
  • Posts: 264
Re: KDE does not remember last dektopsession
« Reply #4 on: 2023/10/28, 19:21:04 »
I don't use KDE but with XFCE4 I can save sessions as a default in the settings or prompt on logout/reboot. I assume KDE has something similar. I believe the process is universal across desktops via free desktop but the user interaction part is as per environment used.

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #5 on: 2023/10/29, 14:14:44 »
By default the KDE setting is remember the last session and start the applications.
There is also a possibility to save the current applications by hand.
I tried both but no result, probably the KDE-crew is too busy with KDE/Plasma-6 in stead of delivering proper updates for KDE/Plasma-5.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 929
Re: KDE does not remember last dektopsession
« Reply #6 on: 2023/10/29, 17:03:03 »
Well, I tried it within a wayland session and the only program which was remembered was FFox, then I switched to X11 and most of the open programs were remembered.
So I think it is a wayland vs X11 thing.

Do you use wayland or X11? <-- read first before typing, sorry I see.

And no, I use wayland and always start with an empty session, I did this for testing only, and I only have a laptop to test it with only the build in monitor.

You have a more complex setup, maybe it is time for you to wright a bug report!

Offline edlin

  • User
  • Posts: 539
Re: KDE does not remember last dektopsession
« Reply #7 on: 2023/10/29, 18:03:30 »
That's one reason I haven't switched to Wayland yet; I like to start with a default setup of applications that launch on different workspaces. X11 handles this well in most cases. FF also starts with multiple windows and the tabs open.

 @Jan46: Can you test a simple setup with a single monitor? Under X11 Firefox, Konsole, Okular, Audacity, KiCad, Gimp etc. should be restored.

That would at least tell us if it's a general problem with your system, or if the problem is only with the multi-monitor setup.


edlin


 
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #8 on: 2023/10/29, 21:53:22 »
Sorry for my answer where i said I'm using X, i thought so because i saw more X11 than Wayland installed when looking with apt search. Now i did:

inxi -G
Graphics:
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel
  Display: wayland server: X.Org v: 1.23.2.2 with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 resolution: 1: 1024x1280~60Hz 2: 1680x1050~60Hz
    3: 1024x1280~60Hz
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.2.1-1 renderer: Mesa Intel HD
    Graphics 530 (SKL GT2)

This makes me think i'm using Wayland.

Is that a game changer and how can i switch to X11?

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #9 on: 2023/10/29, 22:16:46 »
@edlin,

I did a restart of the system with only one monitor connected and in the settings only one monitor chosen.
When i close the system with konsole and dolphin active i both have to restart when i restart the system. Nothing is remembered.
Hope that helps.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 929
Re: KDE does not remember last dektopsession
« Reply #10 on: 2023/10/29, 22:23:35 »
You can change to Xorg if you have "kwin-x11" installed!

Then you can choose in sddm between a x11 or wayland session!

There is a dropdown menu where you can select.

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #11 on: 2023/10/30, 20:44:12 »
I did an update before i wanted to install kwin-x11 and that resulted in an atomatic install of kwin-x11as one of the updates.
so far so good.

When i try to start sddm in a command window i get this:

sddm
[20:30:41.426] (II) DAEMON: Initializing...
[20:30:41.444] (II) DAEMON: Starting...
[20:30:41.445] (II) DAEMON: Logind interface found
[20:30:41.447] (II) DAEMON: Adding new display...
[20:30:41.448] (II) DAEMON: Loaded empty theme configuration
[20:30:41.448] (EE) DAEMON: Failed to open VT master: Toegang geweigerd
[20:30:41.448] (EE) DAEMON: Failed to create xauth file
Afgebroken

I thought that i maybe have to do this as root so i logged in as root in the command window and started sddm, the screen became black and after a while an arrow appeared, i could move the arrow with the mouse but that's it. I had to restart the computer.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 929
Re: KDE does not remember last dektopsession
« Reply #12 on: 2023/10/31, 06:35:11 »
Ähm, how do yo login in your plasma session? Normally you should see sddm where you have to fill in your username and password!
And under the password dialog, if you use our stock sddm theme  left there's an arrow down, klick on it and you can choose between different sessions. There choose plasma-x11 before login!

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 929
Re: KDE does not remember last dektopsession
« Reply #13 on: 2023/10/31, 08:01:46 »
PS. I have forgotten to say that I think that a login-manager session was/is running, so no need to start a second instance of it.

If you want to start a plasma session via tty/getty, then please run as root:

Code: [Select]
~# systemctl isolate multi-user.target
With that comand, you change to the former called runlevel 3
logout and login as $user (or if you su -, only logout)

Code: [Select]
~$ startplasma-x11

Offline Jan46

  • User
  • Posts: 11
Re: KDE does not remember last dektopsession
« Reply #14 on: 2023/10/31, 14:38:09 »
Okay, what happened i don't know but when i logged in today yesterdays desktopsession appeared. So i must have done something to change the desktopmanager to X11.

inxi -G
Graphics:
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel
  Display: x11 server: X.Org v: 1.21.1.9 with: Xwayland v: 23.2.2 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 resolution:
    1: 1024x1280~60Hz 2: 1680x1050~60Hz 3: 1024x1280~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.2.1-1 renderer: Mesa Intel HD
    Graphics 530 (SKL GT2)

Although i see Xwayland in the above...

@hendrikL
Thank you for your support.
When i login i only have to fill in my password i dont see an arrow down only one on the right side of the password and if i click that one i'm logged in.

Another nice thing is that in LibreOffice Calc i now get a comma when i type a dot in the numerical part of the keyboard. This was not the case in the Wayland desktopmanager.

Overall i am happy now.
There is only one problem left but i will start a new topic for that in the hardware section.