Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: plasma5.24 + conky(autostart)  (Read 478 times)

Offline unklarer

  • User
  • Posts: 674
plasma5.24 + conky(autostart)
« on: 2022/02/13, 12:07:48 »
Moin, moin   :)

Mit plasma5.24 startet kein Conky aus dem autostart.
Seit ein paar Tagen suche ich nach der Ursache, finde jedoch keine Lösung. Weiß ein Wissender mehr?   ;D

Die vorgeschlagene -q - Funktion(ist mir unlogisch) funktioniert jedoch bei genau einem Conky von drei. Und, das später zusätzliche -d bewirkt null, auch, wenn ich sie versuche händisch zu starten.

Hier zu sehen mein Script und der Eine, der startet:
Code: [Select]
ps aux | grep conky
unklarer  223745  0.0  0.0   6804  2208 ?        S    11:28   0:00 /bin/bash /home/unklarer/.config/old-autostart-scripts/conkystart.sh
unklarer  225620  0.8  0.4 173048 32956 ?        Sl   11:28   0:00 conky -q -c /home/unklarer/.conky/ragaEUR/ConkyCentrc10
unklarer  235961  0.0  0.0   6244  2424 pts/1    S+   11:29   0:00 grep conky

Es gibt eine Desktop-Konfigurationsdatei in ~/.config/autostart, die auf das Script verweißt und vom System angelegt ist.
Das war auch mein erster Ansatz, dass KDE wieder mal die PATH'e verändert hat. Aber, warum der Eine und die Anderen nicht.   :P
Zumal ich im Debug-Modus von Conky keine Fehler erhalte:

Code: [Select]
conky -d -c /home/unklarer/.conky/rumit/rumit_conky10 -DD &
[1] 249284
unklarer@plasma:~$ DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/conky.cc:2555]: reading contents from config file '/home/unklarer/.conky/rumit/rumit_conky10'
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:401]: enter init_X11()
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:482]: Fixed xinerama area to: 0 0 1920 1080
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:433]: leave init_X11()
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:642]: enter init_window()
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:482]: Fixed xinerama area to: 0 0 1920 1080
conky: desktop window (1e00019) is subwindow of root window (70e)
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:621]: Found ARGB Visual
conky: window type - normal
conky: drawing to created window (0x3200002)
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/x11.cc:992]: leave init_window()
conky: drawing to double buffer
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/core.cc:2045]: no templates to replace
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/core.cc:686]: Adding $cpu for CPU 1
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/core.cc:686]: Adding $cpu for CPU 2
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/core.cc:686]: Adding $cpu for CPU 3
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/core.cc:686]: Adding $cpu for CPU 4
DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/linux.cc:1441]: parsed hwmon args: '0' 'temp' 1 1,000000 0,000000

DEBUG(0) [/build/conky-kqhypt/conky-1.11.6/src/linux.cc:1285]: open_sysfs_sensor: dir=/sys/class/hwmon/ dev=hwmon0/device type=temp n=1

conky: forked to background, pid is 249285

DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky-kqhypt/conky-1.11.6/src/fonts.cc:94]: setting up fonts
^C
[1]+  Fertig                  conky -d -c /home/unklarer/.conky/rumit/rumit_conky10 -DD
« Last Edit: 2022/02/15, 17:11:06 by unklarer »

Offline whistler_mb

  • User
  • Posts: 186
Re: plasma5.24 + conky
« Reply #1 on: 2022/02/15, 13:22:17 »
Conky startet bei mir auch nicht mehr automatisch bei der Anmeldung.

Es ist mir bisher nur nicht wirklich aufgefallen, da ich den Rechner meist in den Standby schicke statt runterzufahren.

Wenn ich die in den Systemeinstellungen bei Starten und Beenden -> Autostart ->Anwendung hinzufügen den Pfad zum Script angebe, dann startet Conky nicht. Wenn ich es als Anmeldungs-Skript hinzufüge, dann ist nach dem Neustart der Eintrag wieder weg.

Offline unklarer

  • User
  • Posts: 674
Re: plasma5.24 + conky(autostart)
« Reply #2 on: 2022/02/15, 17:21:05 »
^Schau mal nach, dein Script hat das System bestimmt nach ~/.config/old-autostart-scripts verschoben und unter ~/.config/autostart eine desktop-Konfigurationsdatei mit Verweis nach old... erstellt.

Warum es dann immer noch ein VZ ~/.config/autostart-scripts gibt, was nicht genutzt wird, versteht wahscheinlich nur kde.   :P

In archlinux ist das übrigens auch so, mit dem Unterschied, dass sich dort die Conky's wenigstens per Hand starten lassen.

Offline unklarer

  • User
  • Posts: 674
Re: plasma5.24 + conky(autostart)
« Reply #3 on: 2022/02/18, 17:12:21 »
Nach täglichem d_u funktioniert es hier wieder.   :D
Was im Einzelnen am Plasma-Desktop (Preining) beigetragen hat (Debian ist ja immer noch bei 5.23), kann ich nicht sagen.

Es bleibt aber dennoch erstmal eine Krücke, ist aber in archlinux mit conky12.2 zur Zeit auch nicht anders. Gemeint ist die nicht vorhandene Transparenz. Ich habe deshalb einen "Rahmen" 'drum gemacht, damit es wenigstens nach was aussieht.


« Last Edit: 2022/02/18, 18:05:15 by unklarer »