Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [gelöst]nouveau + googleearth  (Read 6383 times)

AnJo

  • Guest
[DE] [gelöst]nouveau + googleearth
« on: 2011/07/17, 20:33:04 »
Hallo zusammen,

habe für meine GeForce FX 5200 nun einmal den nouveau-Treiber probiert.
Funktioniert soweit auch alles ganz prima.
Auch googleearth startet ohne Fehlermeldungen. Zu sehen bekomme
ich aber nur einen blauen Ball mit ein paar gelben Linien.

Auch habe ich gelesen, dass googleearth mit nouveau nicht funktioniert !

Anderseits haben es Leute unter Fedora und Suse anscheinend doch geschafft.

Daher hier meine Frage ob es hier jemanden gibt der googleearth mit nouveau zum Laufen bekommen hat ?

Danke.

Gruß
AnJo

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
nouveau + googleearth
« Reply #1 on: 2011/07/17, 20:36:31 »
Du hast 32 oder 64Bit?
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

AnJo

  • Guest
[gelöst]nouveau + googleearth
« Reply #2 on: 2011/07/17, 20:43:15 »
64BIT

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
[gelöst]nouveau + googleearth
« Reply #3 on: 2011/07/17, 20:46:06 »
Also für 64Bit würdest Du den Inhalt von libgl1-mesa-dri-experimental in der 32bit version in /usr/lib32 benötigen, da GE ein 32Bit Programm ist.
Es könnten auch noch diverse Libs aus libgl1-mesa-glx in der 32Bit Version benötigt werden.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

AnJo

  • Guest
[gelöst]nouveau + googleearth
« Reply #4 on: 2011/07/17, 20:50:54 »
Danke towo !

Paket in der 32 Bit Version herunterladen...
...und dann weiter  :oops:

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
[gelöst]nouveau + googleearth
« Reply #5 on: 2011/07/17, 20:52:46 »
Entpacken und die libs nach /usr/lib32 kopieren.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

AnJo

  • Guest
[gelöst]nouveau + googleearth
« Reply #6 on: 2011/07/17, 20:58:49 »
Danke nochmal !

Werde es probieren. Info wenn es geklappt hat folgt.

Gruß
AnJo

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
[gelöst]nouveau + googleearth
« Reply #7 on: 2011/07/17, 21:01:46 »
Ich gehe mal davon aus, daß 3D im System an sich funktioniert, sprich libgl1-mesa-dri-experimental ist installiert und

glxinfo | grep -i render

zeigt das entsprechend auch an.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

AnJo

  • Guest
[gelöst]nouveau + googleearth
« Reply #8 on: 2011/07/17, 21:10:09 »
glxinfo | grep -i render
Code: [Select]
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on NV34

AnJo

  • Guest
[gelöst]nouveau + googleearth
« Reply #9 on: 2011/07/17, 21:21:47 »
Hat funktioniert :D

Werde dann wohl bei nouveau bleiben .

Gruß
AnJo

Phoenix

  • Guest
[gelöst]nouveau + googleearth
« Reply #10 on: 2011/07/18, 20:08:34 »
Hallo,

eine Frage von außen: ist hier bekannt, ob nouveau inzwischen in neuer Version vorliegt? Ich hab in der Webseite nachgelesen, kann mich da aber nicht recht schlau machen (zu verworren, Englisch in DV- Form).

Zu meinen aptosid- Zeiten war nouveau ja der erste Grund, darüber zu fluchen. Jetzt habe ich ein wenig mit Mageia 1-64 probiert, und das bootet nach Installation problemlos unter nouveau, ohne den Kehrbesen benutzen zu müssen. Und nein, ein anderer Treiber ist da nicht aktiv.

Mit ?

Phoenix

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
[gelöst]nouveau + googleearth
« Reply #11 on: 2011/07/18, 20:10:59 »
Hä?
Nouveau DDX ist 1:0.0.16+git20110411+8378443-1+b1
DRI ist aus aktuellem Mesa
DRM ist im Kernel.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Phoenix

  • Guest
[gelöst]nouveau + googleearth
« Reply #12 on: 2011/07/19, 01:04:28 »
Hallo,

ich hab keinen genauen Tipp, wie ich die tatsächliche Version des nouveau- Treibers ermitteln kann; deshalb eine auszugsweise Zusammenstellung aus verschiedenen Dateien:
Quote
Quote
[    11.893] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul  7 18:06:57 2011
[    11.901] (II) Loading /usr/lib64/xorg/modules/drivers/v4l_drv.so
[    11.901] (II) Module v4l: vendor="X.Org Foundation"
[    11.901]    compiled for 1.10.0, module version = 0.1.1
[    11.901]    ABI class: X.Org Video Driver, version 10.0
[    11.903] (II) LoadModule: "nouveau"
[    11.903] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    11.903] (II) Module nouveau: vendor="X.Org Foundation"
[    11.903]    compiled for 1.10.0, module version = 0.0.16
[    11.903]    Module class: X.Org Video Driver
[    11.903]    ABI class: X.Org Video Driver, version 10.0
[    11.903] (II) v4l driver for Video4Linux
[    11.903] (II) NOUVEAU driver
[    11.903] (II) NOUVEAU driver for NVIDIA chipset families :
[    11.904]    GeForce 6       (NV4x)
[    11.908] (--) NOUVEAU(0): Chipset: "NVIDIA NV67"
[    11.908] (II) NOUVEAU(0): Creating default Display subsection in Screen section
   "screen1" for depth/fbbpp 24/32
[    12.125] (II) NOUVEAU(0): h_active: 1680  h_sync: 1784  h_sync_end 1960 h_blank_end 2240 h_border: 0
[    12.125] (II) NOUVEAU(0): v_active: 1050  v_sync: 1053  v_sync_end 1059 v_blanking: 1089 v_border: 0
[    12.125] (II) NOUVEAU(0): Serial No: H4289JA065253
[    12.125] (II) NOUVEAU(0): Modeline "1680x1050"x0.0

Quote
[    11.893] (==) Using config file: "/etc/X11
/xorg.conf"
Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 6100 to GeForce 360"
    Driver "nouveau"
    Option "DPMS"
EndSection


Quote
[    11.893] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
Nichts Verwertbares


Quote
sysinfo:/ im Konqueror
Display Info
Vendor:
nVidia Corporation
Model:
C68 [GeForce 7050 PV / nForce 630a]
2D driver:
nouveau
3D driver:
?


Quote
lspci -v | perl -ne '/VGA/../^$/ and /VGA|Kern/ and print'
[User_4@localhost ~]$ lspci -v | perl -ne '/VGA/../^$/ and /VGA|Kern/ and print'
00:12.0 VGA compatible controller: nVidia Corporation C68 [GeForce 7050 PV / nForce 630a] (rev a2) (prog-if 00 [VGA controller])
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb
[User_4@localhost ~]$


Informelle Grüße

Phoenix

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
[gelöst]nouveau + googleearth
« Reply #13 on: 2011/07/19, 07:37:27 »
Dir is schon klar, daß DU keine /etc/X11/xorg.conf brauchst?
Und die Nouveau-Treiberversion hab ich Dir ja schon genannt.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Phoenix

  • Guest
[gelöst]nouveau + googleearth
« Reply #14 on: 2011/07/19, 18:17:03 »
Hallo,

Quote from: "towo"
Dir is schon klar, daß DU keine /etc/X11/xorg.conf brauchst?
Und die Nouveau-Treiberversion hab ich Dir ja schon genannt.


Ich hab das installierte System durchforstet und anhand der Datei /var/log/Xorg.0.log die Dateien nachgesehen, aus denen die xorg.0.log ihre Bestandteile bezieht. Deshalb die Anmerkung zur xorg.conf.d (die ist nicht leer, aber zum Grafiktreiber steht nichts brauchbares darin).

Die xorg.conf ist vom System angelegt; von früher (...) weiß ich noch, daß man die zumindest bei Problemen löschen soll; aber Probleme macht das System in grafischer Hinsicht nicht.

Zur Treiberbenennung von nouveau: Deine ellenlange Struktur finde ich bei meinen Ausgaben nicht, nur Stücke davon. Ich hab ja keine Probleme mit dem Treiber bei Mageia; bei aptosid hatte ich die, bei openSUSE auch, ganz abgesehen von etlichen aktuellen Livesystemen auf Debian- Basis. Und weil wahrscheinlich keine mir bekannte Distri so aktuelle Quellen verwendet wie aptosid, habe ich hier mal nachgefragt, ob sich da vielleicht etwas geändert hat. Bei Mageia habe ich keine Auskunft dazu erhalten.

Also reine Interessensfrage, kein zu lösendes Problem.
Mir kommt es nur komisch vor, daß eine relativ neue Zusammenstellung wie Mageia mit Grub1 keine solchen Darstellungsprobleme hat, alle mir sonst zugänglichen max. 3 Monate alten Zusammenstellungen, mit beiden Grub- Arten, aber schon.

Nette Grüße

Phoenix