Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] VMware Player 6  (Read 5299 times)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.373
    • Land of the Buckeye
[EN] VMware Player 6
« on: 2013/09/28, 23:31:51 »
VMware Player 6 (64-bit), like the other recent versions, downloads with a ".txt" extension instead of the ".bundle" that it is supposed to have.  I'm not sure if my browser is doing that, or why it happens, but it is easy to rename the file when the download is finished.

On a system where the source files had previously been patched (see previous posts), Player 6 installed with no issues.

When I launched it from the existing panel icon, it failed.  Launching from a terminal with

Code: [Select]
/usr/bin/vmplayer spit the following error:

Failed to create secure directory (/run/user/1000/pulse): Permission denied

Hmmmmm -- a google search produced only 1 relevant hit, indicating this problem happened to a google talk user.  No clean explanation about the nature of this issue, related to pulseaudio.

In root konsole I chowned that directory to my user.  Afterward, Player 6 starts and runs with no problem.

So, it's a clunky workaround at the moment -- I assume the problem will return after a reboot.  I will continue to monitor this and report when there is news.

EDIT 29 SEP:  My assumption regarding the nature of the error was wrong.  Further googling did turn up a few instances of this error for both Debian and Ubuntu, but not directly related to VMware.  I tried a reboot and my system came up with the permissions on /run/user/1000/pulse set to my user.  And of course VMware Player 6 launches and runs correctly.  I proceeded to install it on a second 64-bit KDE system which uses pulseaudio, but first I checked the permissions on /run/user/1000/pulse.  On this system, it turned out to be /run/user/1001/pulse.  Permisssions were set to the user.  VMware Player 6 installed flawlessly and launched correctly the first time.  Apparently, my main system was in a non-standard configuration for some reason, when I first tried the installation.  I'm writing this off as a one-time anomaly, unless I learn differently.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO