Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Broadcom: Neuerdings keine wlan-Verbindung  (Read 7096 times)

Offline 10toe

  • User
  • Posts: 159
[DE] Broadcom: Neuerdings keine wlan-Verbindung
« on: 2011/01/23, 18:15:25 »
Nach einigen Stunden des Probierens komme ich mit dem Notebook meiner Frau (lenovo 530) nicht weiter: Neuerdings lässt sich keine wlan verbindung mehr aufbauen.

Quote
Could not set interface'wlan0' UP


fw-detect:

Code: [Select]
# Follow these instructions to obtain the correct firmware
# and activate the b43 driver:
apt-get update
apt-get install firmware-b43-lpphy-installer
modprobe -r b43
modprobe b43

You must first configure apt to install this non-free software,
refer to the offline manual that came with this distribution.


Ein Purgen und Neuinstallieren von firmware-b43-lpphy-installer hilft leider nicht.

iwconfig:
Code: [Select]

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


infobash -v3:
Code: [Select]
running Linux 2.6.37-0.slh.7-aptosid-686 i686 [ sidux 2009-04 Μόρος - kde-full - (200912310312) ]
CPU Info        Intel Celeron 900 @ 1024 KB cache flags( sse3 nx lm ) clocked at [ 2194.824 MHz ]
Videocard       Intel Mobile 4 Series Chipset Integrated Graphics Controller  X.Org 1.7.7  [ 1280x800@60.0hz ]
Network cards   Broadcom NetLink BCM5906M Fast PCI Express
                Broadcom BCM4312 802.11b/g LP-PHY


Ich kann leider nicht sagen, ob das Problem direkt nach dem letzten du auftrat oder ob noch etwas Zeit dazwischen vergangen ist. Ein Firmware-Problem? Oder vielleicht ein Hardwarefehler? Wie sollte ich am besten vorgehen, um den Fehler schnell einzukreisen?

Vielen Dank im Voraus!
Hans

mylo

  • Guest
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #1 on: 2011/01/24, 00:05:46 »
zeigt lsmod das Modul?

ralv

  • Guest
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #2 on: 2011/01/24, 06:36:29 »
Quote
# Follow these instructions to obtain the correct firmware
# and activate the b43 driver:
apt-get update
apt-get install firmware-b43-lpphy-installer
modprobe -r b43
modprobe b43

You must first configure apt to install this non-free software,
refer to the offline manual that came with this distribution.


Ich würde ja nach dem letzten Satz vermuten, dass die non-free-Quellen in der /etc/apt/sources.list.d/debian.list nicht freigegeben sind...

Gruß aus Münster

Rainer

grefabu

  • Guest
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #3 on: 2011/01/24, 15:37:15 »
Bist du Dir sicher den b43 vorher eingesetzt zu haben?

Bei meinem Lenovo g550 bin ich nur mit dem wl wirklich glücklich geworden.

Grüße

Gregor

Offline 10toe

  • User
  • Posts: 159
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #4 on: 2011/01/24, 18:32:00 »
@mylo
Quote
zeigt lsmod das Modul?

jep! Aber auch ein Ausschalten und Neuladen hilft leider nicht.

lsmod:
Code: [Select]
b43                   157115  0


@ralv
Nene, non-free ist hier schon freigegeben, ich vermute dies ist nur ein Standardhinweis.


@grefabu
Ja, bis jetzt lief b43 problemlos. Hin und wieder gab es kleine Aussetzer, aber nur sekundenweise.
Hm, einen Versuch wäre es wohl wert. Das Modul wl muss man sich aber selbst bauen, stimmts? Wie steht es dann eigentlich mit kommenden dist-upgrades: Muss man dann manuell das Modul updaten?

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #5 on: 2011/01/24, 19:57:51 »
Vielleicht mal mit broadcom-sta Treiber versuchen. Damit läuft zumindest meine BCM4313-Karte problemlos ....

muchan

  • Guest
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #6 on: 2011/01/24, 21:21:37 »
möglich:
# ceni

8)

944

  • Guest
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #7 on: 2011/01/24, 22:11:52 »
mit so ner B43 Karte hab ich mich gestern unter Kubuntu rumgeärgert.... Schon witzig, wenn man das so sieht.

Viel Erfolg !

Offline 10toe

  • User
  • Posts: 159
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #8 on: 2011/01/25, 20:25:52 »
Hm, Stand der Dinge: Modul wl gebildet und die Module b43 und ssb ausgeschaltet nach http://www.broadcom.com/support/802.11/linux_sta.php. Damit wird der Scan begonnen (ohne die Fehlermeldung "could not set ... UP"), jedoch bleibt das Scanergebnis (nach wireless networks) leer. Auch ein manuelles Eingeben der ESSID/BSSID setzt keine Verbindung auf.

Auch leuchtet die Wlan-Kontroll-LED nicht (wobei ich nicht genau weiß, ob das was aussagt).

Hm, mit meiner Frau im Nacken ("es reicht, ich kauf mir jetzt windows") bahnt sich wegen des langen Nonfree-Firmware-Gefrickels zu allem Überfluss auch noch ne ausgewaschene Krise an... :-)

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #9 on: 2011/01/25, 20:53:52 »
mal mit
Code: [Select]
apt-get install broadcom-sta-common broadcom-sta-source versucht?

danach müsste noch
Code: [Select]
m-a a-i broadcom-sta-source kommen (wenn ich mich nicht irre  :D )

Offline 10toe

  • User
  • Posts: 159
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #10 on: 2011/01/25, 21:09:39 »
@reddark
ja, vielen Dank, habe ich tatsächlich schon zuvor versucht. Selbes Ergebnis: Scan wird "durchgeführt", jedoch ohne Scanergebnisse.

Mein aktuelles Vorgehen: Restore eines Rootbackups vor des problematischen Updates. Ich bin mir immer noch nicht sicher, ob einfach die Hardware streikt.

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #11 on: 2011/01/25, 21:26:29 »
Quote

Selbes Ergebnis: Scan wird "durchgeführt", jedoch ohne Scanergebnisse.

Das heisst, die WLan-Karte wird richtig angezeigt in Ceni???
Vielleicht ein Routerproblem?

Offline 10toe

  • User
  • Posts: 159
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #12 on: 2011/01/25, 21:39:40 »
Exakt, ceni zeigt die drahtlose Netzwerkkarte mit "wlan0" (mit modul b43) bzw. "eth1" (mit modul wl) korrekt an. Wie gesagt, nur mit b43 erscheint die Fehlermeldung "could not set interface wlan0 UP", während mit wl der Scan erfolglos durchgeführt wird.

Hm, habe zwischenzeitlich Root-Partition platt gemacht und ein Root-Backup von 2010-12-22 wieder hergestellt. Mist, immer noch selbes Problem: "Could not set ... UP". Damals hatte es aber noch problemlos funktioniert. Evtl. also doch ein Hardware-Schaden?


edit:
Weiterer Hinweis:
Code: [Select]
# ifconfig wlan0 up
SIOCSIFFLAGS: Unbekannter Fehler 132


Wie lässt sich das deuten?

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #13 on: 2011/01/25, 22:07:24 »
Laut dieser Seite http://www.linux-club.de/viewtopic.php?f=19&t=111289 bedeutet die Fehlermeldung, das deine Karte deaktiviert ist .... ;) Hast du einen Wlan-Schalter? Ansonsten vielleicht mal [FN] + [F2] ;)

Offline 10toe

  • User
  • Posts: 159
Broadcom: Neuerdings keine wlan-Verbindung
« Reply #14 on: 2011/01/26, 19:04:31 »
Quote
Hast du einen Wlan-Schalter?


Moment mal. Was ist denn das für ein Ding da an der Vorderseite. Kenn ich noch gar nicht. Hm.

<klick>

<wlan-LED leuchtet>

... :shock:

Ich muss zugeben, ich bin sehr peinlich berührt. Das Problem ließ sich mechanisch, durch einen simplen geschlossenen Stromkreis, lösen. x Stunden Fehlersuche, aber wenigstens was dazu gelernt...

Zurück zu Modul b43, läuft wunderbar. Vielen Dank reddark für den entscheidenden Hinweis! :-)