Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [Solved] Wired network doesn't work  (Read 21888 times)

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
[EN] Re: Wired network doesn't work
« Reply #15 on: 2015/06/03, 17:46:54 »

Static IP doesn't work. So, if the cable it's ok, and I have firmware-realtek installed, where can be my problem?
I've try (just in case) changing the cable and reinstalling the firmware and changing /etc/systemd/network/interfaces to
Code: [Select]
[Match]
Name=eth0
[Network]
DHCP=ipv4


Thanks for your help!!!

Can you tell me what you did? Thanks!

I just realized that perhaps your problem is on a lower level. Can you try to setup your networking manually for testing?

(adjust the addresses as necessary)
# ifconfig eth0 down
# ifconfig eth0 up 192.168.178.10 netmask 255.255.255.0
# route add default gw 192.168.178.1 eth0

Make sure you have something sensible in /etc/resolv.conf (8.8.8.8 is a good choice for testing) and then see if you have connectivity.

If this works you can rule out hardware/firmware/driver issues and focus on the configuration aspects.

Offline der_bud

  • User
  • Posts: 1.073
  • member
Re: Wired network doesn't work
« Reply #16 on: 2015/06/03, 19:30:54 »
I am not fit in systemd-networkd (not used it yet), but from reading other posts and links I think the name of the configuration-file should reflect the devicename (?). So test renaming your above mentioned file '/etc/systemd/network/interfaces' to /etc/systemd/network/eth.network' (or eth0.network). And do not forget to 'systemctl enable systemd-networkd' and 'systemctl start systemd-networkd'.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

reinob

  • Guest
Re: Wired network doesn't work
« Reply #17 on: 2015/06/03, 19:34:37 »
Static IP doesn't work. So, if the cable it's ok, and I have firmware-realtek installed, where can be my problem?


Can you be more specific? I think it makes sense to really check this manually before getting into automatic configurations..
Can you do the ifconfig && route dance and then post here the output of "ifconfig" (or "ip a") and of "route" (or "ip r").
Then try pinging your gateway and tell/post what happens.
If ping fails or hangs run "dmesg" and look in the last few lines if anything is suspicious.
You may also want to, in a separate terminal, run "journalctl -f" (equivalent of "tail -f /var/log/syslog") and see if it spits anything which may be of relevance.


Quote
I've try (just in case) changing the cable and reinstalling the firmware and changing /etc/systemd/network/interfaces to
(snip)

This should go to /etc/systemd/network/eth0.network (you can call it "interfaces" if it makes you happy, but it needs to end with ".network").

Quote
Thanks for your help!!!


You're welcome. My eth0.network looks like this
Code: [Select]

[Match]
Name=eth0


[Link]
MTUBytes=8192


[Network]
DHCP=ipv4
LinkLocalAddressing=no
LLMNR=false
IPForward=true


[DHCP]
SendHostname=true
UseHostname=false
UseDNS=true
UseMTU=false
RouteMetric=10


But many of the options won't be needed (my AR8161 works with the alx module but only if you set the MTU to something bigger than 7*1024), and I set RouteMetric to 10 so that eth0 will be preferred over wlan0, for which I have RouteMetric=20.
Contrary to what I wrote earlier today it actually works reliably. It's not a solid as a failover bond but does the job quite nicely.


Should you decide to test networkd you need to "systemctl enable systemd-networkd" as well as either purge ifupdown or delete any references to your eth0 in /etc/network/interfaces, so avoid conflicts between networkd and ifupdown (as systemd honors -- some -- sysvinit scripts in /etc/init.d, including /etc/init.d/networking.


But first things first. Do it manually and test with ping and/or ssh or something where you can see what's going on.

reinob

  • Guest
Re: Wired network doesn't work
« Reply #18 on: 2015/06/03, 19:36:52 »
I am not fit in systemd-networkd (not used it yet), but from reading other posts and links I think the name of the configuration-file should reflect the devicename (?). So test renaming your above mentioned file '/etc/systemd/network/interfaces' to /etc/systemd/network/eth.network' (or eth0.network). And do not forget to 'systemctl enable systemd-networkd' and 'systemctl start systemd-networkd'.


You're absolutely right. I'd just mention that the basename can be anything ("eth" or "interfaces" or whatever). But the extension is important.


Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #19 on: 2015/06/03, 20:52:26 »
Thank you guys for your time. I really appreciate it.



Keep in mind that I have some knowledge of linux because I used it from a long time, but I'm not an expert by any means.


I've tried this:
With systemd with /etc/systemd/network/eth.network copied from reinob (and previous simplier) and Google DNS in /etc/resolv.conf

# ifconfig eth0 down
# ifconfig eth0 up 192.168.22.2 netmask 255.255.255.0
# route add default gw 192.168.22.1 eth0
# systemctl enable systemd-networkd
# systemctl start systemd-networkd

Code: [Select]
# ifconfig
eth0      Link encap:Ethernet  HWaddr 88:ae:1d:f3:21:46 
          inet addr:192.168.22.2  Bcast:192.168.22.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:8192  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1088 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:93493 (91.3 KiB)  TX bytes:93493 (91.3 KiB)


Code: [Select]
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.22.1    0.0.0.0         UG    0      0        0 eth0
192.168.22.0    *               255.255.255.0   U     0      0        0 eth0


Pings are missing and dmess show:
Code: [Select]
[ 1619.097302] r8169 0000:02:00.0 eth0: link down
[ 1619.112313] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready


Code: [Select]
# journalctl -f
-- Logs begin at mié 2015-06-03 20:14:12 CEST. --
jun 03 20:41:09 toshi ntpd[1039]: Listen normally on 17 eth0 192.168.22.2 UDP 123
jun 03 20:41:09 toshi ntpd[1039]: peers refreshed
jun 03 20:41:09 toshi NetworkManager[826]: <warn>  (eth0): arping could not be found; no ARPs will be sent
jun 03 20:41:18 toshi sshd[1011]: Received SIGHUP; restarting.
jun 03 20:41:18 toshi systemd[1]: Reloaded OpenBSD Secure Shell server.
jun 03 20:41:18 toshi sshd[1011]: Server listening on 0.0.0.0 port 22.
jun 03 20:41:18 toshi sshd[1011]: Server listening on :: port 22.
jun 03 20:41:38 toshi ntpdate[1842]: Can't find host 0.debian.pool.ntp.org: Name or service not known (-2)
jun 03 20:41:58 toshi ntpdate[1842]: Can't find host 1.debian.pool.ntp.org: Name or service not known (-2)
jun 03 20:42:18 toshi ntpdate[1842]: Can't find host 2.debian.pool.ntp.org: Name or service not known (-2)
jun 03 20:42:38 toshi ntpdate[1842]: Can't find host 3.debian.pool.ntp.org: Name or service not known (-2)
jun 03 20:42:38 toshi ntpdate[1842]: no servers can be used, exiting


reinob

  • Guest
Re: Wired network doesn't work
« Reply #20 on: 2015/06/03, 23:27:55 »
Thank you guys for your time. I really appreciate it.


I had written a long reply to your post but somehow Chrome decided that backspace means "go back". I thought only IE did that.


So I'll just say: you need to fix the kernel/module for your card. Maybe you need the r8168 module instead of r8169. I just googled a bit and it seems your card is even worse than mine. Also drop the MTU configuration. Leave it as is.


Once you get the card and kernel physically and logically recognizing that a cable is actually attached to it (check with "ethtool eth0") the rest will be trivial.

krisbee

  • Guest
Re: Wired network doesn't work
« Reply #21 on: 2015/06/04, 10:03:44 »
ajavibp,


A quick sanity check.  In your first post on this thread you said your wired connection stopped working after an update a couple of days ago.  What were you using to configure your connections when this happened? Was it Network Manager, Ceni or something else?


Now you've switched to systemd-networkd you don't want to run other services which might conflict.  For example, you'd want to disable Network Manager, and if you've got any files in /etc/network/interfaces move them elsewhere, or comment out their contents.  ( You can purge Network Manager etc. once you've got systemd-networkd working as you want)


In your last post on this thread you said: "pings missing".  Did you mean pings to external addresses fail and are unresolved? This implies your system is not seeing any DNS servers.


AFAIK, for systemd-networkd to work you also need to use the systemd-resolved.service.  See here for the details:


https://wiki.archlinux.org/index.php/Systemd-networkd#Required_services_and_setup


Note bit the about re-configuring /etc/resolv.conf

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #22 on: 2015/06/04, 15:31:15 »

I also think it's a recognition error hardware.
Thanks for your help.

Thank you guys for your time. I really appreciate it.


I had written a long reply to your post but somehow Chrome decided that backspace means "go back". I thought only IE did that.


So I'll just say: you need to fix the kernel/module for your card. Maybe you need the r8168 module instead of r8169. I just googled a bit and it seems your card is even worse than mine. Also drop the MTU configuration. Leave it as is.


Once you get the card and kernel physically and logically recognizing that a cable is actually attached to it (check with "ethtool eth0") the rest will be trivial.

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #23 on: 2015/06/04, 15:37:37 »
I've always use Network Manager. It's easier, specially when I need to move the laptop to other networks.


I've started to use systemd-networkd to try other possibilities, because I've been unable to make it work.


DNS is not the problem, it's the hardware (firmware, driver,...), because a ping to the router with static IP is missing too.


I'm goint to try to install r8168 module. I hope this solve this annoying problem. At least I can survive thanks to the wifi. I hope that will not break  ;)


ajavibp,


A quick sanity check.  In your first post on this thread you said your wired connection stopped working after an update a couple of days ago.  What were you using to configure your connections when this happened? Was it Network Manager, Ceni or something else?


Now you've switched to systemd-networkd you don't want to run other services which might conflict.  For example, you'd want to disable Network Manager, and if you've got any files in /etc/network/interfaces move them elsewhere, or comment out their contents.  ( You can purge Network Manager etc. once you've got systemd-networkd working as you want)


In your last post on this thread you said: "pings missing".  Did you mean pings to external addresses fail and are unresolved? This implies your system is not seeing any DNS servers.


AFAIK, for systemd-networkd to work you also need to use the systemd-resolved.service.  See here for the details:


https://wiki.archlinux.org/index.php/Systemd-networkd#Required_services_and_setup


Note bit the about re-configuring /etc/resolv.conf

reinob

  • Guest
Re: Wired network doesn't work
« Reply #24 on: 2015/06/04, 16:37:46 »
I'm goint to try to install r8168 module.


On your first post you say "I've tried to install the r8168-dkms package, but it try to remove all kernels images".
In my case it would not remove any packages, but I'm not using the siduction kernel.


You can always install the debian kernel and the r8168-dkms package and test from there. If it works you can then see if you can build the module for the siduction kernel.


Sorry I have no experience with r8168 or r8169. Nevertheless, if you have trouble with this ask and hopefully somebody (even I) can help you.


Good luck.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Wired network doesn't work
« Reply #25 on: 2015/06/04, 16:42:54 »
i suggest to read the message about the kernel removals twice - i would bet that the d-u wants to remove the kernel-headers
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

krisbee

  • Guest
Re: Wired network doesn't work
« Reply #26 on: 2015/06/04, 17:53:31 »

DNS is not the problem, it's the hardware (firmware, driver,...), because a ping to the router with static IP is missing too.


I'm goint to try to install r8168 module. I hope this solve this annoying problem. At least I can survive thanks to the wifi. I hope that will not break  ;)



ajavibp,

Well you've lost me. If you really think you have a hardware problem, and not a software config problem, why not just use a liveCD or  LINUX on a USB stick to test the network card?  Once you know if your on-board realtek NIC is, or is not ,working, then concentrate on getting the software configuration right with Siduction Linux. 

For the record, this is a very common onboard NIC, at least on PC motherboards,  I have it in use now:

Code: [Select]
inxi -F | grep Net
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169


From lspci -v

Code: [Select]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
        Subsystem: Gigabyte Technology Co., Ltd Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 26
        I/O ports at e000 [size=256]
        Memory at f0004000 (64-bit, prefetchable) [size=4K]
        Memory at f0000000 (64-bit, prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169

It had been configured using ceni, but that program is not working after recent updates.  I've had it working with Network Manager, connman and systemd-networkd  in the last couple of days.  But then I don't have the possibility of a conflict between a wired and wireless connection being active at the same time on my machine.

What you said so far leads me to think it's a software, not a hardware, problem.

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #27 on: 2015/06/04, 18:53:33 »
.

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #28 on: 2015/06/04, 18:55:05 »
Thanks @reinob, I think this can be my next attempt.

@melmarker it try to remove all, headers and images, even linux-image-siduction-amd64

@krisbee Sorry, I was thinking in hardware configuration. I hope it's not a hardware problem, but I'll also try to make sure. I do not want to rule anything out.

Thank you!

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Wired network doesn't work
« Reply #29 on: 2015/06/05, 15:28:41 »
Finally it works, but I do not like the solution: downgrade to debian kernel and install oficial drivers from Realtek.


I tried r8164-dkms with debian kernel, but didn't compile. I have to be reinstalled for each new kernel, and I lost the Siduction kernels, but at least the wired network is working again.


Thanks for your invaluable help!