seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/01/19, 08:07:17


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: LIbreoffice Version: 5.4.4.2 Build-ID: 1:5.4.4-1 hohe Prozessorlast im Leerlauf  (Read 521 times)

0 Members and 1 Guest are viewing this topic.

Offline tomsiduction

  • User
  • Posts: 35
Hallo
Seit dem Update auf Libreoffice

Version: 5.4.4.2
Build-ID: 1:5.4.4-1

Ist die CPU zu 25% ausgelastet - auch wenn nur ein leeres Dokument offen ist.
Wenn ich die Eigenschaften des (leeren) Dokuments aufrufe geht die Last sofort zurück.
Wie komme ich bitte wieder auf die frühere Version zurück oder behebe ich dieses Problem?

Auch ein Start im abgesicherten Modus brachte keine Besserung

Die Speicherauslastung sieht wie folgt aus:

Library Usage

The memory usage of a process is found by adding up the memory usage of each of its libraries, plus the process's own heap, stack and any other mappings, plus the stack of its 6 threads.
Private
more
55948 KB    [heap]
55712 KB    /usr/lib/libreoffice/program/libmergedlo.so
12316 KB    /usr/lib/libreoffice/program/libswlo.so
1676 KB    /usr/lib/libreoffice/program/liblocaledata_euro.so
1024 KB    /usr/lib/libreoffice/program/libacclo.so
Shared
more
5592 KB    /usr/lib/x86_64-linux-gnu/libgtk-3.so.0.2200.26
1428 KB    /lib/x86_64-linux-gnu/libc-2.26.so
1368 KB    /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.5400.3
1340 KB    /usr/lib/x86_64-linux-gnu/libicuuc.so.57.1
1288 KB    /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.24
Totals

Private    138944 KB    (= 73464 KB clean + 65480 KB dirty)
Shared    33708 KB    (= 32940 KB clean + 768 KB dirty)
Rss    172652 KB    (= Private + Shared)
Pss    142264 KB    (= Private + Shared/Number of Processes)
Swap    0 KB

Vielen Dank
« Last Edit: 2018/01/11, 15:23:27 by tomsiduction »

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.045
    • g-com.eu
@tomsiduction - gar nicht, aussagefähigen Fehler melden

EDIT: Da ich aber das selbe Verhalten hab, dass soffice --$foo --splash-pipe=5 teilweise über 100% Last macht, werde ich mal den Maintainer fragen, ob das so ernst gemeint ist und bleiben soll 8)

EDIT2: Nach Rücksprache mit dem Maintainer gibt es da ein paar gangbare Wege: Downgrade to stable, upgrade to experimental, dazwischen liegt noch die Möglichkeit, auf snapshot.debian.org ne frühere Version von Libreoffice ohne diesen Bug zu suchen - oder aber ganz einfach den Fehler bis zum Release von LO 6.0 zu ignorieren - ich hab jetzt mal LO aus experimental installiert, sieht nett aus - ich muss allerdings auch zugeben, dass selbst die Möglichkeit des Ignorierens für mich nicht so schlecht aussah, was stört mich, wenn einer von 8 Kernen Vollgas läuft und ansonsten nix passiert. Und ganz klare Aussage LO 5.4 in debian ist tot, es wäre Zeitverschwendung da noch was dran zu löten, Upstream hat im Zeitplan für den geplanten Tod von 5.4 den 11. Juni 2018 stehen.
https://wiki.documentfoundation.org/ReleasePlan/5.4
https://wiki.documentfoundation.org/ReleasePlan/6.0


« Last Edit: 2018/01/11, 18:06:35 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline threepio

  • User
  • Posts: 9
Hi,
I have had the same issue and checked different LO-versions.
The culprit isn`t Libre Office!
I jumped back to my siduction-image from the beginning of this year and checked it.
LO is running fine with cpu 3-5%.
I don`t know which update the culprit is, cause too many packages are updated since first of january.
I switched my repo to buster, doing an update and LO is running as expected.
Maybe someone of you have enough time to check it.
I am doing every two weeks an image of my siduction, to jump back, if something happened like this.

see you

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.045
    • g-com.eu
The culprit is libreoffice, esp. the soffice process - but hey - libeoffice/stable works without this behaviour, libreoffice/experimental too - we are not in a freeze, so this bug in LO 5.4.4 is not nice, but LO 5.4.4 is dead anyways. So it doesn't matter.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline drb

  • User
  • Posts: 90
Version: 5.4.4.2
Build ID: 1:5.4.4-1
I can't replicate high CPU usage.

Offline jure

  • User
  • Posts: 355
also no problems here



Quote
Version: 5.4.4.2
Build-ID: 1:5.4.4-1
CPU-Threads: 4; BS: Linux 4.14; UI-Render: Standard; VCL: x11;
Gebietsschema: de-DE (de_DE.utf8); Calc: group

Code: [Select]
System:    Host: siductionbox Kernel: 4.14.13-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.10.5
           Distro: Debian GNU/Linux buster/sid
CPU:       Quad core Intel Core i5-3570 (-MCP-) cache: 6144 KB
           clock speeds: max: 3401 MHz 1: 1700 MHz 2: 1797 MHz 3: 1772 MHz 4: 1652 MHz
Gruss Juergen

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 1.996
    • http://bluelupo.net
Kann ich ebenfalls bestätigen. Eine CPU (von vier) ist immer auf 100%.

Code: [Select]
libreoffice:
  Installiert:           1:5.4.4-1
  Installationskandidat: 1:5.4.4-1
  Versionstabelle:
 *** 1:5.4.4-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Ciao bluelupo
BlueLupo's Wiki - BlueLupo's Blog
BlueLupo bei GooglePlus
Bluelupo bei Diaspora*

Offline hendrikL

  • User
  • Posts: 232
Mh,
well here on the system i use to use for my daily work, there is no issue about that.
Tested it several times.




Code: [Select]
System:    Host: hhl Kernel: 4.14.13-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.10.5
           Distro: siduction 15.1.0 Thunderstruck - kde - (201512041044)
« Last Edit: 2018/01/12, 13:30:22 by hendrikL »

Offline threepio

  • User
  • Posts: 9
@melmarker
The culprits are  >libglib2.0-bin<  and  > libglib2.0-0< !   
2.54.2-5 from testing are working fine and cpu goes down!
I have spent a lot time to test and check.
I will pin those two libs until new versions will fix the issue.

see you
« Last Edit: 2018/01/12, 14:28:34 by threepio »

Offline jure

  • User
  • Posts: 355
as I wrote - no problems

Code: [Select]
apt policy libglib2.0-bin libglib2.0-0
libglib2.0-bin:
  Installiert:           2.54.3-1
  Installationskandidat: 2.54.3-1
  Versionstabelle:
 *** 2.54.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libglib2.0-0:
  Installiert:           2.54.3-1
  Installationskandidat: 2.54.3-1
  Versionstabelle:
 *** 2.54.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Gruss Juergen

Offline threepio

  • User
  • Posts: 9
@jure
That`s fine for you.
Maybe someone (except you) is interested in solving this issue.
If not, tell me please.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.045
    • g-com.eu
> 2018-01-18  17:48:22 <_rene_> bts: https://bugs.debian.org/887404

^^ So just disable the GTK3 UI should solve the issue, setting this to solved at all - there will be no upload nor modification of LO 5.4.4 in debian, one could consider it as dead. LO 6 is comming soon 8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline threepio

  • User
  • Posts: 9
I will prefer to keep glib, better for my eyes and it works as expected. :)

see you