Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] (gelöst) (solved) Wie wine installieren?  (Read 17080 times)

Offline Lanzi

  • User
  • Posts: 1.782
[DE] Re: (gelöst) (solved) Wie wine installieren?
« Reply #30 on: 2016/02/25, 11:07:45 »
du removed some days ago wine. and for at least 5 days it is not installable.

Code: [Select]
apt install wine-devel wine-devel-i386:i386 winehq-devel
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-devel-i386:i386 : Hängt ab von: libasound2-plugins:i386 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

I do not need the newest wine (aka wine devel). Is there any other possibility?



Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: (gelöst) (solved) Wie wine installieren?
« Reply #31 on: 2016/02/26, 10:43:06 »
Fresh install from my latest build of siduction

Distro: siduction 15.1.0 Thunderstruck - kde - (201602210225)

First install of wine on this system

A du never uninstalled wine on previous system


Code: [Select]
piper@x1:~$  wget https://dl.winehq.org/wine-builds/Release.key
--2016-02-26 03:56:12--  https://dl.winehq.org/wine-builds/Release.key
Resolving dl.winehq.org (dl.winehq.org)... 23.235.40.69
Connecting to dl.winehq.org (dl.winehq.org)|23.235.40.69|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3140 (3.1K) [application/pgp-keys]
Saving to: ‘Release.key’

Release.key                            100%[===========================================================================>]   3.07K  --.-KB/s    in 0s

2016-02-26 03:56:12 (89.2 MB/s) - ‘Release.key’ saved [3140/3140]

piper@x1:~$

Assuming you have apt-transport-https installed already

Code: [Select]
root /home/piper #  apt-key add Release.key
OK
root /home/piper # apt update

Full install can be viewed here   http://pipersid.net/paste/?paste=21#

to big to post


« Last Edit: 2016/02/26, 10:51:19 by piper »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline Lanzi

  • User
  • Posts: 1.782
Re: (gelöst) (solved) Wie wine installieren?
« Reply #32 on: 2016/02/26, 19:03:07 »
Thank you for your fast answer. Its really a mistery to me.

the key i did install, when i switched to the winehq-devel repo.

Code: [Select]
/etc/apt/sources.list.d

deb https://dl.winehq.org/wine-builds/debian/ sid main



Code: [Select]
root@# apt-cache policy winehq-devel
winehq-devel:
  Installiert:           (keine)
  Installationskandidat: 1.9.4~sid
  Versionstabelle:
     1.9.4~sid 500
        500 https://dl.winehq.org/wine-builds/debian sid/main amd64 Packages

Code: [Select]
# apt-get install winehq-devel
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 winehq-devel : Hängt ab von: wine-devel (= 1.9.4~sid)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Code: [Select]
root@# apt install wine-devel
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-devel : Hängt ab von: wine-devel-i386 (= 1.9.4~sid)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


root@# apt install wine-devel-i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-devel-i386:i386 : Hängt ab von: libasound2-plugins:i386 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


its alsways going back to libasound2-plugins:i386, which is not installable


So i tried another way:

aptitude install wine-devel

Code: [Select]
root@hal:/home/h# aptitude install  wine-devel
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  libasound2-plugins:i386{a} libavcodec-ffmpeg56:i386{a} libx265-79:i386{ab} wine-devel wine-devel-amd64{a} wine-devel-i386:i386{a}
Die folgenden Pakete werden ENTFERNT:
  libfontconfig1:i386{u} libfreetype6:i386{u} libgd3:i386{u} libgpac4{u} libgsoap7{u} libjbig0:i386{u} libjpeg62-turbo:i386{u} libtiff5:i386{u} libx265-68:i386{u} libxpm4:i386{u}
  linux-headers-4.4.0-towo.2-siduction-amd64{u} linux-headers-4.4.1-towo.1-siduction-amd64{u}
Die folgenden Pakete werden EMPFOHLEN, aber NICHT installiert:
  libcapi20-3 libcapi20-3:i386 libcups2:i386 libgnutls-deb0-28:i386 libodbc1 libodbc1:i386 libosmesa6 libosmesa6:i386 libssl1.0.0 libssl1.0.0:i386 libv4l-0:i386 libxcomposite1:i386 libxcursor1:i386
  libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386
0 Pakete aktualisiert, 6 zusätzlich installiert, 12 werden entfernt und 9 nicht aktualisiert.
44,4 MB/44,5 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 236 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 libgphoto2-6:i386 : Hängt ab von: libgd3:i386 (>= 2.1.0~alpha~) but it is not going to be installed
                     Hängt ab von: libjpeg62-turbo:i386 (>= 1.3.1) but it is not going to be installed
 libx265-79 : Beschädigt: libx265-79:i386 (!= 1:1.9-dmo1) but 1.9-3 is to be installed
 libx265-79:i386 : Beschädigt: libx265-79 (!= 1.9-3) but 1:1.9-dmo1 is installed
 libavcodec-ffmpeg-extra56 : Kollidiert mit: libavcodec-ffmpeg56:i386 but 7:2.8.6-1+b1 is to be installed
offen: 56; geschlossen: 3488; zurückgestellt: 21; Konflikte: 36                                                                                                                                                         ODie folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Entfernen der folgenden Pakete:
1)     libgphoto2-6:i386

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
2)     libasound2-plugins:i386 [Nicht installiert]
3)     libavcodec-ffmpeg56:i386 [Nicht installiert]
4)     libx265-79:i386 [Nicht installiert]
5)     wine-devel [Nicht installiert]
6)     wine-devel-i386:i386 [Nicht installiert]



Diese Lösung akzeptieren? [Y/n/q/?]

it deinstalld 199 libs

Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  libasound2:i386{u} libasyncns0:i386{u} libavresample-ffmpeg2:i386{u} libavutil-ffmpeg54:i386{u} libcap2:i386{u} libcrystalhd3:i386{u} libdb5.3:i386{u} libdbus-1-3:i386{u} libdrm2:i386{u} libexif12:i386{u}
  libexpat1:i386{u} libffi6:i386{u} libflac8:i386{u} libfontconfig1:i386{u} libfreetype6:i386{u} libgcrypt20:i386{u} libgd3:i386{u} libgettextpo0{u} libgl1-mesa-glx:i386{u} libglapi-mesa:i386{u}
  libglib2.0-0:i386{u} libglu1-mesa:i386{u} libgmp10:i386{u} libgnutls30:i386{u} libgomp1:i386{u} libgpac4{u} libgpg-error0:i386{u} libgphoto2-6:i386{a} libgphoto2-port12:i386{u} libgsm1:i386{u} libgsoap7{u}
  libgstreamer-plugins-base1.0-0:i386{u} libgstreamer1.0-0:i386{u} libhogweed4:i386{u} libice6:i386{u} libicu55:i386{u} libidn11:i386{u} libjack-jackd2-0:i386{u} libjbig0:i386{u} libjpeg62-turbo:i386{u}
  libjson-c2:i386{u} liblcms2-2:i386{u} libldap-2.4-2:i386{u} libltdl7:i386{u} libmp3lame0:i386{u} libmpg123-0:i386{u} libnettle6:i386{u} libnuma1:i386{u} libogg0:i386{u} libopenal1:i386{u} libopenjpeg5:i386{u}
  libopus0:i386{u} liborc-0.4-0:i386{u} libp11-kit0:i386{u} libpcap0.8:i386{u} libpng12-0:i386{u} libpulse0:i386{u} libsamplerate0:i386{u} libsasl2-2:i386{u} libsasl2-modules-db:i386{u}
  libschroedinger-1.0-0:i386{u} libshine3:i386{u} libsm6:i386{u} libsnappy1v5:i386{u} libsndfile1:i386{u} libsoxr0:i386{u} libspeex1:i386{u} libspeexdsp1:i386{u} libstdc++6:i386{u} libswresample-ffmpeg1:i386{u}
  libsystemd0:i386{u} libtasn1-6:i386{u} libtheora0:i386{u} libtiff5:i386{u} libtwolame0:i386{u} libudev1:i386{u} libusb-1.0-0:i386{u} libva1:i386{u} libvorbis0a:i386{u} libvorbisenc2:i386{u} libvpx3:i386{u}
  libwavpack1:i386{u} libwebp5:i386{u} libwrap0:i386{u} libx11-6:i386{u} libx11-xcb1:i386{u} libx264-148:i386{u} libx265-68:i386{u} libxau6:i386{u} libxcb-dri2-0:i386{u} libxcb-dri3-0:i386{u} libxcb-glx0:i386{u}
  libxcb-present0:i386{u} libxcb-randr0:i386{u} libxcb-render0:i386{u} libxcb-shape0:i386{u} libxcb-sync1:i386{u} libxcb-xfixes0:i386{u} libxcb1:i386{u} libxdamage1:i386{u} libxdmcp6:i386{u} libxext6:i386{u}
  libxfixes3:i386{u} libxi6:i386{u} libxml2:i386{u} libxpm4:i386{u} libxshmfence1:i386{u} libxtst6:i386{u} libxvidcore4:i386{u} libxxf86vm1:i386{u} libzvbi0:i386{u} linux-headers-4.4.0-towo.2-siduction-amd64{u}
  linux-headers-4.4.1-towo.1-siduction-amd64{u}

But then it is not installing anything, and the errormessage is the same!

Code: [Select]
root@# apt install  wine-devel-i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-devel-i386:i386 : Hängt ab von: libasound2-plugins:i386 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

running in circles


Offline Lanzi

  • User
  • Posts: 1.782
Re: (gelöst) (solved) Wie wine installieren?
« Reply #33 on: 2016/02/26, 19:20:45 »
okay, I found out, that I have a file from debian multimedia in the game (second block)

libx265-79 : Beschädigt: libx265-79:i386 (!= 1:1.9-dmo1)


I installed only one programm from debian-multimedia, but it seems to be the origin of the problems. My fault!
Since this is not supported, and its my own fault, I thank you for your help so far and I will try to find a solution of my own.

Sorry for the waste of time!
« Last Edit: 2016/02/26, 19:31:09 by Lanzi »

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: (gelöst) (solved) Wie wine installieren?
« Reply #34 on: 2016/02/27, 00:43:06 »
It is not debian-multimedia, since this is default in my builds ( I build with it) and if you see in my paste, it is used

Code: [Select]
Get:35 http://www.deb-multimedia.org sid/main i386 libfaac0 i386 1:1.28-dmo3 [38.2 kB] 
Get:45 http://www.deb-multimedia.org sid/main i386 libavutil55 i386 10:3.0-dmo2 [359 kB]
Get:59 http://www.deb-multimedia.org sid/main i386 libfdk-aac1 i386 1:0.1.4-dmo1 [356 kB]
Get:67 http://www.deb-multimedia.org sid/main i386 libilbc2 i386 2.0.2-dmo4 [52.9 kB]
Get:68 http://www.deb-multimedia.org sid/main i386 libkvazaar3 i386 1:0.8.3-dmo2 [135 kB]                                                                 
Get:74 http://www.deb-multimedia.org sid/main i386 libmp3lame0 i386 1:3.99.5-dmo5 [380 kB]                                                                                           
Get:82 http://www.deb-multimedia.org sid/main i386 libopenh264-1 i386 1.5.0-dmo2 [331 kB]                                                                 
Get:92 http://www.deb-multimedia.org sid/main i386 libswresample2 i386 10:3.0-dmo2 [107 kB]                                                               
Get:93 http://www.deb-multimedia.org sid/main i386 libutvideo15 i386 1:15.1.0-dmo3 [50.5 kB]                                                             
Get:94 http://www.deb-multimedia.org sid/main i386 libx264-148 i386 3:0.148.2665+gita01e339-dmo2 [628 kB]                                                 
Get:100 http://www.deb-multimedia.org sid/main i386 libx265-79 i386 1:1.9-dmo1 [481 kB]                                                                   
Get:104 http://www.deb-multimedia.org sid/main i386 libxvidcore4 i386 3:1.3.4-dmo1 [236 kB]
Get:107 http://www.deb-multimedia.org sid/main i386 libavcodec57 i386 10:3.0-dmo2 [8,277 kB]                                                             
Get:126 http://www.deb-multimedia.org sid/main i386 libavresample3 i386 10:3.0-dmo2 [105 kB]                                                             
Get:127 http://www.deb-multimedia.org sid/main i386 libasound2-plugins i386 1:1.1.0-dmo2 [73.3 kB]
   


Code: [Select]
piper@x1:~$ apt policy libasound2-plugins:i386
libasound2-plugins:i386:
  Installed: 1:1.1.0-dmo2
  Candidate: 1:1.1.0-dmo2
  Version table:
 *** 1:1.1.0-dmo2 500
        500 http://www.deb-multimedia.org sid/main i386 Packages
        100 /var/lib/dpkg/status
     1.1.0-1 500
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
        500 http://httpredir.debian.org/debian testing/main i386 Packages
piper@x1:~$ apt policy libavcodec-ffmpeg56:i386
libavcodec-ffmpeg56:i386:
  Installed: (none)
  Candidate: 7:2.8.6-1+b1
  Version table:
     7:2.8.6-1+b1 500
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
        500 http://httpredir.debian.org/debian testing/main i386 Packages
piper@x1:~$ apt policy libx265-79:i386
libx265-79:i386:
  Installed: 1:1.9-dmo1
  Candidate: 1:1.9-dmo1
  Version table:
 *** 1:1.9-dmo1 500
        500 http://www.deb-multimedia.org sid/main i386 Packages
        100 /var/lib/dpkg/status
     1.9-3 500
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
        500 http://httpredir.debian.org/debian testing/main i386 Packages
piper@x1:~$ apt policy wine-devel
wine-devel:
  Installed: 1.9.4~sid
  Candidate: 1.9.4~sid
  Version table:
 *** 1.9.4~sid 500
        500 https://dl.winehq.org/wine-builds/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
piper@x1:~$ apt policy wine-devel-i386:i386
wine-devel-i386:i386:
  Installed: 1.9.4~sid
  Candidate: 1.9.4~sid
  Version table:
 *** 1.9.4~sid 500
        500 https://dl.winehq.org/wine-builds/debian sid/main i386 Packages
        100 /var/lib/dpkg/status
piper@x1:~$

Perhaps. purge everything and start from scratch, I have been using dmo repo for a very long time (as long as mythtv has been out) and never a problem, and I mean never, my household depends on it, commercial free tv/recordings.

Something is wrong on your end, 4 machines here and never did a dist-upgrade remove wine


« Last Edit: 2016/02/27, 01:09:23 by piper »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline Lanzi

  • User
  • Posts: 1.782
Re: (gelöst) (solved) Wie wine installieren?
« Reply #35 on: 2016/02/27, 11:50:31 »
I found a solution ;D
Buit I am not sure how, or what caused the trouble.
I installed only avidemux from dmo and then deactivated the repo, so maybe some older versions blocked everything.

I uninstalled avidemux, and checked lame and x264, which seemed to have come also from dmo.
When I uninstalled this programms I could install wine...

Well, lets wait for the next DU.

Thanks piper for your patientce and comforting words!