Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] grub defekt?  (Read 2601 times)

Offline NochEinNeuer

  • User
  • Posts: 191
[DE] grub defekt?
« on: 2023/01/08, 10:53:39 »
Hallo,

in meinem Rechner hängen 3 SSD jede mit einer siduction Installation.
Eine SSD (sda) tauschte ich vor einigen Tagen gegen eine größere und installierte wieder siduction mate mit sämtlichen Updates.
In den ersten Tagen gab es kein Problem. Beim Booten wurden mir auch die siduction von den zwei anderen SSD im Bootmenü angezeigt.

Heute früh wurden mir auf einmal die Booteinträge der beiden anderen SSD nicht mehr angezeigt.

Nach einem erneuten Booten von sda kommt nur noch die grub Kommandozeile:

Code: [Select]
WELCOME to GRUB!

error: symbol 'grub_disk_native_sectors" not found.
grub rescue> _


Ich habe im Bootmenü die Bootreihenfolge der SSD geändert. Ich boote jetzt erst mal über sdb und starte über den dortigen Bootmenüeintrag mein siduction von sda.

Unter mate auf sda kommt folgendes:
Code: [Select]
root@tux:/home/jf# update-grub
Code: [Select]
Generating grub configuration file ...
Code: [Select]
Found theme: /usr/share/grub/themes/mow/theme.txt
Code: [Select]
Found linux image: /boot/vmlinuz-6.1.4-1-siduction-amd64
Code: [Select]
Found initrd image: /boot/initrd.img-6.1.4-1-siduction-amd64
Code: [Select]
Found linux image: /boot/vmlinuz-6.1.3-2-siduction-amd64
Code: [Select]
Found initrd image: /boot/initrd.img-6.1.3-2-siduction-amd64
Code: [Select]
Found memtest86+ 64bit EFI image: /boot/memtest86+x64.efi
Code: [Select]
Warning: os-prober will not be executed to detect other bootable partitions.
Code: [Select]
Systems on them will not be added to the GRUB boot configuration.
Code: [Select]
Check GRUB_DISABLE_OS_PROBER documentation entry.
Code: [Select]
Adding boot menu entry for UEFI Firmware Settings ...
Code: [Select]
done
Code: [Select]
root@tux:/home/jf#

Grundsätzlich müsste ja siduction auf sda für mein Verständnis starten aber ich komme nur zu grub rescue

Hat jemand eine Idee wie ich das wieder zum Laufen krieg?
Und vor allem warum funzt es nimmer?

Vielen Dank für Eure Hilfe,
Jürgen

Nachtrag: Ich hab mein Glück mit einer supergrubdisk probiert. Da wird der Eintrag von sda gefunden und lässt sich problemlos auswählen und booten.

Neuinstallation und reconfig brachte auch keine Verbesserung
« Last Edit: 2023/01/08, 11:07:19 by NochEinNeuer »

Thats_me

  • Guest
Re: grub defekt?
« Reply #1 on: 2023/01/08, 11:55:53 »
Ich kenne mich zwar nicht gut aus.

Code: [Select]
Warning: os-prober will not be executed to detect other bootable partitions.
OS-Prober erkennt andere Distris. Ist das deaktiviert, werden sie nicht erkannt.

https://proxy.metager.de/linuxnews.de/2021%2F12%2F20%2Fgrub-2-0-6-deaktiviert-os_prober?url=https%3A%2F%2Flinuxnews.de%2F2021%2F12%2F20%2Fgrub-2-0-6-deaktiviert-os_prober%2F&password=8c4b720a4eaef7fe5e89dace2c401dc648c8cda51cbe9df4346fc2e9bf07fee3

OS-Prober sorgte für Diksussionen in der Ubuntu Linux Community und m. W. auch anderen. Einige Distris deaktivieren das aus Prinzip.

« Last Edit: 2023/01/08, 11:59:38 by Thats_me »

Offline NochEinNeuer

  • User
  • Posts: 191
Re: grub defekt?
« Reply #2 on: 2023/01/08, 12:04:56 »
Danke damit wäre das Problem mit os-prober gelöst.

Bleibt nur noch das Problem das sich dieses mate nicht mehr direkt booten lässt.

Thats_me

  • Guest
Re: grub defekt?
« Reply #3 on: 2023/01/08, 12:18:41 »
Danke damit wäre das Problem mit os-prober gelöst.

Bleibt nur noch das Problem das sich dieses mate nicht mehr direkt booten lässt.
Da kenne ich mich nicht aus. Evtl. mit Live System oder chroot grub updaten?


Für UEFI

Code: [Select]
xmg:[me]:~$ efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001,0004
Boot0000* Artix HD(1,GPT,6a060eb0-ae4f-9247-8ea6-32d3c26b1cf0,0x800,0x7d000)/File(\EFI\ARTIX\GRUBX64.EFI)
Boot0001* UEFI OS HD(1,GPT,6a060eb0-ae4f-9247-8ea6-32d3c26b1cf0,0x800,0x7d000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
Boot0004* MX21 HD(1,GPT,6a060eb0-ae4f-9247-8ea6-32d3c26b1cf0,0x800,0x7d000)/File(\EFI\MX21\GRUBX64.EFI)

Zeigt, ob es einen Eintrag im efi Bootmanager gibt.
« Last Edit: 2023/01/08, 12:23:17 by Thats_me »

Offline NochEinNeuer

  • User
  • Posts: 191
Re: grub defekt?
« Reply #4 on: 2023/01/08, 12:42:44 »
Code: [Select]
jf@tux:~$ efibootmgr
Code: [Select]
BootCurrent: 000A
Code: [Select]
Timeout: 1 seconds
Code: [Select]
BootOrder: 000A,0001,0002,0009,0008
Code: [Select]
Boot0001* siduction_2021.2.0
Code: [Select]
Boot0002* siduction
Code: [Select]
Boot0008* UEFI OS
Code: [Select]
Boot0009* UEFI OS
Code: [Select]
Boot000A* UEFI OS
Code: [Select]
jf@tux:~$

Thats_me

  • Guest
Re: grub defekt?
« Reply #5 on: 2023/01/08, 14:04:35 »
Auch da kann ich dir leider nicht wirklich helfen.
Ich blicke da selbst nicht genau durch.
Ich schreibe mal, wie ich das bisher grob verstanden habe.

Das eine ist grub, ob andere Distris erkannt werden. Aslo das os-prober.
Dann das Grubmenü das bei Start angezeigt wird und die Auswahl der Distris anbietet.
Das andere, dass die Distri auch in das EFI geschrieben wird.
Normalerweise sollte das in einem EFI System automatisch bei der Installation passieren, dass die "efi-Datei" der Distri
efi/boot/bootx64.efi (?) oder grubx64.efi (?) in den Efibootmanager geschrieben wird.

Grub bietet dann alle Distris an, die es im efibootmanager findet.
Alternativ kann man auch direkt über das Bios den efi bootmanager aufrufen. Das ist aber nicht so komfortabel wie über das Grubmenü.

Ist das nicht der Fall, kann man den Efi Eintrag auch nachträglich in den entsprechenden Ordner einfügen.
Ich habe aktuell genau das Problem. Sidu installiert sich nicht in /boot/efi

https://wiki.ubuntuusers.de/efibootmgr/
https://wiki.gentoo.org/wiki/Efibootmgr/de

Wie man das genau macht und ob das hier nötig ist, müssen aber die Experten hier sagen.
Vielleicht gibt es ja auch andere Wege.



Aber wie gesagt, alles ohne Gewähr!
« Last Edit: 2023/01/08, 14:12:24 by Thats_me »

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.938
Re: grub defekt?
« Reply #6 on: 2023/01/08, 14:12:16 »

Quote
Grub bietet dann alle Distris an, die es im efibootmanager findet.
Nein, tut es nicht!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline dieres

  • User
  • Posts: 786
Re: grub defekt?
« Reply #7 on: 2023/01/08, 16:57:40 »
Du bootest von sdb über efi das system auf sda.

dort installierst du grub neu . Im einfachsten fall als root mit grub-install /dev/sda. dann noch update-grub nachdem Du Dich vergewissert hast, das in /etc/default/grub os-prober aktiviert ist. Aufpassen wegen doppelter Verneinung  disable auf  false setzen.
Dann sollte eigentlich wieder alles funken, solange Du auch von uefi gebooteten USB Stick für die Neuinstallation benutzt hast.

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.938
Re: grub defekt?
« Reply #8 on: 2023/01/08, 17:06:31 »

Quote
dort installierst du grub neu . Im einfachsten fall als root mit grub-install /dev/sda.
Auf einem EFI System installiert man Grub nicht auf ein Device.

Aus diesem Grund reicht bei EFI auch ein einfaches grub-install ohne weitere Angaben, wenn /boot/efi ordentlich gemountet ist.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline dieres

  • User
  • Posts: 786
Re: grub defekt?
« Reply #9 on: 2023/01/09, 17:59:14 »
Danke, manchmal hilft Nachdenken vorm Schreiben ;-) Wieder was dazugelernt.