Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  [fixed] New libsnappy1v5 = 1.2.0-1 cause lookup error  (Read 670 times)

Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Programs using qtwebengine (like quasselclient, chromium, nextcloud, kmail ...) stop working with the following error:

symbol lookup error: /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5: undefined symbol: _ZN6snappy11RawCompressEPKcmPcPm

This is caused by new libsnappy1v5 = 1.2.0-1

Downgrading fixed it for me.

Code: [Select]
LANG=C apt policy libsnappy1v5
libsnappy1v5:
  Installed: 1.1.10-1+b1
  Candidate: 1.2.0-1
  Version table:
     1.2.0-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://incoming.debian.org/debian-buildd buildd-unstable/main amd64 Packages
 *** 1.1.10-1+b1 100
        100 /var/lib/dpkg/status

https://snapshot.debian.org/package/snappy/1.1.10-1/#libsnappy1v5_1.1.10-1:2b:b1

Thr bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1070217
« Last Edit: 2024/05/03, 10:31:38 by hendrikL »

Offline samoht

  • User
  • Posts: 480
Re: New libsnappy1v5 = 1.2.0-1 cause lookup error
« Reply #1 on: 2024/05/03, 10:16:22 »
Thank you so much, @hendrikL

Falkon has also been bitten by this bug.

UPDATE:
Now fixed with updated package
Code: [Select]
# LANG=C apt policy libsnappy1v5
libsnappy1v5:
  Installed: 1.2.0-2
  Candidate: 1.2.0-2
« Last Edit: 2024/05/03, 10:28:13 by samoht »

Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: New libsnappy1v5 = 1.2.0-1 cause lookup error
« Reply #2 on: 2024/05/03, 10:31:11 »
With the new libsnappy1v5 = 1.2.0-2 the bug is fixed!