Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  Attention/ Achtung, an 64-bit time_t transition is in progress in unstable  (Read 27267 times)

Offline lanig

  • User
  • Posts: 54
I can volunteer for that.
My system is not completely ruined but I have lost video codecs which makes for an rather poor multimedia experience...Yes week-end will be loooong.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
I've been using Debian-unstable for about 25 years now. But this is the most intense transition I've experienced so far.

...

Right. About 15 years using sidux, aptosid, and siduction, and I have never before seen dpkg throw an error that there are conflicting packages within the repo.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline Geier0815

  • User
  • Posts: 588
I can volunteer for that.
My system is not completely ruined but I have lost video codecs which makes for an rather poor multimedia experience...Yes week-end will be loooong.
/var/log/apt/history.log and "apt install bla/testing blat64-" is your friend. Don't ask why I know that ;)
« Last Edit: 2024/03/01, 22:13:04 by Geier0815 »
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline RunLevelZero

  • User
  • Posts: 14
Thanks as always for the heads-up. Hard for me to stay on top of things and when I see big stuff happening, KDE etc I just check here and know to wait or what steps are safe. You are all awesome and thank you to the Siduction team for an awesome distribution.

Offline Isegrimm666

  • User
  • Posts: 87
@edlin

This time I paid attention  ;)... but nala is getting really rough now:

Quote
Dieses mal hab ich aufgepasst ;) ... aber nala wird jetzt ganz ruppig:

Code: [Select]
Keine Änderung: https://linux.teamviewer.com/deb stable InRelease               

Keine Änderung: https://deb.debian.org/debian unstable InRelease               

Keine Änderung: https://siduction.mirror.garr.it/extra unstable InRelease       

Keine Änderung: https://siduction.mirror.garr.it/fixes unstable InRelease       

Geholt 0 Bytes in 0s (0 bytes/s)                                               
libpam0t64
└── libpam0g (< 1.5.3-4) wird libpam0g (1.5.2-9.1+b1) beschädigen

Notiz: Die obigen Informationen können hilfreich sein
Fehler: Sie haben beschädigte Pakete zurückgehalten

How is this to be understood now?

(Of course you keep your feet still for now.)

Quote
Wie ist das jetzt zu verstehen?

(Klar, dass man erstmal die Füße still hält.)

Offline lanig

  • User
  • Posts: 54

/var/log/apt/history.log and "apt install bla/testing blat64-" is your friend. Don't ask why I know that ;)
Thanks for the tip. I want to be sure that I won't break more my system

Code: [Select]
apt  install mpv/testing
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Version choisie « 0.37.0-1 » (Debian:unstable, Debian:testing [amd64]) pour « mpv »
Version choisie « 7:6.1.1-1 » (Debian:testing [amd64]) pour « libavcodec60 » à cause de « mpv »
Version choisie « 7:6.1.1-1 » (Debian:testing [amd64]) pour « libavutil58 » à cause de « libavcodec60 »
Version choisie « 7:6.1.1-1 » (Debian:testing [amd64]) pour « libavdevice60 » à cause de « mpv »
Version choisie « 7:6.1.1-1 » (Debian:testing [amd64]) pour « libavfilter9 » à cause de « libavdevice60 »
Version choisie « 7:6.1.1-1 » (Debian:testing [amd64]) pour « libavformat60 » à cause de « libavfilter9 »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libavdevice60 : Dépend: libavfilter9 (>= 7:6.0)
 mpv : Dépend: libavfilter9 (>= 7:6.0)
       Dépend: libswscale7 (>= 7:6.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

So I think I can not but but wait.

Offline ro_sid

  • User
  • Posts: 227
@Isegrimm666:
Quote
Code: [Select]
[...]
Geholt 0 Bytes in 0s (0 bytes/s)                                               
libpam0t64
└── libpam0g (< 1.5.3-4) wird libpam0g (1.5.2-9.1+b1) beschädigen

Notiz: Die obigen Informationen können hilfreich sein
Fehler: Sie haben beschädigte Pakete zurückgehalten
Quote
How is this to be understood now?

(Of course you keep your feet still for now.)

Quote

    Wie ist das jetzt zu verstehen?

    (Klar, dass man erstmal die Füße still hält.)
Relativ einfach, beim "neuen" Paket libpam0t64 wurde vergessen eine '>'-Verträglichkeits-Regel für libpam0g zu setzen.
libpam0g (1.5.2-9.1+b1) ist (wie verlangt) kleiner als  (< 1.5.3-4), sollte aber nicht zusammen mit libpam0t64 installiert werden.


Offline seasons

  • User
  • Posts: 269
Now our systems will have no problem with the year 2038. Hopefully, we can run dist-upgrade by then too.

Offline edlin

  • User
  • Posts: 548
I will be 83 years old in a few days on 19 January 2038. I'm less worried about Siduction and Debian/Sid than about my life expectancy.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline terroreek

  • User
  • Posts: 202
I'm still waiting for the first user who hasn't read or understood the warnings and has ruined their system.
The weekend is still long ...  8)

Code: [Select]
apt update && apt upgrade
edlin

Even if I wanted to I couldn't apt-dist upgrade is showing me this;

Code: [Select]
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpam0t64 : Breaks: libpam0g (< 1.5.3-4)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Offline edlin

  • User
  • Posts: 548
In such situations, a
Code: [Select]
doas apt update && doas apt upgradeis the better choice.

And we have plenty of time until 19 January 2038 ...

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline terroreek

  • User
  • Posts: 202
I know that's what I did I was just saying I couldn't shoot myself in the foot even if I tried. 

Offline Isegrimm666

  • User
  • Posts: 87
Things are moving...  ;)

Code: [Select]
[07:42:34][root@C-Y-G-N-A:/home/isegrimm]$ nala upgrade

...

==========================================================================================
 Zusammenfassung                                                                                                                                                                                                                 
==========================================================================================
 Konfigurieren    1 Pakete                                                                                                                                                                                                       
 Zurückgehalten 380 Pakete                                                                                                                                                                                                       
                                                                                                                                                                                                                                 
     
Möchten Sie fortfahren? [J/n]

No... I certainly don't want to...  >:(

(The one package is still "tex-common" that cannot be configured due to problems...)

Offline Pip

  • User
  • Posts: 165
Tried it out with an apt upgrade. It will upgrade linux-image to 6.7.8-1 but not linux-header, so a reboot left it struggling with starting virtualbox and rabbitmq (where it stalled). Rebooting with 6.7.6-1 gave me the machine back. No other issues I've come across so far.

Offline michaa7

  • User
  • Posts: 2.304
Tried it out with an apt upgrade. It will upgrade linux-image to 6.7.8-1 but not linux-header....

Interessting.

I was wondering whether or not to upgrade (instead of d-u) and whether or not currently upgrade is always safe. Or could it technically lead to some incompatible package combinations which a d-u (when it is sensible to do it again) could and would prevent from happening.

Note: I am not claiming to know anything better than what is recommended since years!
I am only wondering, given the huge amount of packages waiting to be upgaded, wheather it is saver to wait for the moment when doing a d-u is sensible agian or simply incementally upgrading with the risc (is it?) of little glitches over time amounting to something serious.

Given the amount of packages (here at the moment 1.375 MB of upgradable packages + 377 packages still waiting for being upgradable) I really wonder which is the safer way to go .... 
« Last Edit: 2024/03/03, 14:24:49 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake