Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: [1] 2 3 ... 10
1
Software - Support / Re: Startet bei Euch Inkscape?
« Last post by hendrikL on 2024/04/20, 17:28:15 »
2
Software - Support / Re: Startet bei Euch Inkscape?
« Last post by hendrikL on 2024/04/20, 15:13:40 »
Mal via konsole gestartet?
Vielleicht gibt es es ja etwas mehr zu lesen!

ps. schon mal einen Test-user angelegt und dort inkscape versucht zu starten?
3
Software - Support / Re: Startet bei Euch Inkscape?
« Last post by edlin on 2024/04/20, 14:05:23 »
Antwort steht ja da: Interner Fehler. Dummerweise ist das gefühlt die Universalfehlermeldung von Inkscape.
Wenn du in den Logfiles etc. nichts auffälliges findest, wird es so erstmal schwierig. Ich habe selbst unter aktuellem KDE/Plasma weder unter X11 noch unter Wayland Probleme, Inkscape als user zu starten.
Versuche doch zunächst folgenden Weg: Inkscape purgen, dann das AppImage von https://inkscape.org/release/inkscape-1.3.2/ laden. Gleicher Fehler? Es bleibt ja noch der harte Weg, Inkscape aus den Quellen zu compilieren und installieren.
Unsere Systeme unterscheiden sich halt ein wenig in der Hardware und irgendwo zwischen BIOS, Firmware und Treibern liegt wohl das Geheimnis des internen Fehlers begraben.

Code: [Select]
System:
  Host: Devil Kernel: 6.8.7-1-siduction-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 13.2.0
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 2023.1.0 giants - kde -
    (202308160855) base: Debian GNU/Linux trixie/sid
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x
    serial: 210585044805011 uuid: 43110cbe-bd18-48b3-5e8b-7c10c93ed120
    UEFI: American Megatrends v: 3607 date: 03/18/2024
Battery:
  Device-1: hidpp_battery_0 model: Logitech Marathon Mouse/Performance Plus
    M705 charge: 55% (should be ignored) status: discharging
Memory:
  System RAM: total: 32 GiB available: 30.66 GiB used: 12.64 GiB (41.2%)
  Array-1: capacity: 128 GiB slots: 4 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: DIMM_A1 type: no module installed
  Device-2: DIMM_A2 type: DDR4 size: 16 GiB speed: 2133 MT/s
  Device-3: DIMM_B1 type: no module installed
  Device-4: DIMM_B2 type: DDR4 size: 16 GiB speed: 2133 MT/s
CPU:
  Info: 6-core model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 2403 high: 3437 min/max: 400/4464 cores: 1: 400 2: 2991
    3: 3029 4: 400 5: 400 6: 2993 7: 3214 8: 3007 9: 2992 10: 2981 11: 2995
    12: 3437 bogomips: 93426
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 bus-ID: 0a:00.0
    temp: 26.0 C
  Device-2: Aveo USB2.0 UVC PC Camera driver: uvcvideo type: USB
    bus-ID: 1-3.4:4
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.6 driver: X:
    loaded: amdgpu unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu
    resolution: 1920x1200~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms:
    active: gbm,x11,surfaceless,device inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-1 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir LLVM
    17.0.6 DRM 3.57 6.8.7-1-siduction-amd64)
Auch mal nach neuer Firmware fürs MoBo schauen.

edlin
4
Software - Support / Re: Startet bei Euch Inkscape?
« Last post by Lanzi on 2024/04/20, 11:50:24 »
2024-04: So, muss diesen Thread mal aufrollen.

Aufgrund der xz-utils-Problematik habe ich gestern SIduction KDE neu aufgesetzt, mit dem kde-testbuelid vom 29.3.

Ich hatte mir seit der letzten Installation damit beholfen Inkscape als root zu starten. Ist zwar blöd, ging aber. Die Fehlermeldung (als user zu starten) verschwand nie. Das Programm war (und ihr ahnt es schon,) und ist nicht zu starten.
Auch das Libreoffice-Problem (Einfrieren bei großen Dokumenten, u.U. minutenlang beim Start) blieb bestehen.

Nun habe ich gestern neu installiert und vor und nachdem full-upgrade als allererstes Inkscape gestartet. Keine anderen Partitionen eingebunden, nichts... und siehe da, die Fehlermeldung ist immer noch da. (siehe Bild)
Das Libreoffice-Problem scheint weg zu sein... abwarten.

Bin gerade sehr gefrustet, da ich Inkscape regelmäßig brauche. Hat noch jemand eine Idee?

Code: [Select]
root@h# inxi -v5
System:
  Host: hal-2024-04 Kernel: 6.8.7-1-siduction-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 13.2.0
  Console: pty pts/1 Distro: siduction 2023.1.1 giants - kde -
    (202403291554) base: Debian GNU/Linux trixie/sid
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: TUF GAMING Z790-PLUS WIFI v: Rev 1.xx
    serial: 221213896804390 uuid: 8bfc1230-5003-ffc1-61ad-c87f54560fb4
    UEFI: American Megatrends v: 0812 date: 02/24/2023
Battery:
  Device-1: wacom_battery_0 model: Wacom Intuos Pro M charge: 100%
    status: full
Memory:
  System RAM: total: 64 GiB available: 62.56 GiB used: 9.84 GiB (15.7%)
    igpu: 64 MiB
  Array-1: capacity: 256 GiB slots: 4 modules: 2 EC: None
    max-module-size: 64 GiB note: est.
  Device-1: Controller0-DIMM0 type: DDR5 size: 32 GiB speed: 4000 MT/s
  Device-2: Controller0-DIMM1 type: no module installed
  Device-3: Controller1-DIMM0 type: DDR5 size: 32 GiB speed: 4000 MT/s
  Device-4: Controller1-DIMM1 type: no module installed
CPU:
  Info: 16-core (8-mt/8-st) model: 13th Gen Intel Core i7-13700 bits: 64
    type: MST AMCP arch: Raptor Lake rev: 1 cache: L1: 1.4 MiB L2: 24 MiB
    L3: 30 MiB
  Speed (MHz): avg: 837 high: 1100 min/max: 800/5100:5200:4100 cores: 1: 800
    2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 1100
    12: 1100 13: 1100 14: 800 15: 800 16: 800 17: 800 18: 800 19: 800 20: 800
    21: 800 22: 800 23: 800 24: 800 bogomips: 101376
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-13 bus-ID: 00:02.0
  Device-2: Logitech BRIO 4K Stream Edition
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB bus-ID: 2-9.1:4
  Display: server: X.Org v: 23.2.6 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 resolution:
    1: 3840x2160~60Hz 2: 3840x2160~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms:
    active: gbm,x11,surfaceless,device inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.5-1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Graphics (RPL-S)
Audio:
  Device-1: Intel Raptor Lake High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: Logitech BRIO 4K Stream Edition
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB bus-ID: 2-9.1:4
  API: ALSA v: k6.8.7-1-siduction-amd64 status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: n/a (root, process)
Network:
  Device-1: Intel Raptor Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlan0 state: down mac: 88:d8:2e:78:8f:52
  Device-2: Intel Ethernet I226-V vendor: ASUSTeK driver: igc v: kernel
    port: N/A bus-ID: 06:00.0
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: c8:7f:54:56:0f:b4
Bluetooth:
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB
    bus-ID: 1-14:8
  Report: hciconfig ID: hci0 rfk-id: 1 state: up address: 88:D8:2E:78:8F:56
    bt-v: 5.3 lmp-v: 12
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd v: 0.6 bus-ID: 00:0e.0
Partition:
  ID-1: / size: 3.51 TiB used: 1.72 TiB (49.0%) fs: ext4 dev: /dev/nvme0n1p2
    label: N/A uuid: f1a72087-d5c6-49f1-a7bf-2b3e969b30fb
  ID-2: /boot/efi size: 299.4 MiB used: 156 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1 label: -r uuid: D9E2-F2EF
Swap:
  ID-1: swap-1 type: partition size: 68.81 GiB used: 20 KiB (0.0%)
    dev: /dev/nvme0n1p3 label: swap uuid: 3c2352d0-1ec0-4ab3-8d5d-19259f10ee22
Sensors:
  System Temperatures: cpu: 27.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 470 Uptime: 14h 57m Init: systemd target: graphical (5)
  Packages: 3198 Compilers: gcc: 13.2.0 Shell: Bash v: 5.2.21 inxi: 3.3.34
root@hal-2024-04:~#
5
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by edlin on 2024/04/19, 18:17:59 »
I had checked after the initial posting to see if it was already „too late“ for me. util-linux was already installed in the latest version. I then installed util-linux-extra additionally and without any problems. No package had to be removed etc.

I am therefore also of the opinion that we are not affected.

edlin
6
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by Pip on 2024/04/19, 16:43:54 »
Glad it's clear. I did mention that issue with holding util-linux-extra in the original post, but not clearly enough.

As has been said, this is probably not relevant to us (actually, since hendrikL said it, it's a definite), but there's a fix being developed and it just seemed more prudent for me to wait a little while. But then, I am a coward.
7
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by lanig on 2024/04/19, 14:19:39 »
OK, thanks.

My problem came from the fact that I have put on hold  util-linux-extra because of the bug report :
Code: [Select]
b1 - #1069064 - util-linux-extra: insufficient Replaces for util-linux due to /usr-move
I was confused because I haven't understood the discussion about "upgrading from bookworm". It is clear now.
8
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by hendrikL on 2024/04/19, 10:02:38 »
hi lanig,

What is the outcome of 'apt full-upgrade fdisk+ partitionmanager+'?
You can also use apt dist-upgrade <foo>+'.

Both are installed here™.

Code: [Select]
:~$ LANG=C apt policy partitionmanager fdisk
partitionmanager:
  Installed: 22.12.3-1+b1
  Candidate: 22.12.3-1+b1

fdisk:
  Installed: 2.40-6
  Candidate: 2.40-6
9
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by lanig on 2024/04/19, 09:35:25 »
I don't know whether it is related or not, but
Code: [Select]
apt dist-upgrade                                                                             
Installing dependencies:                                                                                       
  libcares2 libmpg123-0t64 libquazip5-1t64                                                                     
                                                                                                               
Paquets suggérés :                                                                                             
  libquazip-doc                                                                                                     
                                                                                                                     
Upgrading:                                                                                                           
  audacity gstreamer1.0-plugins-good libnode-dev libnode109 libopenmpt0t64 libsndfile1 nodejs nomacs                 
                                                                                                                     
Not upgrading:                                                                                                       
  bsdextrautils libblkid-dev libfdisk1    libmount1     libuuid1 rfkill     util-linux-extra                         
  eject         libblkid1    libmount-dev libsmartcols1 mount    util-linux uuid-dev                                 
                                                                                                                     
REMOVING:                                                                                                           
  fdisk libc-ares2 libkpmcore12 libmpg123-0 libquazip5-1 partimage partitionmanager uuid-runtime           
         

I am surprised to see fdisk and partitionmanager being removed. Is it safe to dist-upgrade?

Best regards,
                                                                                                                     
       
10
Upgrade Warnings / Re: Warning: util-linux/2.40-6 has serious error
« Last post by hendrikL on 2024/04/19, 07:45:11 »
Quote
from the bugreport
[...]
util-linux-extra gained the utils ctrlaltdel, fsck.cramfs, fsck.minix,
mkfs.bfs, mkfs.cramfs, and mkfs.minix. In util-linux-extra, these now
reside below /usr/sbin while they used to reside in /sbin in util-linux
in bookworm and earlier. Hence upgrading from bookworm to sid can cause
these files to be lost.
[...]

So we are already on sid not bookworm and before!
I do not think, that will affect us.

Code: [Select]
~$ LANG=C apt policy util-linux
util-linux:
  Installed: 2.40-6
  Candidate: 2.40-6
  Version table:
 *** 2.40-6 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://ftp.uni-hannover.de/debian/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
hhl@hhl-2:~$ LANG=C apt policy util-linux
util-linux          util-linux-extra    util-linux-locales
hhl@hhl-2:~$ LANG=C apt policy util-linux-extra
util-linux-extra:
  Installed: 2.40-6
  Candidate: 2.40-6
  Version table:
 *** 2.40-6 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://ftp.uni-hannover.de/debian/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
:~$ ls -l /sbin/mkfs.m*
-rwxr-xr-x 1 root root 129432 15. Apr 09:51 /sbin/mkfs.minix
lrwxrwxrwx 1 root root      8 18. Feb 2021  /sbin/mkfs.msdos -> mkfs.fat
hhl@hhl-2:~$ ls -l /usr/sbin/mkfs.m*
-rwxr-xr-x 1 root root 129432 15. Apr 09:51 /usr/sbin/mkfs.minix
lrwxrwxrwx 1 root root      8 18. Feb 2021  /usr/sbin/mkfs.msdos -> mkfs.fat

I updated my system from bookworm to sid/trixie long ago, and so all others should done too!

Code: [Select]
:~$ inxi -S
System:
  Host: hhl-2 Kernel: 6.8.6-1-siduction-amd64 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 22.1.2 Masters_of_War -
    kde - (202303151559)

:~$ cat /etc/debian_version
trixie/sid
Pages: [1] 2 3 ... 10