Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Installing in Xeon E5-1650 notebook with SSD drives and LVM  (Read 2455 times)


  • Guest
So, finally my new notebook has arrived (well, it is more like a mobile workstation and one needs to be quite strong to move it...).

It comes with:

- 2 x SSD drives
- 1 x normal SATA drive
- 1 x 6-core Xeon E5-1650
- 16 GB of RAM
- 1 x NVIDIA GTX 670MX
- UEFI activated in the BIOS
- Safe boot deactivated (not by default though)
- This thing is a Clevo P570WM and therefore, the BIOS seems buggy (or, in other words, Windows 8-ready) and not very configurable.

I wanted to make a Volume Group including both SSD drives and a separate VG with the other drive.

In the SSD drives I created a ext2 partition for /boot which was not included in the LVM. The SSD volume group has two logical volumes, one for root, one for home. The swap logical volume is in the backup drive.


With this configuration I was able to install Siduction, as far as I did not define mount points for "non-standard" partitions (those not pre-defined by the installer).

However, upon rebooting, I was welcome by the Intel Boot Loader instead of by Grub.

Removing the LVM configuration enabled me to get a bit further, but the system hanged during booting.


The installer is not able to handle logical volumes and, in any case, it crashes miserably even with normal partitions.


Sid installation is straightforward even with the LVM configuration. The problem is that the system hangs upon booting due to the lack of the Intel microcode.

I think that this problem could be worked around by the use of a netinstall image including the various firmware and microcodes required.


Wheezy works like a charm. Why? I guess that that is because the required microcodes are included in the kernel. Upgrading to kernel 3.9 from backports results in the behaviour described above for Sid. However, installing the required firmware, along with the Intel microcode (I guess this is the important thing), solved the issue.

Now I am dubious about how to install Sid: Upgrading Wheezy or creating a Sid netinstall image containing the firmware and microcode?