Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl  (Read 5728 times)

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
[DE] Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #30 on: 2024/04/10, 10:46:07 »
I have no added any patch. The problem is the kernel is build with gcc-14 and the midule-sorce was not compatible with gcc-14. Nvidia upstream has fixed that in the new versions of the driver.

You can try the following:

put

make CC=/bin/gcc-13 IGNORE_CC_MISMATCH=1 ...

in your dkms.conf. But that only works, if your nvidia version is generaly compatible with kernel 6.8.
Besides of that, we do not support packages, installed from 3rd party repos.

You even can wait for the next kernel-update, which use gcc-13 for compiling.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Mte90

  • User
  • Posts: 223
  • KDE & Debian lover
    • http://www.mte90.net
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #31 on: 2024/04/10, 10:49:52 »
I will wait for the next kernel version :-)

Offline Pip

  • User
  • Posts: 164
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #32 on: 2024/04/13, 10:24:40 »
And that all seems to work nicely now - Linux sidomen 6.8.5-1-siduction-amd64.

Offline DrJuanNadie

  • Newbie
  • Posts: 2
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #33 on: 2024/04/13, 17:29:26 »
It worked for me too with kernel 6.8.5-1

Offline charlyheinz

  • User
  • Posts: 102
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #34 on: 2024/04/15, 17:42:13 »
Hello- which Nvidia-driver are you using? I would like to have the 550... Nvidia proprietary driver running on my system with the actual kernel (6.8.6-1), but for me it dos not work!
Are you using the Nouveau- driver?
The only Nvidia-driver running with this kernel for me is 535.171.04-0siduction1.

Am I right?

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #35 on: 2024/04/15, 18:32:33 »
You will never get help with such a description:
Quote
but for me it dos not work!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline charlyheinz

  • User
  • Posts: 102
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #36 on: 2024/04/15, 18:48:47 »
Sorry towo

With nvidia-driver 550... from the fix repro glxinfo tells me that I am using mesa as glx- implementation not Nvidia. That is all.

Any help / idea...

But I can live with that using Nvidia-driver 535.171.04-0siduction1 as it works out of the box!

Offline ro_sid

  • User
  • Posts: 227
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #37 on: 2024/04/15, 20:48:08 »
What shall I say? I am using an "Optimus"-Laptop. A "primusrun glxinfo" works just fine, reporting the Nvidia-driver. It is the "550.67-0siduction2" version with the  "6.8.6-1-siduction-amd64_6.8-6" linux kernel (- it also worked with the 6.8.5-1-siduction kernel).
It certainly is not a general problem, unlike the one that started this thread.
So you have to be a little more specific.

Offline michaa7

  • User
  • Posts: 2.302
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #38 on: 2024/05/16, 13:52:02 »
How is the situation with nvidia-tesla-470-driver? Anyone has it working with kernel 6.8.x ? I am still on 6.7.x
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #39 on: 2024/05/16, 13:59:30 »
470.239.06-1 should™ work.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline michaa7

  • User
  • Posts: 2.302
Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Reply #40 on: 2024/05/16, 14:55:38 »
I thought there  was need for a new patch from nvidia to make it work with 6.8.x and therefor was waiting for new nvidia packages all the time.  I may have misunderstood one of your postings ...

Anyway, modules for 6.8.x are build and system is rebooted ... all is fine.


Thanks
Ok, you can't code, but you still might be able to write a bug report for Debian's sake