Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  [solved] Sound Dummy Output in pavucontrol  (Read 3899 times)

Offline Pirmin

  • User
  • Posts: 39
[solved] Sound Dummy Output in pavucontrol
« on: 2022/03/15, 17:06:51 »
I lost my audio playback devices. In pavucontrol I don't see a sound output device. Neither integrated speakers nor HDMI output. When I start mpv I see the following lines:
Code: [Select]
ALSA lib pcm_pulse.c:758:(pulse_prepare) PulseAudio: Unable to create stream: Zeitüberschreitung
[ao/alsa] Unable to set hw-parameters: Eingabe-/Ausgabefehler
[ao/alsa] Attempting to work around even more ALSA bugs...

My sound cards are available:
Code: [Select]
cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7a14000 irq 38
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a10000 irq 37
Code: [Select]
lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
Code: [Select]
inxi -A
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.16.12-1-siduction-amd64 running: yes
  Sound Server-2: PipeWire v: 0.3.48 running: yes

To fix this I had to install wireplumber, pipewire-audio-client-libraries and pipewire-media-session. The information is from Debian wiki:
Code: [Select]
sudo apt install pipewire-media-session wireplumber pipewire-audio-client-libraries


Listen to the music

« Last Edit: 2022/03/15, 17:28:07 by Pirmin »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.373
    • Land of the Buckeye
Re: [solved] Sound Dummy Output in pavucontrol
« Reply #1 on: 2022/03/15, 18:32:39 »
Just so pulseaudio users understand:

Code: [Select]
sudo apt rdepends pipewire-pulse
[sudo] password for user:
Reverse Depends:
  Breaks: pipewire-media-session (<< 0.3.39-1)
  Recommends: wireplumber
  Depends: plasma-pa
  Replaces: pipewire-media-session (<< 0.3.39-1)
  Depends: libcanberra-pulse
  Depends: pavucontrol-qt
  Depends: phosh-core
  Depends: gnome-core
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline Pirmin

  • User
  • Posts: 39
Re: [solved] Sound Dummy Output in pavucontrol
« Reply #2 on: 2022/06/06, 20:05:37 »
I had this issue again. Now I have to use wireplumber without pipewire-media-session.

Code: [Select]
sudo apt rdepends wireplumber

It crashes / collides with pipewire-media-session. Removing pipewire-media-session and installing wireplumber solves my problem and enables speaker output.