Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Calibre is missing some packages  (Read 341 times)

Offline edlin

  • User
  • Posts: 155
Calibre is missing some packages
« on: 2022/08/16, 15:08:15 »
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  calibre calibre-bin libqt6webenginecore6 libqt6webenginecore6-bin libqt6webenginequick6 libqt6webenginewidgets6 python3-pyqt6 python3-pyqt6.qtqml python3-pyqt6.qtquick
  python3-pyqt6.qtsvg python3-pyqt6.qtwebchannel python3-pyqt6.qtwebengine
Die folgenden Pakete werden aktualisiert (Upgrade):
  libqt6concurrent6 libqt6core6 libqt6dbus6 libqt6gui6 libqt6network6 libqt6opengl6 libqt6opengl6-dev libqt6openglwidgets6 libqt6positioning6 libqt6printsupport6 libqt6qml6
  libqt6qmlmodels6 libqt6quick6 libqt6quickwidgets6 libqt6sql6 libqt6sql6-sqlite libqt6svg6 libqt6svgwidgets6 libqt6test6 libqt6waylandclient6 libqt6waylandcompositor6
  libqt6waylandeglclienthwintegration6 libqt6waylandeglcompositorhwintegration6 libqt6webchannel6 libqt6widgets6 libqt6wlshellintegration6 libqt6xml6 qmake6 qmake6-bin qt6-base-dev
  qt6-base-dev-tools qt6-gtk-platformtheme qt6-image-formats-plugins qt6-qpa-plugins qt6-wayland
35 aktualisiert, 0 neu installiert, 12 zu entfernen und 0 nicht aktualisiert.
Code: [Select]
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 calibre-bin : Hängt ab von: qt6-base-abi (= 6.2.4)
 libqt6webenginecore6 : Hängt ab von: qt6-base-abi (= 6.2.4)
 libqt6webenginequick6 : Hängt ab von: qt6-base-abi (= 6.2.4)
 python3-pyqt6 : Hängt ab von: qt6-base-abi (= 6.2.4)

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Camelot

  • User
  • Posts: 61
Re: Calibre is missing some packages
« Reply #1 on: 2022/08/16, 16:14:43 »
It’s Qt6 transition 6.2.4 → 6.3.1
Use apt upgrade, not apt full-upgrade and wait.
Code: [Select]
apt -V upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
   libqt6core6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6dbus6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6gui6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6network6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6opengl6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6openglwidgets6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6positioning6 (6.2.4-3 => 6.3.1-2)
   libqt6printsupport6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6qml6 (6.2.4+dfsg-6 => 6.3.1+dfsg-2)
   libqt6qmlmodels6 (6.2.4+dfsg-6 => 6.3.1+dfsg-2)
   libqt6quick6 (6.2.4+dfsg-6 => 6.3.1+dfsg-2)
   libqt6quickwidgets6 (6.2.4+dfsg-6 => 6.3.1+dfsg-2)
   libqt6sql6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6sql6-sqlite (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6svg6 (6.2.4-2 => 6.3.1-2)
   libqt6svgwidgets6 (6.2.4-2 => 6.3.1-2)
   libqt6test6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6waylandclient6 (6.2.4-2 => 6.3.1-2)
   libqt6waylandcompositor6 (6.2.4-2 => 6.3.1-2)
   libqt6waylandeglclienthwintegration6 (6.2.4-2 => 6.3.1-2)
   libqt6waylandeglcompositorhwintegration6 (6.2.4-2 => 6.3.1-2)
   libqt6webchannel6 (6.2.4-2 => 6.3.1-2)
   libqt6widgets6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   libqt6wlshellintegration6 (6.2.4-2 => 6.3.1-2)
   libqt6xml6 (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   qt6-gtk-platformtheme (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   qt6-image-formats-plugins (6.2.4-2 => 6.3.1-2)
   qt6-qpa-plugins (6.2.4+dfsg-10 => 6.3.1+dfsg-6)
   qt6-wayland (6.2.4-2 => 6.3.1-2)
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.

Offline edlin

  • User
  • Posts: 155
Re: Calibre is missing some packages
« Reply #2 on: 2022/08/18, 09:36:40 »
Alle Abhängigkeiten für Calibre sind wieder erfüllt, so dass ein apt full-upgrade (oder eine Neuinstallation) problemlos funktionieren sollten.

All dependencies for Calibre are fulfilled again, so an apt full-upgrade (or new/reinstall) should work without problems.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates