Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [Solved] emacs 28.1  (Read 223 times)

Offline finotti

  • User
  • Posts: 226
[Solved] emacs 28.1
« on: 2022/08/19, 13:44:01 »
Emacs 28.1 (finally!) came to Sid, but installation is not successful, at least in my (aptosid) system.

After a failed installation, I tried:

Code: [Select]
# apt -f install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up emacs-gtk (1:28.1+1-1) ...
Install emacsen-common for emacs
emacsen-common: Handling install of emacsen flavor emacs
malloc(): unsorted double linked list corrupted
Fatal error 6: Aborted
Backtrace:
emacs(+0x153d71)[0x564e81774d71]
emacs(+0x48902)[0x564e81669902]
emacs(+0x48dcf)[0x564e81669dcf]
emacs(+0x15209d)[0x564e8177309d]
emacs(+0x152189)[0x564e81773189]
/lib/x86_64-linux-gnu/libc.so.6(+0x3daf0)[0x7fcb9f43daf0]
/lib/x86_64-linux-gnu/libc.so.6(+0x8983c)[0x7fcb9f48983c]
/lib/x86_64-linux-gnu/libc.so.6(raise+0x12)[0x7fcb9f43da52]
/lib/x86_64-linux-gnu/libc.so.6(abort+0xcf)[0x7fcb9f428469]
/lib/x86_64-linux-gnu/libc.so.6(+0x7dc18)[0x7fcb9f47dc18]
/lib/x86_64-linux-gnu/libc.so.6(+0x9355a)[0x7fcb9f49355a]
/lib/x86_64-linux-gnu/libc.so.6(+0x9645c)[0x7fcb9f49645c]
/lib/x86_64-linux-gnu/libc.so.6(malloc+0x95)[0x7fcb9f497275]
emacs(+0x195c35)[0x564e817b6c35]
emacs(+0x195dc6)[0x564e817b6dc6]
emacs(+0x196002)[0x564e817b7002]
emacs(+0x1962d0)[0x564e817b72d0]
emacs(+0x1df895)[0x564e81800895]
emacs(+0x1e3278)[0x564e81804278]
emacs(+0x1e3f3a)[0x564e81804f3a]
emacs(+0x1b8442)[0x564e817d9442]
emacs(+0x1b8710)[0x564e817d9710]
emacs(+0x1ba758)[0x564e817db758]
emacs(+0x1b8ecf)[0x564e817d9ecf]
emacs(+0x1b9481)[0x564e817da481]
emacs(+0x4b4ae)[0x564e8166c4ae]
emacs(+0x4b76e)[0x564e8166c76e]
emacs(+0x4b77c)[0x564e8166c77c]
emacs(+0x1b85d8)[0x564e817d95d8]
/usr/libexec/emacs/28.1/x86_64-linux-gnu/../../../../bin/../lib/emacs/28.1/native-lisp/28.1-aa5da5cc/preloaded/env-72406999-a036d1f6.eln(F737562737469747574652d656e762d696e2d66696c652d6e616d65_substitute_env_in_file_name_0+0x70)[0x7fcb9abd8810]
emacs(+0x1b87d0)[0x564e817d97d0]
emacs(+0x1b888a)[0x564e817d988a]
emacs(+0x16c9d8)[0x564e8178d9d8]
emacs(+0x1e377d)[0x564e8180477d]
emacs(+0x1e3f3a)[0x564e81804f3a]
emacs(+0x1b8442)[0x564e817d9442]
emacs(+0x1b8710)[0x564e817d9710]
emacs(+0x1b88df)[0x564e817d98df]
emacs(+0x1deff5)[0x564e817ffff5]
emacs(+0x1df9d3)[0x564e818009d3]
emacs(+0x1e3278)[0x564e81804278]
...
Aborted
ERROR: install script from emacsen-common package failed
dpkg: error processing package emacs-gtk (--configure):
 installed emacs-gtk package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of emacs:
 emacs depends on emacs-gtk (>= 1:27.1) | emacs-lucid (>= 1:27.1) | emacs-nox (>= 1:27.1); however:
  Package emacs-gtk is not configured yet.
  Package emacs-lucid is not installed.
  Package emacs-nox is not installed.

dpkg: error processing package emacs (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 emacs-gtk
 emacs
E: Sub-process /usr/bin/dpkg returned an error code (1)

and

Code: [Select]
# dpkg --configure -a
Setting up emacs-gtk (1:28.1+1-1) ...
Install emacsen-common for emacs
emacsen-common: Handling install of emacsen flavor emacs
malloc(): unsorted double linked list corrupted
Fatal error 6: Aborted
Backtrace:
emacs(+0x153d71)[0x5563ea6ffd71]
emacs(+0x48902)[0x5563ea5f4902]
emacs(+0x48dcf)[0x5563ea5f4dcf]
emacs(+0x15209d)[0x5563ea6fe09d]
emacs(+0x152189)[0x5563ea6fe189]
/lib/x86_64-linux-gnu/libc.so.6(+0x3daf0)[0x7f61f3c3daf0]
/lib/x86_64-linux-gnu/libc.so.6(+0x8983c)[0x7f61f3c8983c]
/lib/x86_64-linux-gnu/libc.so.6(raise+0x12)[0x7f61f3c3da52]
/lib/x86_64-linux-gnu/libc.so.6(abort+0xcf)[0x7f61f3c28469]
/lib/x86_64-linux-gnu/libc.so.6(+0x7dc18)[0x7f61f3c7dc18]
/lib/x86_64-linux-gnu/libc.so.6(+0x9355a)[0x7f61f3c9355a]
/lib/x86_64-linux-gnu/libc.so.6(+0x9645c)[0x7f61f3c9645c]
/lib/x86_64-linux-gnu/libc.so.6(malloc+0x95)[0x7f61f3c97275]
emacs(+0x195c35)[0x5563ea741c35]
emacs(+0x195dc6)[0x5563ea741dc6]
emacs(+0x196002)[0x5563ea742002]
emacs(+0x1961d0)[0x5563ea7421d0]
emacs(+0x16d1c8)[0x5563ea7191c8]
emacs(+0x1df28d)[0x5563ea78b28d]
emacs(+0x1e3278)[0x5563ea78f278]
emacs(+0x1e3f3a)[0x5563ea78ff3a]
emacs(+0x1b8442)[0x5563ea764442]
emacs(+0x1b8710)[0x5563ea764710]
emacs(+0x1ba758)[0x5563ea766758]
emacs(+0x1b8ecf)[0x5563ea764ecf]
emacs(+0x1b9481)[0x5563ea765481]
emacs(+0x4b4ae)[0x5563ea5f74ae]
emacs(+0x4b76e)[0x5563ea5f776e]
emacs(+0x4b77c)[0x5563ea5f777c]
emacs(+0x1b85d8)[0x5563ea7645d8]
/usr/libexec/emacs/28.1/x86_64-linux-gnu/../../../../bin/../lib/emacs/28.1/native-lisp/28.1-aa5da5cc/preloaded/env-72406999-a036d1f6.eln(F737562737469747574652d656e762d696e2d66696c652d6e616d65_substitute_env_in_file_name_0+0x70)[0x7f61f1f09810]
emacs(+0x1b87d0)[0x5563ea7647d0]
emacs(+0x1b888a)[0x5563ea76488a]
emacs(+0x16c9d8)[0x5563ea7189d8]
emacs(+0x1e377d)[0x5563ea78f77d]
emacs(+0x1e3f3a)[0x5563ea78ff3a]
emacs(+0x1b8442)[0x5563ea764442]
emacs(+0x1b8710)[0x5563ea764710]
emacs(+0x1b88df)[0x5563ea7648df]
emacs(+0x1deff5)[0x5563ea78aff5]
emacs(+0x1df9d3)[0x5563ea78b9d3]
...
Aborted
ERROR: install script from emacsen-common package failed
dpkg: error processing package emacs-gtk (--configure):
 installed emacs-gtk package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of emacs:
 emacs depends on emacs-gtk (>= 1:27.1) | emacs-lucid (>= 1:27.1) | emacs-nox (>= 1:27.1); however:
  Package emacs-gtk is not configured yet.
  Package emacs-lucid is not installed.
  Package emacs-nox is not installed.

dpkg: error processing package emacs (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 emacs-gtk
 emacs

I could not find any bug report on that...

If anyone has any suggestions, I would greatly appreciate it!  (I really depend on emacs....)
« Last Edit: 2022/08/19, 20:24:58 by finotti »

Offline edlin

  • User
  • Posts: 155
Re: emacs 28.1
« Reply #1 on: 2022/08/19, 16:57:25 »
aptosid? Tell us more about your system and your package sources.
I have just updated my current system including emacs. There were no problems and emacs updated to the 1:28 version without any problems.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline finotti

  • User
  • Posts: 226
Re: emacs 28.1
« Reply #2 on: 2022/08/19, 20:24:31 »
Thanks for the reply!

I did some digging and could remove and reinstall emacs.  (I had to remove dictionaries-common to do so, which also removed many other packages), and now it works on this system.  I am not exactly sure what was the problem...  I could updates it in a siduction installation without problems.

Thanks again!