Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [Solved] No microphone input on HDA Intel Card  (Read 10197 times)

delta9

  • Guest
[EN] [Solved] No microphone input on HDA Intel Card
« on: 2012/01/29, 20:52:42 »
Hello,

there is no microphone input on my notebook. Here is some info:

Code: [Select]
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xceafc000 irq 44
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xcf1dc000 irq 46


Code: [Select]
$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]


Code: [Select]
cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC272


In alsamixer all bars are up to all channels.

The problem is that there is no microphone input. I edited the /etc/modprobe.d/alsa-base.conf and add the line
Code: [Select]
options snd-hda-intel model="model". I tried different models for my chipset. With some of them the option internal Mic / Mic is added to alsamixer, but still mic does not work.

Thanks a lot in advance,

d9

Online michaa7

  • User
  • Posts: 2.318
No microphone input on HDA Intel Card
« Reply #1 on: 2012/01/30, 02:05:26 »
what's the output of

# arecord -l
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

delta9

  • Guest
[Solved] No microphone input on HDA Intel Card
« Reply #2 on: 2012/01/30, 20:13:18 »
Thanks a lot for your reply michaa7,

here it is

Code: [Select]
arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Online michaa7

  • User
  • Posts: 2.318
[Solved] No microphone input on HDA Intel Card
« Reply #3 on: 2012/01/31, 00:47:46 »
and

$ alsamixer / F4

what devices show up?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

delta9

  • Guest
[Solved] No microphone input on HDA Intel Card
« Reply #4 on: 2012/01/31, 13:46:54 »
that would be

Code: [Select]
Mic Boost - Capture - Digital - Input Source - Internal Mic Boost[/quote]

Online michaa7

  • User
  • Posts: 2.318
[Solved] No microphone input on HDA Intel Card
« Reply #5 on: 2012/01/31, 14:27:26 »
taken from "http://ubuntuforums.org/showthread.php?t=1386425"

Quote
You need to put the mute on your mic if the option is there. That way it is not directly fed to the speakers. It will still be recorded, always has been for me on cards with the capabilities.

 If it does not have a mute don't worry, some don't. Then you will need to set it as capture. The ones without mute it usually stops a direct feed to the speakers when enabling capture. My X-Fi for example has no mute but has capture to check off.

 If you don't have a check box for capture you need to select it in the actual capture "channel" for the mixer.

 Like with Kmix you want to got to Settings>Configure Channels, then choose capture. It has a drop down, select mic on it and crank the volume on the mic and you should be all set. There may also be an option to expose a mic boost in your mixer.

 If you do all that and the levels are still low you can build an Alsa mapping to boost the mic levels pretty easily and then send it to the capture.

 I hope this helps.


If this does not help: Do all of the input devices (alsamixer / F4) have a volume bar?

EDIT://

maybe it's related (did it work with an 3.0 kernel?):
https://lkml.org/lkml/2011/11/2/82
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

delta9

  • Guest
[Solved] No microphone input on HDA Intel Card
« Reply #6 on: 2012/02/04, 21:21:06 »
Ok issue solved.
Michaa7, your last post helped a lot.

The internal mic worked by adding to /etc/modprobe.d/alsa-base.conf this line
Code: [Select]
options snd-hda-intel model=asus-mode4

(i have a lenovo notebook by the way)

Now, the tricky part was that when adding this line, an "internal mic" bar appears. Which is not working. The real internal mic is actually assigned to the "Digital" bar, something that was mentioned to the link of your last post.

Thanks a lot for your time and effort, much appreciated.

Online michaa7

  • User
  • Posts: 2.318
[Solved] No microphone input on HDA Intel Card
« Reply #7 on: 2012/02/09, 16:24:21 »
Glad I could help.

BTW: It would be a good idea to report this solution together with your laptops specs to the alsa-devel mailing list. This way this solution could be added to the list of quirks for the respectiv model. And in some future alsa version your quirk will work out of the box.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake