Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] (solved)No sound 3.9-0.towo.2-siduction-amd64  (Read 10339 times)

Offline michaa7

  • User
  • Posts: 2.321
[EN] RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade to 3.
« Reply #15 on: 2013/05/10, 13:19:37 »
Now after reading piper's advice I realize that I possibly was focused on alsa/hda_intel too much. Maybe the culprit is not alsa but kde.

Did you try to play a (.wave-) file with "aplay" directly (or any other player not relying on kde/phonon such as the commandline player "moc"? I think moc is a siduction standard package. So all you have to do is to open a VT, type "mocp" (music_on_commandline_play) and navigate to a song within the moc_ncurses_shell)
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

dlalias2k1

  • Guest
RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade to 3.
« Reply #16 on: 2013/05/11, 02:39:45 »
Did as requested, No change in lack of sound on the new kernel.

Phonon is reporting that I have the gstreamer and vlc backends installed. As for your command:

apt-cache policy phonon-backend-null
phonon-backend-null:
  Installed: (none)
  Candidate: 4:4.6.0.0-3
  Version table:
     4:4.6.0.0-3 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        500 ftp://ftp.us.debian.org/debian/ unstable/main amd64 Packages

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade to 3.
« Reply #17 on: 2013/05/11, 02:48:17 »
Quote

apt-cache policy phonon-backend-null
phonon-backend-null:
Installed: (none)
Candidate: 4:4.6.0.0-3
Version table:
4:4.6.0.0-3 0
500 http://http.debian.net/debian/ unstable/main amd64 Packages
500 ftp://ftp.us.debian.org/debian/ unstable/main amd64 Packages



That's how it should look, thanks.

I am out of options, not sure if kernel related or not
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade to 3.
« Reply #18 on: 2013/05/11, 02:55:06 »
What I would do is download the latest test iso

http://test.siduction.org/iso/siduction/kde/13_05_10_0704/

that has kernel 3.9-1 and see if sound works in live mode
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

dlalias2k1

  • Guest
RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade to 3.
« Reply #19 on: 2013/05/11, 04:23:00 »
I couldn't get the test iso to boot into KDE. It would go to a black screen with regular boot and with Safegfx mode. I could jump to another console, but ctrl-alt-f7 never finished loading the DisplayManager.

But in other news, Messing with audio and mocp, I did discover something. Previously audio was controlled via Master and PCM channels.
Under the new kernel with the non-Stac92xx audio, Sound IS working now.
While the speaker channel wasn't muted it didn't have audible sound (the channel was set at half volume on the slider) With all the sliders maxed, I do have sound, but it's not quite as loud as it was under the earlier kernel for some reason.

Offline michaa7

  • User
  • Posts: 2.321
Re: RE: Re: RE: Re: RE: Re: RE: No sound since dist-upgade t
« Reply #20 on: 2013/05/11, 10:40:52 »
Quote from: "dlalias2k1"
...
But in other news, Messing with audio and mocp, I did discover something. Previously audio was controlled via Master and PCM channels.
Under the new kernel with the non-Stac92xx audio, Sound IS working now.
While the speaker channel wasn't muted it didn't have audible sound (the channel was set at half volume on the slider) With all the sliders maxed, I do have sound, but it's not quite as loud as it was under the earlier kernel for some reason.


So your problem seems partly solved (does it work now with KDE?). But if the max volume isn't as satisfying as it was with the older driver it's still worth a bug report with all the details to http://alsa-project.org/main/index.php/Mailing-lists#alsa-devel_at_alsa-project.org (as mentioned above).
Ok, you can't code, but you still might be able to write a bug report for Debian's sake