Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED]lost kde usb mount  (Read 9414 times)

Ercolinux

  • Guest
[EN] [SOLVED]lost kde usb mount
« on: 2013/10/02, 18:52:47 »
Hello to all community, this is my first post here. My system is an aptosid box, but I want to stay on the edge with kde, so I'm using kdenext repository. In addition I always like to follow discussion here in the forums, technical expertize is often very high.
For some reason not clear to me, since some days I lost kde 4.11.1 ability to mount any usb HD (usbpen, mp3, externalHdisk,etc). Plug in an usbpen, with fdisk -l I see the relative entry in /dev/sdX, but kde does not mount it. I have to do myself by command line.
Any hints where/what to check ?
Thanks in advance

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
RE: lost kde usb mount
« Reply #1 on: 2013/10/02, 20:22:31 »
Hi Ercolinux, and welcome!

On the right end of your KDE panel, just to the left of the clock, are you able to see the device notifier icon?  You might need to click a small triangle there to expose it.  It is actually a widget in the plasma-desktop toolkit, and possibly you have accidentally removed it.  If that is the case, you can (a) unlock widgets, (b) "Add Widgets" and then choose the device notifier, and (c) lock the widgets again.

Some brave souls run their KDE desktop with widgets unlocked all the time, but personally I have found that to be the path to a damaged workspace, so I keep the widgets locked full time.  ;)
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Ercolinux

  • Guest
RE: lost kde usb mount
« Reply #2 on: 2013/10/02, 23:28:10 »
Thanks dibl.
I have device notifier icon in the tray. I also tried adding a new one on the desktop, but no change, notifier does not "see" any device plugged in.
By the way, thanks for the hint on "lock the widgets", I didn't understand the real meaning : now I locked.
Hoping You have other hint to solve the issue :-)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
RE: lost kde usb mount
« Reply #3 on: 2013/10/03, 08:43:40 »
Does
Code: [Select]
apt-mark showholdreturn anything?

greetz
devil

Online samoht

  • User
  • Posts: 480
Re: lost kde usb mount
« Reply #4 on: 2013/10/03, 12:16:17 »
Hello, siduction community

Would like to join this thread and, at first, confirm all of @Ercolinux 's aforementioned findings.
Let me add some related observations:
In dolphin there is no devices section on the side bar.
In krusader are no available devices
(German forum: http://forum.siduction.org/index.php?topic=3858).
My box:
Fully upgraded siduction, kdenext repo included, no packages on hold,
several partitions (ext4, fat32, ntfs, hfsplus) on two internal and one external (eSATA) hard disks.
Code: [Select]
# ls -al /dev/disk/by-label/
insgesamt 0
drwxr-xr-x 2 root root 340 Okt  3 12:57 .
drwxr-xr-x 5 root root 100 Okt  3 11:29 ..
lrwxrwxrwx 1 root root  10 Okt  3 10:20 BergLoewe -> ../../sda1
lrwxrwxrwx 1 root root  10 Okt  3 12:57 BigData_ntfs -> ../../sdc3
lrwxrwxrwx 1 root root  10 Okt  3 10:20 DATEN -> ../../sdb3
lrwxrwxrwx 1 root root  10 Okt  3 12:57 ExtDaten -> ../../sdc8
lrwxrwxrwx 1 root root  11 Okt  3 12:57 ExtEight -> ../../sdc10
lrwxrwxrwx 1 root root  10 Okt  3 12:57 ExtSid -> ../../sdc6
lrwxrwxrwx 1 root root  10 Okt  3 12:57 ExtSUSE -> ../../sdc7
lrwxrwxrwx 1 root root  10 Okt  3 12:57 Lion -> ../../sdc2
lrwxrwxrwx 1 root root  10 Okt  3 10:20 openSUSE -> ../../sdb7
lrwxrwxrwx 1 root root  10 Okt  3 10:20 Seven -> ../../sdb1
lrwxrwxrwx 1 root root  10 Okt  3 10:20 sid -> ../../sdb6
lrwxrwxrwx 1 root root  10 Okt  3 12:57 SnowLeo -> ../../sdc9
lrwxrwxrwx 1 root root  10 Okt  3 12:57 swap -> ../../sdc5
lrwxrwxrwx 1 root root  10 Okt  3 10:20 Work -> ../../sdb2
lrwxrwxrwx 1 root root  10 Okt  3 12:57 ZwillingPuma -> ../../sdc1
There is no such problem in another siduction installation (not upgraded for about one week) and an openSUSE upgraded today to kde 4.11.2.
I have no clue, unfortunately, which packages are responsible for device recognition.
Greetings
Tom
« Last Edit: 2013/11/10, 01:34:20 by ayla »

Ercolinux

  • Guest
RE: Re: lost kde usb mount
« Reply #5 on: 2013/10/03, 18:07:55 »
Hi Devil,
yes I have some package in hold, mainly linked to Nvidia proprietary drivers to re-build in case of xserver update.
Code: [Select]

$ apt-mark showhold
kde-config-gtk-style
lib32v4l-0
skype:i386
xserver-xorg
xserver-xorg-core

Hello samoht,
I dont  know, in this case, if to say I'm happy to not be the only one :-)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
RE: Re: lost kde usb mount
« Reply #6 on: 2013/10/03, 20:05:29 »
In systemsettings > Startup and Shutdown > Service Manager, is the Removable Device Automounter service checked and running?  If not, you need to check it and restart the service.

In systemsettings > Removable Devices, do you have a check in "Enable automatic mounting of removable media"?  If you do, uncheck it and restart KDE and see if the behavior has changed.

I have 4 siduction KDE systems all updated as of yesterday or today, and USB device mounting works correctly on all of them, with the above settings.  I don't know much about how this part of Linux and KDE works from an engineering view -- I believe udisks2 is involved.  If you still have an issue then possibly some googling on that could help -- it looks like the Arch wiki has a lot of coverage on the topic.

@samoht, in the dolphin 4.11.2 menu, if I click View > Panels > Places, it will toggle the left panel items on or off.  When it is on, it shows both the places and also the devices and partitions.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Ercolinux

  • Guest
RE: Re: lost kde usb mount
« Reply #7 on: 2013/10/03, 21:43:00 »
Thanks dibl, googling I already saw the point on needed service running and uncheck on Automonter - all seems fine here.
What about udisks2 : is this requested by kde 4.11.x or by siduction? Because i do not have it. aptosid uses udisks - checked and working on my system using a Virtual Machine and LiveCD -

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
Re: RE: Re: lost kde usb mount
« Reply #8 on: 2013/10/03, 22:31:52 »
Quote from: "Ercolinux"
... aptosid uses udisks - checked and working on my system using a Virtual Machine and LiveCD -



Hmmmmmm -- aptosid is Debian sid, same as siduction, so it should be like this:

Code: [Select]
root@imerabox:/# apt-cache policy udisks2
udisks2:
  Installed: 2.1.1-1
  Candidate: 2.1.1-1
  Version table:
 *** 2.1.1-1 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Unless there is something about running on a VM that would be different, but I don't think so.

udisks is also installed here, BTW, again from debian sid:

Code: [Select]
root@imerabox:/# apt-cache policy udisks
udisks:
  Installed: 1.0.4-8+b1
  Candidate: 1.0.4-8+b1
  Version table:
 *** 1.0.4-8+b1 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Crust

  • Guest
RE: Re: RE: Re: lost kde usb mount
« Reply #9 on: 2013/10/04, 07:42:44 »
I can confirm this issue.  I have lost all ability to mount anything through usb.  When looking at dmesg, it looks like the partitions aren't even detected.

Crust

  • Guest
RE: Re: RE: Re: lost kde usb mount
« Reply #10 on: 2013/10/04, 08:12:21 »
It must have been a kernel thing - I dist-upgraded (it included a kernel update) and things are working again.

Online samoht

  • User
  • Posts: 480
Re: lost kde usb mount
« Reply #11 on: 2013/10/04, 09:52:49 »
Thank you so much, @dibl.
Your hint regarding udisks2 "war Gold wert"  :wink: .
Installing udisks2 solved this issue.
I did not notice, that/when I "lost" this package.
Update:
udisks2 not needed any longer.
Code: [Select]
kde4libs (4:4.11.2-0r1) UNRELEASED; urgency=low

  * Use again udisks instead of udiks2.

 -- José Manuel Santamaría Lema <panfaust@gmail.com>  Fri, 04 Oct 2013 00:33:56 +0200

...

kde4libs (4:4.11.1-90r0) UNRELEASED; urgency=low

  * Add dont_leak_sockets.diff.
  * Build against udisks2.

 -- José Manuel Santamaría Lema <panfaust@gmail.com>  Sun, 22 Sep 2013 18:54:31 +0200
Greetings
Tom

Ercolinux

  • Guest
RE: Re: lost kde usb mount
« Reply #12 on: 2013/10/04, 17:48:57 »
thanks samoht for sharing this.
kde upgrade solved the issue also here.