Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved] Radeon R7 260X defaults to extended desktop - how to disable  (Read 3790 times)

Offline OppaErich

  • OLE
  • User
  • Posts: 382
Hi,


my AV amp died and I replaced it. The new one shows active inputs even when powered off. I have my desktop monitor connected via DVI and the big screen is connected via this AV amp using the HDMI port, this is for comfy gaming (Win7).


X comes up with extended desktop. Took me a while to realize (where is my icedove window ? :)  ), found out when I powered on the big screen and saw the desktop background on it. This seems to start at grub stage already as the grub screen was in 1080p and is now in some low res.


How do I disable this ?


Happy sunday,
Stephan
« Last Edit: 2015/03/09, 16:49:31 by OppaErich »

Offline musca

  • User
  • Posts: 725
  • sid, fly high!
Hallo OppaErich,

KDE can save its config as default.

If your desktop can't do this, you can create your config at startup.
xrandr can disable a monitor on the fly and you can script it.


I would prefer to add an ignore option like this to my /etc/X11/xorg.conf.d/dualhead.conf:
# /etc/X11/xorg.conf.d/dualhead.conf
# Identifiers taken from xrandr

Section "Monitor"
    Identifier      "DVI-I-1"
EndSection

Section "Monitor"
    Identifier      "HDMI-0"
    Option          "RightOf"       "DVI-I-1"
    Option          "ignore"         "true"
EndSection

# Ende dualhead.conf


greetings
musca
β€žEs irrt der Mensch, solang er strebt.β€œ  (Goethe, Faust)

Offline OppaErich

  • OLE
  • User
  • Posts: 382

If your desktop can't do this,
...
F..rigging hell yeah. Haven't thought of that, GNOME here but it can do this too as I've just found out.

And I was googling MAO and found only tutorials how to enable this.


Thank you,
Stephan