Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] 2.6.38 + ath9k + AR5008 = langsame Verbindung  (Read 4214 times)

schlumbl

  • Guest
[DE] 2.6.38 + ath9k + AR5008 = langsame Verbindung
« on: 2011/03/19, 10:21:17 »
Hallo allerseits!

Seit die .38er-Serie in aptosid aufgeschlagen ist, ist die Downloadgeschwindigkeit meiner Wlan-Karte am unteren Rand der Messbarkeit (z.B. benötigt ein tarball von 4 MB per wget etwa 30 (!) Stunden).

Mein Chipsatz:
Code: [Select]
$ lspci | grep Network
01:09.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)


Mein workaround ist derzeit bei (d.h. vor, sonst dauert's die oben genannten 30 Stunden) jedem Kernelupgrade den aktuellsten ath9k-Treiber von http://wireless.kernel.org/en/users/Download#Directly_downloading_the_tarball zu holen, und nach der dortigen Anleitung zu bauen und zu installieren.

Da dass bei der derzeitigen Frequenz der Kernelupgrades doch etwas unkomfortabel ist, lautet meine Frage ob jemand mit dem gleichen Problem evtl. eine dauerhaftere Lösung gefunden hat. D.h. falls jemand dasselbe Phänomen hat, natürlich.

Grüße aus Balin,

schlumbl


EDIT: Sorry für den Leer-Post. Erst wurde der Text nicht gespeichert, plötzlich ging's dann doch...

wromey

  • Guest
2.6.38 + ath9k + AR5008 = langsame Verbindung
« Reply #1 on: 2011/03/20, 06:50:06 »
Bei mir ist mit

AR928X

das Verhalten ähnlich: Langsame Verbindung, nach einer gewissen Zeit bicht der Datenfluss ab, obwohl die WLAN-Verbindung noch da ist.

Wolfgang

LaCa

  • Guest
2.6.38 + ath9k + AR5008 = langsame Verbindung
« Reply #2 on: 2011/03/24, 21:54:35 »
Hallo zusammen,
bei mir ist es ähnlich. Die WLan-Verbindung wird immer langsamer und kommt fast zum erliegen. Bei mir ist gleichzeitig auch die Lan-Verbindung betroffen. Diese wird ebenfalls langsamer.

lspci | grep Network
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
lspci | grep Eth
02:00.0 Ethernet controller: Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)

Beim Suchen im Netz bin ich auf folgendes gestoßen:

als root
   "rmmod -f ath9k"
&
   "modprobe ath9k nohwcrypt=1"
eingeben.

Damit läuft mein Wlan und mein Lan wieder mit einer Geschwindigkeit, die der mit Kernel 2.6.37 entspricht.
Nur nach jedem Booten müssen die beiden Befehle wieder eingegeben werden.
Schön wäre ja ein Skript, welches man in den Autostart packt, aber ich scheitere noch daran, das es als root ausgeführt werden muss.

Gruß LaCa

Offline hschn

  • User
  • Posts: 118
2.6.38 + ath9k + AR5008 = langsame Verbindung
« Reply #3 on: 2011/03/25, 07:47:37 »
Hallo,
ich hatte vor einiger Zeit ein ähnliches Problem nach dem Einbau meiner Atheros AR5212 Karte.
Die Lösung bei mir bestand darin, im BIOS die Werte für die IRQs auf automatisch zu stellen.
Seit dem läuft alles problemlos.
Gruß
hschn
Mögen hätt' ich schon wollen, aber dürfen habe ich mich nicht getraut (Karl Valentin)

Offline ralul

  • User
  • Posts: 1.814
2.6.38 + ath9k + AR5008 = langsame Verbindung
« Reply #4 on: 2011/03/25, 09:57:10 »
@LaCa, dafür gedacht ist
/etc/rc.local

dieses wird aufgerufen von
/etc/init.d/rc.local

wenn es verlinkt ist als
/etc/rc5.d/S99rc.local
(99 kann niedriger sein, gesetzt durch insserv)
experiencing siduction runs better than my gentoo makes me know I know nothing

schlumbl

  • Guest
2.6.38 + ath9k + AR5008 = langsame Verbindung
« Reply #5 on: 2011/03/31, 10:37:55 »
Eine dauerhaftere Lösung ist auch einfach die Zeile
Code: [Select]
options ath9k nohwcrypt=1
in einer Datei /etc/modprobe.d/ath9k.conf zu hinterlegen.

Läuft bei mir problemlos.