Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  A silent bug fix release, 2023.1.1 [EN / DE]  (Read 9899 times)

Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 1.000
A silent bug fix release, 2023.1.1 [EN / DE]
« on: 2023/09/10, 19:58:18 »
We announce a silent bug fix release.
After that little trouble with grub and our chroot-helper, we decided to release a new iso.
We integrated the changes in our siduction-btrfs script, introduced by grub (https://github.com/siduction/siduction-btrfs/pull/1), thank you fbermel!
towo reworked the chroot-helper, it works now also in our nox-iso!
And we built it with the new grub (which was causing that little trouble out there).
A new kernel for sure is also there (6.5.2-1).
So in the hope that the little hurricane is over, have fun!

https://siduction.org/installation-media/

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Nach dem kleinen Problem mit grub und unserem chroot-helper haben wir uns entschlossen, ein neues iso zu veröffentlichen.
Wir haben die Änderungen in unserem siduction-btrfs-Skript integriert, die von grub (https://github.com/siduction/siduction-btrfs/pull/1) eingeführt wurden, vielen Dank an fbermel!
towo hat den chroot-helper überarbeitet, er funktioniert jetzt auch in unserem nox-iso!
Und wir haben es mit dem neuen grub gebaut (der das kleine Probllem verursacht hat).
Ein neuer Kernel ist natürlich auch dabei (6.5.2-1).
In der Hoffnung, dass der kleine Sturm vorbei ist, viel Spaß!


https://siduction.org/installation-media/
« Last Edit: 2023/09/10, 20:30:05 by hendrikL »

Offline bevo

  • User
  • Posts: 333
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #1 on: 2023/09/11, 15:17:50 »
Da scheint es ein Problem zu geben.
Booted auf diesem PC, aber nicht auf meinem Lenovo Laptop.
Die Version vom 23.8. booted auf beiden Systemen.

Offline ro_sid

  • User
  • Posts: 261
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #2 on: 2023/09/11, 15:58:14 »
Also als Live-Fassung bootet es auf meinem Lenovo Thinkpad problemlos. Allerdings gibt es natürlich eine breite Auswahl an Lenovo Laptops.
Auch eine aktuelle (aus MoW) auf den neuesten Stand gebrachte installierte Version macht mir keine Schwierigkeiten.

(Etwas) mehr Information würde helfen.

Offline bevo

  • User
  • Posts: 333
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #3 on: 2023/09/11, 16:32:05 »
Alles mit Live-iso EFI. An der Hardware kann also nicht liegen. Der Stick wurde mit der gleichen Methode (dd if=) erstellt.

Offline ro_sid

  • User
  • Posts: 261
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #4 on: 2023/09/11, 16:49:52 »
Aber wo/wann versagt er, der Stick? Bootauswahl? Booten? Desktop-Anzeige?
Spezielle Hardware (Touchscreen etc.)?
Es hilft auch, beim Kernelaufruf von grub das "quiet" herauszunehmen. (Edit-Mode 'e'.)
[Und ist es sichergestellt, daß der Boot-Modus "EFI" ist? Manchmal stört es, wenn CSM aktiv ist.]

Offline bevo

  • User
  • Posts: 333
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #5 on: 2023/09/11, 16:55:25 »
Da es mit der alten Version geht und mit der zweiten nicht, liegt es doch eindeutig an der ISO. 

Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 1.000
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #6 on: 2023/09/11, 17:36:13 »
nö, nicht eindeutig.

dann gib uns doch mal die nötigen Informationen, mit einem funktionierenden stick booten und dann mal beherzt inxi -F und die Ausgabe hier rein. lenovo hat unendlich viele laptops mit unendlich vielen Konfigurationen. Und das beste, wie sollen wir wissen was nicht geht, geht nicht sagt rein gar nichts aus. Ist es die Grafik, bleibt es schon beim booten hängen, also was funktioniert nicht?

Offline edlin

  • User
  • Posts: 599
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #7 on: 2023/09/11, 17:58:01 »
Da es mit der alten Version geht und mit der zweiten nicht, liegt es doch eindeutig an der ISO.
Dann ist das Problem ja geklärt, das ISO ist schuld.
Sorry, das erinnert mich an eine Karikatur aus den 70ern:
Ein Mann betätigt die Klospülung und das Haus stürzt ein. In der letzten Zeichnung wird klar: Es gab ein großes Erdbeben und keinen Zusammenhang mit der Klospülung.
@hendrikL hat es ja schon geschrieben: Wir wissen absolut Nichts über deine Installation, ext4 oder btrfs, deine Vorgehensweise, deine Einstellungen (Kompatibilitätsmodus) etc.

Solltest du allerdings sicher sein, dass es am ISO liegt, dann gib @towo oder einem anderen Mitglied (@Devil macht gerade Urlaub, also verschonen) des Siduction-Teams einen Tipp. Es sollte kein Problem sein, neue ISOs zu bauen, wenn der Fehler bekannt ist.
 
edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.964
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #8 on: 2023/09/11, 19:48:36 »
Tja, was soll ich sagen, KDE ISO (per dd und auch Ventoy) bootet hier auf 5 Rechnern.
Mehr  Hardware zum Testen habe ich nicht, ergo bringt auch ein neues ISO nichts, solange ich nicht weiss, was nicht funktioniert.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bevo

  • User
  • Posts: 333
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #9 on: 2023/09/12, 14:44:44 »
Calm down  ;)

Ich habe die Lösung, aber keine Erklärung!
Hier mein Vorgehen:
der selbe Stick, die selben Parameter 1x mit ISO alt, 1x mit ISO neu.
ISO alt booted normal
ISO neu booted nicht, keine Anzeige, schwarzer Bildschirm
wenn ich jetzt im BIOS UEFI/Legacy Boot Priority > [UEFI First] in [Legacy First] ändere, booted ISO neu !

Eine Frage bleibt ungeklärt; warum verhält sich ISO neu anders ??
System:
Host: X240 Kernel: 6.5.2-1-siduction-amd64 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.7 Distro: siduction 22.1.2 Masters_of_War - kde
- (202303142333)
Machine:
Type: Laptop System: LENOVO product: 20AMS3PU16 v: ThinkPad X240
serial: <superuser required>
Mobo: LENOVO model: 20AMS3PU16 serial: <superuser required> UEFI: LENOVO
v: GIET76WW (2.26 ) date: 08/27/2014
Battery:
ID-1: BAT0 charge: 16.4 Wh (99.4%) condition: 16.5/23.2 Wh (70.9%)
ID-2: BAT1 charge: 21.8 Wh (100.0%) condition: 21.8/23.2 Wh (93.9%)
CPU:
Info: dual core model: Intel Core i5-4300U bits: 64 type: MT MCP cache:
L2: 512 KiB
Speed (MHz): avg: 799 min/max: 800/2900 cores: 1: 798 2: 800 3: 800 4: 800
Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Display: wayland server: X.Org v: 1.23.2 with: Xwayland v: 23.2.0
compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
dri: crocus gpu: i915 resolution: 1366x768~60Hz
API: OpenGL v: 4.6 Mesa 23.1.7-1 renderer: Mesa Intel HD Graphics 4400
(HSW GT2)
Audio:
Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
API: ALSA v: k6.5.2-1-siduction-amd64 status: kernel-api
Server-1: PipeWire v: 0.3.79 status: active
Network:
Device-1: Intel Ethernet I218-LM driver: e1000e
IF: enp0s25 state: down mac: 28:d2:44:73:c7:cb
Device-2: Intel Wireless 7260 driver: iwlwifi
IF: wlan0 state: up mac: e8:2a:ea:07:e8:ce
IF-ID-1: wwan0 state: down mac: 6e:bb:54:ba:98:35
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb type: USB
Report: hciconfig ID: hci0 state: up address: E8:2A:EA:07:E8:D2 bt-v: 4.0
Drives:
Local Storage: total: 238.47 GiB used: 48.12 GiB (20.2%)
ID-1: /dev/sda vendor: Samsung model: MZ7TE256HMHP-000L7 size: 238.47 GiB
Partition:
ID-1: / size: 32.28 GiB used: 16.87 GiB (52.3%) fs: ext4 dev: /dev/sda2ID-2: /boot/efi size: 299.4 MiB used: 6.2 MiB (2.1%) fs: vfat
dev: /dev/sda1
Swap:
Alert: No swap data was found.
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (rpm): fan-1: 0
Info:
Processes: 207 Uptime: 20m Memory: total: 8 GiB available: 7.65 GiB
used: 1.73 GiB (22.6%) Shell: Bash inxi: 3.3.29


Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 1.000
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #10 on: 2023/09/12, 14:54:54 »
verstehe ich das richtig, es kommt noch nicht einmal zur Sprach- und Bootauswahl, oder bootet es aber der bildschirm bleibt schwarz nach dem der Kernel uns so weiter durch ist und man die grafische Oberfläche sehen müsste?

Offline edlin

  • User
  • Posts: 599
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #11 on: 2023/09/12, 15:33:37 »
Ich kann nur für mein System sprechen. Bei mir ist CSM im UEFI/Bios disabled. Meine olle SD-Karte mit dem per dd drauf gebügelten Iso wird und wurde als UEFI gekennzeichnet als Bootdevice erkannt und bootet(e) ohne Probleme. Ist hier mal was mit UEFI und Legacy durcheinander geraten?

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline bevo

  • User
  • Posts: 333
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #12 on: 2023/09/12, 16:14:57 »
@hendrikL  Ich wähle mit F12 das Boot-Menu und klicke den Stick; das war's Screen schwarz.

@edlin  Änderung an CSM hat den Fehler nicht beseitigt. Da sich das Problem beliebig wiederholen lässt, ist ein Durcheinander UEFI und Legacy wohl auszuschließen.

Online hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 1.000
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #13 on: 2023/09/12, 16:33:02 »
ich kann mir dies nur so erklären, daß es einen Fehler im ISO hat, sprich irgendwas beim Download schiefgelaufen ist oder beim Kopieren auf den Stick, wenn der Stick nicht selber das Problem ist.

Offline ro_sid

  • User
  • Posts: 261
Re: A silent bug fix release, 2023.1.1 [EN / DE]
« Reply #14 on: 2023/09/12, 16:50:43 »
ich kann mir dies nur so erklären, daß es einen Fehler im ISO hat, sprich irgendwas beim Download schiefgelaufen ist oder beim Kopieren auf den Stick, wenn der Stick nicht selber das Problem ist.
Das sollte sich doch leicht identifizieren lassen:
Vergleich des ISO-Abbildes mit der zugehörigen .md5 oder/und .sha256 Datei (Kommandos: md5sum bzw. sha256sum).
Damit sollte sich doch die Authentizität und Integrität überprüfen lassen.
Falls schon die Datei beschädigt war, fertig, Sonst für den Stick einfach die Datei per "dd" wieder als .iso-Datei herunterladen - nötigenfalls die Länge/Größe anpassen.
Falls alles übereinstimmt bitte sofort melden, dann ist die Download-Seite gehackt  :).