Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: Carnophage on 2022/07/04, 09:35:29

Title: [solved] lvm2 initramfs-tools hook fails
Post by: Carnophage on 2022/07/04, 09:35:29
After today's upgrade I seem to hit: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014314
Title: Re: lvm2 initramfs-tools hook fails
Post by: Mister00X on 2022/07/04, 09:40:08
Thanks for the heads up. All my systems use lvm, this would be very fatal for me.
Title: Re: lvm2 initramfs-tools hook fails
Post by: dpanter on 2022/07/04, 12:17:51
The simplest immediate fix is to pull lvm2 from testing.
Having apt-listbugs installed and reading the bug reports before committing to any update is a very good idea.

As of writing, assuming you have the testing repo enabled, the command/version would be
Code: [Select]
sudo apt install lvm2=2.03.11-2.1
Title: Re: lvm2 initramfs-tools hook fails
Post by: tomsiduction on 2022/07/04, 16:29:54
Hello and thank you

That was the fix
Title: Re: lvm2 initramfs-tools hook fails
Post by: Mte90 on 2022/07/04, 17:15:48
I executed:

Code: [Select]
cp -a /lib/udev/rules.d/69-lvm.rules /lib/udev/rules.d/69-lvm-metad.rules
Reported in the debian ticket that seems fix the issue on updating to the latest kernel as https://forum.siduction.org/index.php?topic=8646.msg69073#msg69073
Title: Re: lvm2 initramfs-tools hook fails
Post by: sidrak on 2022/07/04, 23:47:31
FYI it's fixed now
Title: Re: [solved] lvm2 initramfs-tools hook fails
Post by: tomsiduction on 2022/07/05, 11:39:06
Hello
Unfortunately I get now
Code: [Select]
depmod: WARNING: could not open modules.builtin.modinfo at /var/tmp/mkinitramfs_PGxXYF/lib/modules/5.16.9-1-siduction-amd64: No such file or directory



Can this be ignored?
Title: Re: [solved] lvm2 initramfs-tools hook fails
Post by: michaa7 on 2022/07/05, 11:55:06
I did.

Modul is building. System booting. X+nvidia working.
Title: Re: [solved] lvm2 initramfs-tools hook fails
Post by: Mister00X on 2022/07/05, 13:46:23
Hello
Unfortunately I get now
Code: [Select]
depmod: WARNING: could not open modules.builtin.modinfo at /var/tmp/mkinitramfs_PGxXYF/lib/modules/5.16.9-1-siduction-amd64: No such file or directory


Can this be ignored?
This appears to be https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014319
Unfortunately I have no idea if this can be ignored or not.
For now I have downgraded kmod and put it on hold.
Title: Re: [solved] lvm2 initramfs-tools hook fails
Post by: dibl on 2022/07/05, 13:52:37
Quote from: Mister00X
....
This appears to be https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014319
Unfortunately I have no idea if this can be ignored or not. ...

I see it is categorized "Minor".  I have just now upgraded two very different systems here -- one laptop with Intel graphics and one desktop with Nvidia graphics, and they both are working trouble-free.
Title: Re: [solved] lvm2 initramfs-tools hook fails
Post by: Mister00X on 2022/07/05, 13:55:40
Quote
I see it is categorized "Minor".  I have just now upgraded two very different systems here -- one laptop with Intel graphics and one desktop with Nvidia graphics, and they both are working trouble-free.

Oh yes you're right I completely ignored the severity of that report.
In that case I will unhold kmod again.