Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [solved] Some packages kept back  (Read 557 times)

Offline orinoco

  • User
  • Posts: 198
  • Bullshit artist
[solved] Some packages kept back
« on: 2022/07/11, 00:55:16 »
Hello,

since some weeks three packages are kept back:
Code: [Select]
$ LANG=C sudo apt -V full-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
   kde-full (5:121 => 5:123)
   kde-standard (5:121 => 5:123)
   polkit-kde-agent-1 (4:5.24.4-1 => 4:5.24.5-1)
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
To get an idea what's maybe wrong:
Code: [Select]
$ LANG=C sudo apt -f install kde-full
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 polkitd : Depends: libpolkit-agent-1-0 (= 0.105-33) but 0.112-5.3.1~really-0.105-8 is to be installed
           Depends: libpolkit-gobject-1-0 (= 0.105-33) but 0.112-5.3.1~really-0.105-8 is to be installed
E: Unable to correct problems, you have held broken packages.

Any idea how I can fix this?
« Last Edit: 2022/07/12, 13:51:23 by orinoco »

Online dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.213
    • Land of the Buckeye
Re: Some packages kept back
« Reply #1 on: 2022/07/11, 03:42:11 »
You might have some configuration issue -- I don't see that problem here.

Code: [Select]
don@dibl-HP350:~$ sudo apt policy kde-full
kde-full:
  Installed: 5:123
  Candidate: 5:123
  Version table:
 *** 5:123 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
don@dibl-HP350:~$ sudo apt policy polkitd
polkitd:
  Installed: 0.105-33
  Candidate: 0.105-33
  Version table:
 *** 0.105-33 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline der_bud

  • User
  • Posts: 1.037
  • member
Re: Some packages kept back
« Reply #2 on: 2022/07/11, 07:32:59 »
Looks like those '~really'-versioned packages of libpolkit stuff are the reason, they were probably an older fix for something and now they pretend to have a higher version number than the real current packages. To check this, enter 'apt policy libpolkit-agent-1-0' and you might see installed the 0.112~really packages probably from a fixes or not longer active repository, and the debian 0.105-33 packages available but with a lower priority.
You can install the current packages giving apt the exact version after an equal-sign, like:
Code: [Select]
apt install --reinstall libpolkit-agent-1-0=0.105-33 libpolkit-gobject-1-0=0.105-33
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline orinoco

  • User
  • Posts: 198
  • Bullshit artist
Re: Some packages kept back
« Reply #3 on: 2022/07/12, 02:14:43 »
apt policy
Code: [Select]
$ LANG=C apt policy libpolkit-agent-1-0 libpolkit-gobject-1-0
libpolkit-agent-1-0:
  Installed: 0.112-5.3.1~really-0.105-8
  Candidate: 0.112-5.3.1~really-0.105-8
  Version table:
 *** 0.112-5.3.1~really-0.105-8 100
        100 /var/lib/dpkg/status
     0.105-33 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
libpolkit-gobject-1-0:
  Installed: 0.112-5.3.1~really-0.105-8
  Candidate: 0.112-5.3.1~really-0.105-8
  Version table:
 *** 0.112-5.3.1~really-0.105-8 100
        100 /var/lib/dpkg/status
     0.105-33 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
apt install --reinstall
Code: [Select]
$ LANG=C sudo apt -V install libpolkit-agent-1-0=0.105-33 libpolkit-gobject-1-0=0.105-33 --reinstall
[sudo] password for frank: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be DOWNGRADED:
   libpolkit-agent-1-0 (0.112-5.3.1~really-0.105-8 => 0.105-33)
   libpolkit-gobject-1-0 (0.112-5.3.1~really-0.105-8 => 0.105-33)
0 upgraded, 0 newly installed, 2 downgraded, 0 to remove and 3 not upgraded.
Need to get 78.8 kB of archives.
After this operation, 24.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 https://deb.debian.org/debian unstable/main amd64 libpolkit-gobject-1-0 amd64 0.105-33 [49.7 kB]
Get:2 https://deb.debian.org/debian unstable/main amd64 libpolkit-agent-1-0 amd64 0.105-33 [29.1 kB]
Fetched 78.8 kB in 0s (192 kB/s)           
dpkg: warning: downgrading libpolkit-gobject-1-0:amd64 from 0.112-5.3.1~really-0.105-8 to 0.105-33
(Reading database ... 436924 files and directories currently installed.)
Preparing to unpack .../libpolkit-gobject-1-0_0.105-33_amd64.deb ...
Unpacking libpolkit-gobject-1-0:amd64 (0.105-33) over (0.112-5.3.1~really-0.105-8) ...
dpkg: warning: downgrading libpolkit-agent-1-0:amd64 from 0.112-5.3.1~really-0.105-8 to 0.105-33
Preparing to unpack .../libpolkit-agent-1-0_0.105-33_amd64.deb ...
Unpacking libpolkit-agent-1-0:amd64 (0.105-33) over (0.112-5.3.1~really-0.105-8) ...
Setting up libpolkit-gobject-1-0:amd64 (0.105-33) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-33) ...
Processing triggers for libc-bin (2.33-7) ...
Scanning processes...                                                                                                                                                                                               
Scanning candidates...                                                                                                                                                                                             
Scanning processor microcode...                                                                                                                                                                                     
Scanning linux images...                                                                                                                                                                                           
 
Running kernel seems to be up-to-date.
 
Failed to check for processor microcode upgrades.
 
Restarting services...
 systemctl restart accounts-daemon.service polkitd.service udisks2.service
Service restarts being deferred:
 systemctl restart ModemManager.service
 
No containers need to be restarted.
 
User sessions running outdated binaries:
 orinoco @ session #3: plasma_session[17802]
 
No VM guests are running outdated hypervisor (qemu) binaries on this host.
apt full-upgrade
Code: [Select]
LANG=C sudo apt -V full-upgrade 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
   polkitd (0.105-33)
The following packages will be upgraded:
   kde-full (5:121 => 5:123)
   kde-standard (5:121 => 5:123)
   polkit-kde-agent-1 (4:5.24.4-1 => 4:5.24.5-1)
3 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 182 kB of archives.
After this operation, 308 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 https://deb.debian.org/debian unstable/main amd64 polkitd amd64 0.105-33 [88.9 kB]
Get:2 https://deb.debian.org/debian unstable/main amd64 polkit-kde-agent-1 amd64 4:5.24.5-1 [60.2 kB]
Get:3 https://deb.debian.org/debian unstable/main amd64 kde-standard amd64 5:123 [16.5 kB]
Get:4 https://deb.debian.org/debian unstable/main amd64 kde-full amd64 5:123 [16.5 kB]
Fetched 182 kB in 0s (480 kB/s)
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Changelogs werden gelesen... Fertig
Selecting previously unselected package polkitd.
(Reading database ... 436924 files and directories currently installed.)
Preparing to unpack .../polkitd_0.105-33_amd64.deb ...
Unpacking polkitd (0.105-33) ...
dpkg: error processing archive /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 trying to overwrite '/etc/pam.d/polkit-1', which is also in package policykit-1 0.112-5.3.1~really-0.105-8
Preparing to unpack .../polkit-kde-agent-1_4%3a5.24.5-1_amd64.deb ...
Unpacking polkit-kde-agent-1 (4:5.24.5-1) over (4:5.24.4-1) ...
Preparing to unpack .../kde-standard_5%3a123_amd64.deb ...
Unpacking kde-standard (5:123) over (5:121) ...
Preparing to unpack .../kde-full_5%3a123_amd64.deb ...
Unpacking kde-full (5:123) over (5:121) ...
Errors were encountered while processing:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt install --fixbroken
Code: [Select]
$ LANG=C sudo apt --fix-broken install Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  polkitd
The following NEW packages will be installed:
  polkitd
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/88.9 kB of archives.
After this operation, 308 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
(Reading database ... 436924 files and directories currently installed.)
Preparing to unpack .../polkitd_0.105-33_amd64.deb ...
Unpacking polkitd (0.105-33) ...
dpkg: error processing archive /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 trying to overwrite '/etc/pam.d/polkit-1', which is also in package policykit-1 0.112-5.3.1~really-0.105-8
Errors were encountered while processing:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline der_bud

  • User
  • Posts: 1.037
  • member
Re: Some packages kept back
« Reply #4 on: 2022/07/12, 11:33:06 »
afaik the first part looks okay so far while the last part tells us that the same "really"-something-stuff also happens to policykit-1. To the best of my knowledge I think you could try to fix it in the same manner, assure yourself with 'apt policy $packagename' what is installed versus what is available, and install the wanted ones with 'apt install $package=$version'. Perhaps look if any other *pol*something packages need this ;)

---
(edit: searching this forum I found a thread from 2016 dealing with 0.112-5.3.1~really-0.105-8,  see https://forum.siduction.org/index.php?topic=6226.msg51228#msg51228 , so I wonder why it happens _now_ on your system...)
« Last Edit: 2022/07/12, 11:40:38 by der_bud »
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline orinoco

  • User
  • Posts: 198
  • Bullshit artist
Re: Some packages kept back
« Reply #5 on: 2022/07/12, 13:50:36 »
This did the trick:

Code: [Select]
sudo apt -V install policykit-1=0.105-33 pkexec polkitd --reinstallThe following full upgrade finished well. Thanks for the support.
orinoco