Siduction Forum

Siduction Forum => Scripting & Kernelhacking => Scripting & Kernelhacking (EN) => Topic started by: Mte90 on 2014/05/07, 19:44:45

Title: (solved) Logitech C920 and xhci_hcd
Post by: Mte90 on 2014/05/07, 19:44:45
I've bought the Logitech C920, the first day work without problems.
The second it's not reconized and crash different softwares...
Dmesg:
Code: [Select]
[16605.282832] media: Linux media interface: v0.10[16605.289107] Linux video capture interface: v2.00
[16605.294727] usbcore: registered new interface driver uvcvideo
[16605.294734] USB Video Class driver (1.1.1)
[16916.772656] usb 3-5: new high-speed USB device number 14 using xhci_hcd[16918.008344] usb 3-5: New USB device found, idVendor=046d, idProduct=082d
[16918.008349] usb 3-5: New USB device strings: Mfr=0, Product=2, SerialNumber=1[16918.008351] usb 3-5: Product: HD Pro Webcam C920
[16918.008353] usb 3-5: SerialNumber: BDE8AF9F
[16918.008841] uvcvideo: Found UVC 1.00 device HD Pro Webcam C920 (046d:082d)
[16918.009287] input: HD Pro Webcam C920 as /devices/pci0000:00/0000:00:14.0/usb3/3-5/3-5:1.0/input/input21
[16918.239835] usbcore: registered new interface driver snd-usb-audio[16930.626616] usb 3-5: reset high-speed USB device number 14 using xhci_hcd
[16930.626691] xhci_hcd 0000:00:14.0: Setup ERROR: setup context command for slot 13.
[16930.626699] usb 3-5: hub failed to enable device, error -22
[16930.786387] usb 3-5: reset high-speed USB device number 14 using xhci_hcd
[16930.786410] xhci_hcd 0000:00:14.0: Setup ERROR: setup context command for slot 13.
[16930.786417] usb 3-5: hub failed to enable device, error -22
[16930.899669] usb 3-5: reset high-speed USB device number 14 using xhci_hcd
[16930.919028] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b1882960

a friend suggest me this patch for the kernel https://lists.ubuntu.com/archives/kernel-team/2014-March/040463.html (https://lists.ubuntu.com/archives/kernel-team/2014-March/040463.html)

Can anyone help me with this problem?
Title: Re: Logitech C920 and xhci_hcd
Post by: Mte90 on 2014/05/20, 16:54:45
http://www.mte90.net/2014/05/install-logitech-c920-on-debian-sid/

Resolved, missing some codecs :-D