Siduction Forum

Siduction Forum => Software - Support => Software Support (EN) => Topic started by: lesdelc on 2021/10/02, 21:35:36

Title: Problem installing rtl88x2bu- DKMS
Post by: lesdelc on 2021/10/02, 21:35:36
I cannot find the solution to installing rtl88x2bu- DKMS. See the problem below I captured the install problem.

This file is related to my internal modem problems. My modem keeps dropping carrier. To prevent the carrier from dropping I added a USB Wi-Fi adaptor from tp-link to my laptop. Any suggestions to installing rtl88x2bu- DKMS?

Loading new rtl88x2bu- DKMS files...
Building for 5.14.9-1-siduction-amd64
Building initial module for 5.14.9-1-siduction-amd64
Error! Bad return status for module build on kernel: 5.14.9-1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/rtl88x2bu/ for more information.
dpkg: error processing package rtl88x2bu-dkms (--configure):
 installed rtl88x2bu-dkms package post-installation script subprocess returned error exit status 10
Setting up xdg-desktop-portal (1.10.1-2) ...
Setting up libnm0:amd64 (1.32.12-1) ...
Setting up gir1.2-nm-1.0:amd64 (1.32.12-1) ...
Setting up libkf5attica5:amd64 (5.86.0-2) ...
Setting up network-manager (1.32.12-1) ...
Processing triggers for siduction-dynamic-dms (2016.01.31) ...
Processing triggers for dbus (1.12.20-2) ...
Processing triggers for libc-bin (2.32-4) ...
Processing triggers for man-db (2.9.4-2) ...
Errors were encountered while processing:
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Title: Re: Problem installing rtl88x2bu- DKMS
Post by: wesleydt on 2021/10/02, 22:54:37
try it!!
Title: Re: Problem installing rtl88x2bu- DKMS
Post by: lesdelc on 2021/10/03, 02:27:20
Thank you for the reply. I am trying to get into the Debian forum but I am having difficulty. I can reply once I get access.

try it!!

Title: Re: Problem installing rtl88x2bu- DKMS (Solved)
Post by: lesdelc on 2021/10/25, 20:24:39
I am late in replying to those who left me replies to my query. My apologies I solved my problem. I had a MS Surface Pro book laptop which did not meet the specs for Win 11. I wiped the disk and installed Siduction on it. The install went great. However, the modem kept dropping carrier after a few minutes of use. I gave up on the build in modem and added a USB tp-link modem. This cleared up the modem dropping carrier. The tp-link USB modem runs great. I must say the MS Surface Pro Book laptop is a great piece of hardware. Great to see that Siduction has found a home on my MS laptop!  8)