Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  Anwendungen ohne Fensterleiste  (Read 3434 times)

Offline wodga

  • User
  • Posts: 191
Anwendungen ohne Fensterleiste
« on: 2011/07/04, 07:47:43 »
KDE scheint nach gestrigen d-u nicht richtig zu funktionieren, alle Anwendungen laufen ohne Fensterleiste. Ich kann nicht mal in die bash schreiben!
64bit, intel i5, GeForce GTX 650 Ti

arwa

  • Guest
Anwendungen ohne Fensterleiste
« Reply #1 on: 2011/07/04, 09:01:54 »
Funktioniert Alt+F2, um den Schnellstarter (krunner) zu aktivieren? Wenn ja, gib dort mal "kwin --replace" ein.

Wenn nein, musst Du das über die Konsole (Strg+Alt+F1) starten. Hier muss aber noch die display-Variable gesetzt werden, damit kwin weiß, welcher X-Server gemeint ist, mit dem es arbeiten soll.

export DISPLAY=0:0
kwin --replace &&

ggf. ist hier dann auch ein Restart von plasma-desktop interessant:
kquitapp plasma-desktop
plasma-desktop &

Vielleicht siehst Du dann ein paar Fehlermeldung, die interessant sein könnten, wenn es nicht klappt. Wenn es aber klappt, kann es sein, dass beim nächsten Login KDE diese Dinge vergessen hat. Du könntest dann versuchen, die Session nochmal zu speichern. Aber genaueres kann man nur sagen mit ein paar mehr Infos zu Fehlermeldungen bspw. auch in Logfiles unter /var/log.

Wenn "kwin --replace" nicht funktionieren sollte, kannst Du ggf. auch einen anderen window manager übergangsweise benutzen. Bspw. nach Installation des Paketes openbox ein "openbox --replace".

Offline wodga

  • User
  • Posts: 191
Anwendungen ohne Fensterleiste
« Reply #2 on: 2011/07/04, 13:24:36 »
mit openbox funktioniert's. Hat das aktuelle kwin einen bug, oder wo liegt das Problem?

Der Versuch openbox als Standardfenstermanager einzurichten (Systemeinstellungen-Standardkomponenten-Fenstermanager) scheitert! Wo könnte ich das noch festlegen?
64bit, intel i5, GeForce GTX 650 Ti

arwa

  • Guest
Anwendungen ohne Fensterleiste
« Reply #3 on: 2011/07/05, 09:11:58 »
Bei mir läuft kwin (64bit, letztes dist-upgrade for ca. 2 Tagen). Wenn es bei Dir nicht läuft, solltest Du in den Logs schauen, ob Du da Fehlermeldungen findest. Speziell in ~/.xsession-errors in Deinem Home-Verzeichnis. Oder auf der Konsole, von der aus Du ein "kwin --replace" versuchst.

Auch könntest Du mit einem frisch angelegten User-Profil gegentesten, ob es an Deinen kde4-Settings liegt.

Einen anderen WM in den settings zu konfigurieren, habe ich noch nie probiert. Nach meinem Verständnis sollte das dort funktionieren, wo Du es probiert hast. Vielleicht kann man auch aber nach einem "openbox --replace" die Session nochmal speichern, so dass dort die Einstellungen gespeichert sind.

Offline wodga

  • User
  • Posts: 191
xsession-errors
« Reply #4 on: 2011/07/05, 09:45:27 »
das mit dem sessionspeichern hat geklappt.

Vielleicht kannst du mit den xsession-errors was anfangen.
64bit, intel i5, GeForce GTX 650 Ti

arwa

  • Guest
xsession-errors
« Reply #5 on: 2011/07/05, 20:45:51 »
Nee, sorry, die xsession-errors sagen mir nichts.