Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  libqt5core5a update  (Read 9084 times)

°C

  • Guest
libqt5core5a update
« on: 2014/06/06, 20:18:12 »
Code: [Select]
Commit Log for Fri Jun  6 00:11:51 2014


Removed the following packages:
libqt5qml5
libqt5quick5
libqt5script5
libqt5webkit5
libqupzilla1
qupzilla

Upgraded the following packages:
binutils (2.24.51.20140604-1) to 2.24.51.20140604-2
dpkg (1.17.9) to 1.17.10
dpkg-dev (1.17.9) to 1.17.10
hexchat (2.10.0.siduction.2) to 2.10.0.siduction.4
hexchat-common (2.10.0.siduction.2) to 2.10.0.siduction.4
libdpkg-perl (1.17.9) to 1.17.10
libgnutls-openssl27 (3.2.15-1) to 3.2.15-2
libgtk-3-0 (3.12.2-1) to 3.12.2-1+b1
libgtk-3-bin (3.12.2-1) to 3.12.2-1+b1
libgtk2-perl (2:1.2491-3) to 2:1.2491-4
libkeyutils1 (1.5.6-1) to 1.5.9-4
liblcms2-2 (2.6-1) to 2.6-2
libpython3.4-minimal (3.4.1-2) to 3.4.1-3
libpython3.4-stdlib (3.4.1-2) to 3.4.1-3
libqt5core5a (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5dbus5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5gui5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5network5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5opengl5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5printsupport5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5sql5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5sql5-sqlite (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libqt5widgets5 (5.2.1+dfsg-3) to 5.3.0+dfsg-4
libssl1.0.0 (1.0.1g-4) to 1.0.1h-1
linux-libc-dev (3.14.4-1) to 3.14.5-1
openssl (1.0.1g-4) to 1.0.1h-1
python3.4 (3.4.1-2) to 3.4.1-3
python3.4-minimal (3.4.1-2) to 3.4.1-3
xterm (304-1) to 306-1

Installed the following packages:
libcolord2 (1.2.1-1)
libgnutls-deb0-28 (3.2.15-2)

Santa

  • Guest
Re: libqt5core5a update
« Reply #1 on: 2014/06/06, 20:39:49 »
Hello,


indeed there is the qt 5.3 transition going on https://release.debian.org/transitions/html/qtbase-abi-5-3-0.html


However qupzilla shouldn't be affected since it's still using qt4, also note it's not listed in the transition tracker. Are you able to reinstall qupzilla without issues? if not, can you please paste the output of aptitude install qupzilla?

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: libqt5core5a update
« Reply #2 on: 2014/06/06, 20:47:00 »
@Santa: you are wrong: Our qupzilla uses Qt5
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

°C

  • Guest
Re: libqt5core5a update
« Reply #3 on: 2014/06/06, 20:50:11 »
Code: [Select]
root@siductionbox:~# aptitude install qupzilla
The following NEW packages will be installed:
  libqt5core5a{a} libqt5dbus5{a} libqt5gui5{a} libqt5network5{a} libqt5opengl5{a} libqt5printsupport5{a} libqt5qml5{ab}
  libqt5quick5{ab} libqt5script5{ab} libqt5sql5{a} libqt5sql5-sqlite{a} libqt5webkit5{ab} libqt5widgets5{a}
  libqupzilla1{a} libxcb-icccm4{a} libxcb-image0{a} libxcb-render-util0{a} libxcb-xkb1{a} qupzilla
0 packages upgraded, 19 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/22.3 MB of archives. After unpacking 89.6 MB will be used.
The following packages have unmet dependencies:
 libqt5script5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5qml5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5quick5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5webkit5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
The following actions will resolve these dependencies:
                                                                                                                             
     Keep the following packages at their current version:                                                                   
1)     libqt5qml5 [Not Installed]                                                                                           
2)     libqt5quick5 [Not Installed]                                                                                         
3)     libqt5script5 [Not Installed]                                                                                         
4)     libqt5webkit5 [Not Installed]                                                                                         
5)     libqupzilla1 [Not Installed]                                                                                         
6)     qupzilla [Not Installed]   

Santa

  • Guest
Re: libqt5core5a update
« Reply #4 on: 2014/06/06, 21:39:09 »
@Santa: you are wrong: Our qupzilla uses Qt5


The debian version is higher.


Code: [Select]

root@nemesis:/home/santa# apt-cache policy libqupzilla1
libqupzilla1:
  Instalados: 1.6.6-1
  Candidato:  1.6.6-1
  Tabla de versión:
 *** 1.6.6-1 0
        500 http://ftp.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.6.5.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     1.6.3-1.1 0
        500 http://packages.siduction.org/fixes/ unstable/main amd64 Packages
root@nemesis:/home/santa# apt-cache policy qupzilla
qupzilla:
  Instalados: 1.6.6-1
  Candidato:  1.6.6-1
  Tabla de versión:
 *** 1.6.6-1 0
        500 http://ftp.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.6.5.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     1.6.3-1.1 0
        500 http://packages.siduction.org/fixes/ unstable/main amd64 Packages

Santa

  • Guest
Re: libqt5core5a update
« Reply #5 on: 2014/06/06, 21:40:40 »
Code: [Select]
root@siductionbox:~# aptitude install qupzilla
The following NEW packages will be installed:
  libqt5core5a{a} libqt5dbus5{a} libqt5gui5{a} libqt5network5{a} libqt5opengl5{a} libqt5printsupport5{a} libqt5qml5{ab}
  libqt5quick5{ab} libqt5script5{ab} libqt5sql5{a} libqt5sql5-sqlite{a} libqt5webkit5{ab} libqt5widgets5{a}
  libqupzilla1{a} libxcb-icccm4{a} libxcb-image0{a} libxcb-render-util0{a} libxcb-xkb1{a} qupzilla
0 packages upgraded, 19 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/22.3 MB of archives. After unpacking 89.6 MB will be used.
The following packages have unmet dependencies:
 libqt5script5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5qml5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5quick5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5webkit5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
The following actions will resolve these dependencies:
                                                                                                                             
     Keep the following packages at their current version:                                                                   
1)     libqt5qml5 [Not Installed]                                                                                           
2)     libqt5quick5 [Not Installed]                                                                                         
3)     libqt5script5 [Not Installed]                                                                                         
4)     libqt5webkit5 [Not Installed]                                                                                         
5)     libqupzilla1 [Not Installed]                                                                                         
6)     qupzilla [Not Installed]   


Thanks, please post also the output of apt-cache policy qupzilla.

°C

  • Guest
Re: libqt5core5a update
« Reply #6 on: 2014/06/06, 21:50:46 »
Code: [Select]
root@siductionbox:~# apt-cache policy qupzilla
qupzilla:
  Installed: (none)
  Candidate: 1.6.6.siduction.2
  Version table:
     1.6.6.siduction.2 0
        500 http://packages.siduction.org/extra/ next/main amd64 Packages
     1.6.6-1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
     1.6.5.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     1.6.3-1.1 0
        500 http://packages.siduction.org/fixes/ unstable/main amd64 Packages

Santa

  • Guest
Re: libqt5core5a update
« Reply #7 on: 2014/06/06, 23:54:49 »
Code: [Select]
root@siductionbox:~# apt-cache policy qupzilla
qupzilla:
  Installed: (none)
  Candidate: 1.6.6.siduction.2
  Version table:
     1.6.6.siduction.2 0
        500 http://packages.siduction.org/extra/ next/main amd64 Packages
     1.6.6-1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
     1.6.5.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     1.6.3-1.1 0
        500 http://packages.siduction.org/fixes/ unstable/main amd64 Packages


So you have the version based on qt5. In any case I think the problem is gone thanks to our fixes/ repository, please let us know if the problem persists.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: libqt5core5a update
« Reply #8 on: 2014/06/07, 01:20:15 »
There is a new version of qupzilla in next - if there are no big problems we should move the qt5-build to extra/unstable
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)