Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  [EN] SDDM installation/update unmet dependencies  (Read 1020 times)

Offline masinick

  • Newbie
  • Posts: 4
[EN] SDDM installation/update unmet dependencies
« on: 2023/01/13, 20:44:01 »
When attempting to update the system today I ran into this problem.
I reissued the specific package/group that led to the problem.

sudo apt-get install sddm
[sudo] password for "user":
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt5qml5 : Depends: qtbase-abi-5-15-7 but it is not installable
libqt5qmlmodels5 : Depends: qtbase-abi-5-15-7 but it is not installable
qml-module-qtquick2 : Depends: libqt5quick5 (>= 5.15.1) but it is not installable or
                                libqt5quick5-gles (>= 5.15.1) but it is not installable
sddm : Depends: libqt5quick5 (>= 5.8.0~) but it is not installable or
                libqt5quick5-gles (>= 5.8.0~) but it is not installable
E: Unable to correct problems, you have held broken packages.
« Last Edit: 2023/01/13, 22:33:15 by towo »

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.871
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 844
Re: SDDM installation/update unmet dependencies
« Reply #2 on: 2023/01/13, 22:05:17 »
btw. this is not a bug!

We have a warning section in our forum!

Like we told so many times, read what apt want's to do, and if unsure, konsult the forum and ask before doing wrong things!