Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Warning: nvidia updates may not be suitable  (Read 4161 times)

Offline Pip

  • User
  • Posts: 165
[EN] Warning: nvidia updates may not be suitable
« on: 2023/03/23, 23:19:11 »
I did a full-upgrade earlier with a number of nvidia upgrades, largely to version 525.89.02-2. After that, I couldn't boot into graphic mode or run startx at the command line (didn't note the error at the time, sorry).

nvidia-detect told me I should install nvidia-tesla-470-driver for my GK104 [GeForce GTX 770] (rev a1), which I did, but it still wouldn't boot into GUI. I was thinking of removing it completely, but just went for a few


Code: [Select]
sudo apt remove nvidia-alternative nvidia-egl-common nvidia-vdpau-driver nvidia-vulkan-common nvidia-vulkan-icd
which then expanded to:

Code: [Select]
Remove: libnvcuvid1:amd64 (525.89.02-2), nvidia-alternative:amd64 (525.89.02-2), libgles-nvidia1:amd64
(525.89.02-2), libgles-nvidia2:amd64 (525.89.02-2), nvidia-egl-icd:amd64 (525.89.02-2), nvidia-vulkan-i
cd:amd64 (525.89.02-2), nvidia-tesla-470-driver:amd64 (470.161.03-2), nvidia-vulkan-common:amd64 (525.8
9.02-2), libglx-nvidia0:amd64 (525.89.02-2), nvidia-kernel-support:amd64 (525.89.02-2), nvidia-driver-b
in:amd64 (525.89.02-2), libnvidia-ml1:amd64 (525.89.02-2), libnvidia-encode1:amd64 (525.89.02-2), nvidi
a-driver-libs:amd64 (525.89.02-2), nvidia-driver:amd64 (525.89.02-2), nvidia-tesla-470-egl-icd:amd64 (4
70.161.03-2), nvidia-tesla-470-driver-libs:amd64 (470.161.03-2), libgl1-nvidia-glvnd-glx:amd64 (525.89.
02-2), nvidia-kernel-dkms:amd64 (525.89.02-2), libnvidia-cfg1:amd64 (525.89.02-2), nvidia-settings:amd6
4 (525.85.05-1), nvidia-egl-common:amd64 (525.89.02-2), nvidia-tesla-470-vulkan-icd:amd64 (470.161.03-2
), nvidia-vdpau-driver:amd64 (525.89.02-2), libegl-nvidia0:amd64 (525.89.02-2), xserver-xorg-video-nvid
ia:amd64 (525.89.02-2), libcuda1:amd64 (525.89.02-2), nvidia-smi:amd64 (525.89.02-2)

After that, it booted into GUI again.

Be careful out there.

Offline eriefisher

  • User
  • Posts: 283
Re: Warning: nvidia updates may not be suitable
« Reply #1 on: 2023/03/24, 12:04:25 »
So what driver are you left with?

Offline michaa7

  • User
  • Posts: 2.323
Re: Warning: nvidia updates may not be suitable
« Reply #2 on: 2023/03/24, 12:12:12 »
It seems you have "nvidia-driver" still installed (which will always install the highest version, currently 525.x.

You need to uninstall it and replace it with "nvidia-tesla-470-driver". (Some nvidia utilites like nvidia-detect will still be a higher version which is necessary and does not hurt)
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline Pip

  • User
  • Posts: 165
Re: Warning: nvidia updates may not be suitable
« Reply #3 on: 2023/03/25, 00:41:56 »
The remaining nvidia packages are:


Code: [Select]
apt list --installed | grep nvidia
 
firmware-nvidia-gsp/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
glx-alternative-nvidia/unstable,now 1.2.2 amd64 [installed,automatic]
libegl-nvidia-tesla-470-0/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libgl1-nvidia-tesla-470-glvnd-glx/unstable,now 470.161.03-2 amd64 [installed,automatic]
libgles-nvidia-tesla-470-1/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libgles-nvidia-tesla-470-2/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libglx-nvidia-tesla-470-0/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-allocator1/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-egl-gbm1/unstable,now 1.1.0-2 amd64 [installed,auto-removable]
libnvidia-egl-wayland1/unstable,now 1:1.1.10-1 amd64 [installed,auto-removable]
libnvidia-eglcore/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-glcore/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-glvkspirv/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-legacy-390xx-eglcore/unstable,now 390.157-1 amd64 [installed,auto-removable]
libnvidia-legacy-390xx-fatbinaryloader/unstable,now 390.157-1 amd64 [installed,auto-removable]
libnvidia-legacy-390xx-glcore/unstable,now 390.157-1 amd64 [installed,auto-removable]
libnvidia-legacy-390xx-ptxjitcompiler1/unstable,now 390.157-1 amd64 [installed,auto-removable]
libnvidia-ptxjitcompiler1/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-rtcore/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
libnvidia-tesla-470-cbl/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libnvidia-tesla-470-cfg1/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-cuda1/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-eglcore/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-encode1/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libnvidia-tesla-470-glcore/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-glvkspirv/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libnvidia-tesla-470-ml1/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-nvcuvid1/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
libnvidia-tesla-470-ptxjitcompiler1/unstable,now 470.161.03-2 amd64 [installed,automatic]
libnvidia-tesla-470-rtcore/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
nvidia-detect/unstable,now 525.89.02-2 amd64 [installed]
nvidia-installer-cleanup/unstable,now 20220217+2 amd64 [installed,automatic]
nvidia-kernel-common/unstable,now 20220217+2 amd64 [installed,automatic]
nvidia-legacy-check/unstable,now 525.89.02-2 amd64 [installed,auto-removable]
nvidia-modprobe/unstable,now 530.30.02-1 amd64 [installed,automatic]
nvidia-persistenced/unstable,now 525.85.05-1 amd64 [installed,automatic]
nvidia-settings-tesla-470/unstable,now 470.161.03-1 amd64 [installed,automatic]
nvidia-support/unstable,now 20220217+2 amd64 [installed,automatic]
nvidia-tesla-470-alternative/unstable,now 470.161.03-2 amd64 [installed,automatic]
nvidia-tesla-470-driver-bin/unstable,now 470.161.03-2 amd64 [installed,auto-removable]
nvidia-tesla-470-kernel-dkms/unstable,now 470.161.03-2 amd64 [installed,automatic]
nvidia-tesla-470-kernel-support/unstable,now 470.161.03-2 amd64 [installed,automatic]
nvidia-tesla-470-smi/unstable,now 470.161.03-2 amd64 [installed,automatic]
nvidia-tesla-470-vdpau-driver/unstable,now 470.161.03-2 amd64 [installed,automatic]
xserver-xorg-video-nvidia-tesla-470/unstable,now 470.161.03-2 amd64 [installed,automatic]
I haven't gone through it in detail to find out just what went wrong, I was more concerned with getting it functional again and getting back to work.

Offline michaa7

  • User
  • Posts: 2.323
Re: Warning: nvidia updates may not be suitable
« Reply #4 on: 2023/03/25, 10:55:44 »
ohne gewähr:

Code: [Select]
apt purge nvidia* && apt install nvidia-tesla-470-driver nvidia-detect
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline Camelot

  • User
  • Posts: 81
Re: Warning: nvidia updates may not be suitable
« Reply #5 on: 2023/03/26, 09:44:13 »
Don’t forgot the libnvidia-legacy-390xx packages.
« Last Edit: 2023/03/26, 09:48:41 by Camelot »

Offline dpanter

  • User
  • Posts: 61
Re: Warning: nvidia updates may not be suitable
« Reply #6 on: 2023/03/28, 21:02:17 »
Nvidia in their infinite wisdom dropped support for Kepler chips in 2021 so upgrading would indeed cause a problem for a GTX 770.
The last driver series to support Kepler (GT/GTX6xx, GT/GTX7xx, Titan/Black/Z) is 470, with the side note that GTX745/750/750ti are still supported in the latest 525/530 driver series as those cards have Maxwell chips.
<< insert signature here >>

Offline shab

  • User
  • Posts: 10
Re: Warning: nvidia updates may not be suitable
« Reply #7 on: 2023/04/16, 13:59:10 »
how can I upgrdade if I have a GTX 770?

Offline Pip

  • User
  • Posts: 165
Re: Warning: nvidia updates may not be suitable
« Reply #8 on: 2023/04/16, 15:13:10 »
I have the GeForce GTX 770 and, after making the previously mentioned changes, I've not had any problems with upgrades.

Offline shab

  • User
  • Posts: 10
Re: Warning: nvidia updates may not be suitable
« Reply #9 on: 2023/04/17, 18:46:38 »
It worked for me as well. THX

Offline sidlix

  • User
  • Posts: 115
Re: Warning: nvidia updates may not be suitable
« Reply #10 on: 2023/04/30, 16:58:48 »
I attach myself once to the post.

I have a problem with a nvidia driver and the linux-headers-6.2.6-1-siduction-amd64.


inxi -G writes:

Code: [Select]
NVIDIA GK208 [GeForce GT 630 Rev. 2] driver: nvidia v: 470.161.03


last running kernel:

Code: [Select]
Kernel: 6.1.3-2-siduction-amd64 arch: x86_64 bits: 64


When trying to perform a dist-upgrade I get the following message:


Code: [Select]
...

Try "apt --fix-broken install" to fix this.
The following packages have unfulfilled dependencies:
 nvidia-driver : Depends on: nvidia-kernel-dkms (= 525.105.17-1) but 510.108.03-2 is installed or
                                nvidia-kernel-525.105.17 or
                                nvidia-open-kernel-525.105.17 oder
                                nvidia-open-kernel-525.105.17
                Recommends: nvidia-settings (>= 525) but is not installed
E: Unfulfilled dependencies. Try "apt --fix-broken install" without specifying a package (or specify a solution).




Attempting apt --fix-broken install fails with the same error message from above; even dpkg --configure -a does not provide a workaround.  Likewise, the packages cannot be removed after install nor the offending kernel with apt purge linux-image-6.2.6-1-siduction-amd64.


What am I doing wrong and does anyone have a solution?


Thank you very much for reading.





Ich hänge mich einmal an den Beitrag an.
Ich habe ein Problem mit einem nvidia Treiber und dem linux-headers-6.2.6-1-siduction-amd64.

inxi -G schreibt:
Code: [Select]
NVIDIA GK208 [GeForce GT 630 Rev. 2] driver: nvidia v: 470.161.03

letzter lauffähiger Kernel:
Code: [Select]
Kernel: 6.1.3-2-siduction-amd64 arch: x86_64 bits: 64 
Bei Versuch, ein dist-upgrade durchzuführen erhalte ich folgende Meldung:

Code: [Select]
...
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 nvidia-driver : Hängt ab von: nvidia-kernel-dkms (= 525.105.17-1) aber 510.108.03-2 ist installiert oder
                                nvidia-kernel-525.105.17 oder
                                nvidia-open-kernel-525.105.17 oder
                                nvidia-open-kernel-525.105.17
                Empfiehlt: nvidia-settings (>= 525) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).



Der Versuch mit apt --fix-broken install schlägt fehlt mit gleicher Fehlermeldung von oben; auch dpkg --configure -a schafft keine Abhilfe.  Ebenso lassen sich die Pakete nicht nach installieren noch der beanstandete Kernel mit apt purge linux-image-6.2.6-1-siduction-amd64 entfernen.

Was mache ich falsch und hat jemand eine Lösung?

Vielen Dank schon einmal für das Lesen.
s i d l i x
... .. -.. .-.. .. -..-
debian s i d +  nee l i x

Offline dpanter

  • User
  • Posts: 61
Re: Warning: nvidia updates may not be suitable
« Reply #11 on: 2023/04/30, 19:15:17 »
You can't have newer driver than 470 series for the GT630. Read the posts in this thread as you already have the answer here.
<< insert signature here >>

Offline michaa7

  • User
  • Posts: 2.323
Re: Warning: nvidia updates may not be suitable
« Reply #12 on: 2023/05/02, 15:17:14 »
You need to purge "nvidia-driver" (which may cause the nvidia-470 driver to be purged, too!) and then install "nvidia-tesla-470-driver" (which will reinstall the 470 driver).
Ok, you can't code, but you still might be able to write a bug report for Debian's sake