Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] gelöst : nvidia treiber installation  (Read 15025 times)

Offline ayla

  • User
  • Posts: 1.744
[DE] gelöst : nvidia treiber installation
« Reply #15 on: 2010/11/09, 17:47:45 »
Und stell deine hardware-Informationen zur Verfügung.
Code: [Select]
infobash -v3
Gruß
ayla

Phoenix

  • Guest
gelöst : nvidia treiber installation
« Reply #16 on: 2010/11/09, 20:06:24 »
Hallo ayla,

infobash -v3 ist ein wenig schwierig, das Arbeitssystem will das nicht verarbeiten...

Hallo towo,
Quote

Warum erzählst du nicht einfach, wo es hakt?
Und btw, Anhänge pakt man in ein tgz, das sollte die Forensoftware akzeptieren.


Wo es hakt? das grafische System auf Aptosid ist kaputt, ich kann also detailliert keine Auskünfte geben. Ich hatte allerdings eine ganze Latte Infos in dem Writer- Dokument aufgelistet, als ich die Versuche gemacht habe. Und die Datei hat 8 Seiten...

Ich versuche es jetzt mal mit einem 7zip- Format. Die /var/log/Xorg.0.log sollte das wichtigste zeigen.

Ich möchte jetzt gern Tipps haben, wie ich das System wieder herrichten kann ohne Neuinstallation. Danach interessiert mich, wie ich die Originaltreiber von NVidia installieren kann.

Nette Grüße

Phoenix

p.s.: 7z funktioniert auch nicht; vielleicht .zip?

Offline ayla

  • User
  • Posts: 1.744
gelöst : nvidia treiber installation
« Reply #17 on: 2010/11/09, 20:46:06 »
Hi,

also, zuerst mal: Du bist in Runlevel 3 (multiuser und Netzwerkbetrieb)?

Ohne zu wissen welchen Chip du hast:

dann als root
Code: [Select]
nano /etc/apt/sources.list.d/debian.list
contrib und non-free (zumindest non-free, contrib brauchst du für den Treiber nicht, aber vielleicht später mal) wie im thread zu sehen anhängen.

Dann Tastenkombi: strg+o zum Speichern; enter zum Bestätigen; strg+x zum verlassen des Editors.

Dann

Code: [Select]
apt-get update

Dann Handbuch folgen: http://manual.aptosid.com/de/hw-dev-hw-dri-de.htm#non-free-3d

Dort wo <editor> steht nano einsetzen und mit der Kombi oben, nach Einfügen der betreffenden Zeilen, speichern und verlassen.

Und es nützt rein garnix wenn ein Schritt nicht geklappt hat dann einfach weiterzumachen.

Sollte alles problemlos durchlaufen solltest du am Ende wieder deine grafische Oberfläche haben.

Falls nicht:
Code: [Select]
nano /etc/X11/xorg.conf.d/20-nvidia.conf und bei driver statt nvidia vesa eingeben, speichern und verlassen, reboot


Wenns unterwegs nochmal Probleme gibt -fragen.

besenmuckel

  • Guest
gelöst : nvidia treiber installation
« Reply #18 on: 2010/11/10, 00:59:48 »
falls  editor nano nicht auf deinen system ist, kannst du auch mcedit nehmen und machen wie ayla beschrieben. mc ist als standart dabei.
z.b.
Code: [Select]
mcedit /etc/apt/sources.list.d/debian.list
und
Code: [Select]
mcedit /etc/X11/xorg.conf.d/20-nvidia.conf
mcedit beenden mit taste F10, mit pfeiltaste auswählen speichern. kwrite und andere gehen nur wenn der xserver läuft. wenn z.b. kde läuft kannst du mit tastenkombination(Alt+F2) im befehlsfenster eingeben
Code: [Select]
kdesu kwrite
damit startet kwrite mit root-rechten.

Phoenix

  • Guest
Fehlinstallation repariert
« Reply #19 on: 2010/11/10, 01:17:36 »
Hallo ayla,

was soll ich sagen? Ich arbeite gerade auf Aptosid; also... Deine Hinweise stimmten, das Grafiksystem läuft wieder. Ich kann mich einfach nur bedanken.

Die Fuhrwerkerei :lol: auf der Textkonsole war für mich völlig ungewohnt. Ohne Ausdruck der Hinweise wären die Eingaben auch nicht möglich gewesen.

Ich sollte zwar jetzt die Nvidia- Treiber aus den Debian- Quellen installiert haben, aber die maximale Bildschirmauflösung entspricht mit 1024x768 nicht der maximal möglichen des Bildschirms.
Code: [Select]
(58: None 00.0: 10000 Monitor
  [Created at fb.71]        
  Unique ID: rdCR.EY_qmtb9YY0
  Hardware Class: monitor    
  Model: "Generic Monitor"  
  Vendor: "Generic"          
  Device: "Monitor"          
  Resolution: 1400x1050@77Hz
  Driver Info #0:            
    Max. Resolution: 1400x1050
    Vert. Sync Range: 50-90 Hz
    Hor. Sync Range: 31-85 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown)

Größere Angaben = höhere Auflösung läßt der gerade verwendete Treiber nicht zu.

Jetzt muß ich als Quälgeist natürlich fragen, wie ich den Firmentreiber noch installiert bekomme. In der Writer- Datei ist der Treiber genannt, den würde ich natürlich noch einmal suchen.

Aber: selbst herunterladen, dann mit einem Werkzeug installieren, oder:
mit einem Installationswerkzeug direkt herunterladen & in einem Weg installieren?

Das Handbuch muß natürlich mein Freund werden...

Nette Grüße

Phoenix

Phoenix

  • Guest
gelöst : nvidia treiber installation
« Reply #20 on: 2010/11/10, 01:32:17 »
Nachtrag:

Nutzer_3@aptosidbox:~$ infobash -v3
Code: [Select]
Host/Kernel/OS  "aptosidbox" running Linux 2.6.35-4.slh.9-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info        AMD Athlon 64 4000+ 1024 KB cache flags( sse3 nx lm ) clocked at [ 2400.000 MHz ]
Videocard       nVidia C68 [GeForce 7050 PV / nForce 630a]  X.Org 1.7.7  [ 1024x768@50.0hz ]
Network cards   nVidia MCP67
Processes 114 | Uptime 42min | Memory 370.6/1759.0MB | HDD SAMSUNG HD502IJ,r Technology J92 Size 750GB (34%used) | GLX Renderer GeForce 7050 PV / nForce 630a/PCI/SSE2 | GLX Version 2.1.2 NVIDIA 195.36.31 | Client Shell | Infobash v3.34

Nutzer_3@aptosidbox:~$

Hallo besenmuckel,

Dein Post kam erst bei meiner Arbeit am letzten Post... danke.

Aber den Nano kenne ich schon, nur habe ich den wahrscheinlich 1 oder 2 Jahre nicht benutzt. Mit vim habe ich auch schon gearbeitet, aber nano hat für mich bessere Menüs. Am Bildschirmrand werden ja die wichtigsten Befehle angezeigt. Weshalb mir nicht einfiel, die KDE- Editoren durch etwas „vernünftiges“ zu ersetzen, weiß ich nicht. (Man wird eben nicht jünger).

Nette Grüße

Phoenix

Offline ayla

  • User
  • Posts: 1.744
gelöst : nvidia treiber installation
« Reply #21 on: 2010/11/10, 07:57:44 »
Hi,

schön daß du es wieder bunt hast und infobash sagt auch daß der proprietäre (oder wie du es nennst Firmen-)Treiber benutzt wird :)

Als erstes würde ich mein System auf den neuesten Stand bringen:
Konsole öffnen und zu root werden
Code: [Select]
sux
passwort
apt-get update
apt-get dist-upgrade -d
init 3
als root im Textmodus einloggen
Code: [Select]
apt-get dist-upgrade
reboot

Dann kannst du versuchen ob du mit den nvidia-settings weiterkommst.
Code: [Select]
apt-get install nvidia-settings
Danach kannst du die "settings" über das K-Menü aufrufen.

Von dem aktuellen Treiber der Nvidia-Website würde ich im Moment noch die Finger lassen bis du dich mit deinem System besser auskennst, wenn du allerdings mit den Settings nicht weiter kommen solltest hat towo auf seinem Frickelplatz, so weit ich weiß, auch immer einen aktuellen Treiber und hilft dir sicher auch bei der Installation weiter.

Gruß
ayla

darktiger

  • Guest
gelöst : nvidia treiber installation
« Reply #22 on: 2010/11/11, 13:54:44 »
hast Du auch das Handbuch konsultiert/probiert? http://manual.aptosid.com/de/hw-dev-hw-dri-de.htm#non-free-3d

Edit: Post ignorieren. Ich hatte übersehen, dass die Diskussion auf der zweiten Seite weiterging :-) Sorry.

Phoenix

  • Guest
gelöst : nvidia treiber installation
« Reply #23 on: 2010/11/11, 17:07:04 »
Hallo ayla,

Ich hab den ganzen Ablauf durchgeackert. So ca. 2 h hat's gedauert...
Danach müßte ich ja eigentlich ein aktuelles System haben.
Aber: verstehst Du unter den settings die Systemeinstellungen - … - Anzeige? Leider hat sich da nichts geändert, 1024 x 768 bleibt. Oder gibt es da ein verstecktes weiteres Modul?

Quote
"schön daß du es wieder bunt hast und infobash sagt auch daß der proprietäre (oder wie du es nennst Firmen-)Treiber benutzt wird"

Den Terminus habe ich gewählt, weil mir nicht ganz klar ist, inwieweit der NV- Treiber propritär oder nur unfrei im Sinne der Debian- Richtlinien ist.

Quote
Code: [Select]
"Konsole öffnen und zu root werden
apt-get update
apt-get dist-upgrade -d
init 3
als root im Textmodus einloggen
apt-get dist-upgrade
reboot


Code: [Select]
... nvidia-settings ...
apt-get install nvidia-settings


Code: [Select]
...die "settings" über das K-Menü aufrufen.“


Quote
"Von dem aktuellen Treiber der Nvidia-Website würde ich im Moment noch die Finger lassen bis du dich mit deinem System besser auskennst, wenn du allerdings mit den Settings nicht weiter kommen solltest hat towo auf seinem Frickelplatz, so weit ich weiß, auch immer einen aktuellen Treiber und hilft dir sicher auch bei der Installation weiter."


Deinem letzten Hinweis nach sollte ich ja in dem Falle bei towo mal anklopfen. >>

Ich hoffe, daß Du, towo, auch mitliest. Was hast Du in Deinem Schatull an weiteren Möglichkeiten? Ich hatte das Theater mit der unzureichenden Bildschirmauflösung auch schon bei der Erstinstallation des openSUSE (und später auch des Mandriva) bei dem neuen Rechner ab 03/2009. Erst der wirkliche Originaltreiber von Nvidia brachte die korrekte Auflösung. Aus heutiger Sicht würde ich auf Nvidia verzichten, aber...
Ich kenne die Hintergründe der Bremse nicht, die die Verfeinerung der Ansicht behindert.

Ich habe jetzt zwar große Schriften, aber bei den meisten Menüs keine komplette Darstellung ohne Scrollen.

Bis jetzt hatte ich mit aylas Hinweisen Glück. Ich freue mich sehr, wenn auch Du mir Hinweise gibst, wie es weitergehen könnte.
 
Hallo darktiger,
Quote

"hast Du auch das Handbuch konsultiert/probiert?“

Danke, aber ayla hatte mich in seinem Post vom 09.11.2010, 20:46
Quote
"Dann Handbuch folgen: http://manual.aptosid.com/de/hw-dev-hw- ... on-free-3d“
schon darauf hingewiesen. Selbstverständlich habe ich auch den Ablauf dort nachgestellt.

Nette Grüße nach Assindia!

Dank an alle Mitstreiter hier

Phoenix

seagull

  • Guest
gelöst : nvidia treiber installation
« Reply #24 on: 2010/11/11, 17:51:36 »
Bevor ich den Treiber von der Nvidia-Web-Seite installiere, würde ich mal versuchen mit dem von aptosid zur Verfügung gestellten zurecht zu kommen.
Eine Möglichkeit ist eine sogenannte "mode-line" zu berechnen und in der 20-nvidia.conf einzutragen.
hwinfo --monitor kann falsche Angaben machen, deshalb ist die technische Bezeichnung vom Monitor wichtig (Handbuch, Geräterückseite).

Mit den korrekten Monitordaten kannst du mit Hilfe eines "Modeline Calculator" eine mode-line berechnen und in die 20-nvidia.conf eintragen.

Offline ayla

  • User
  • Posts: 1.744
gelöst : nvidia treiber installation
« Reply #25 on: 2010/11/11, 18:08:48 »
Quote from: "Phoenix"

Aber: verstehst Du unter den settings die Systemeinstellungen - … - Anzeige? Leider hat sich da nichts geändert, 1024 x 768 bleibt. Oder gibt es da ein verstecktes weiteres Modul?


Den Terminus habe ich gewählt, weil mir nicht ganz klar ist, inwieweit der NV- Treiber propritär oder nur unfrei im Sinne der Debian- Richtlinien ist.


Hallo Phoenix,

wenn du die nvidia-settings installiert hast dann hast du in deinem K-Menü einen Eintrag "NVIDIA X Server Settings". Wenn du diese öffnest und in "X Server Display Configuration" gehst hast du dort einen Eintrag "Resolution". Bei meinem ION-Chip und Acer- sowie LG-Monitor wird die jeweilige Auflösung korrekt angezeigt und ist dort auch änderbar.

Der nv-Treiber ist nicht der nvidia-Treiber, das sind zwei ganz verschiedene Paar Schuhe.
Der nv-Treiber ist soweit ich weiß FOSS, wird aber leider nicht mehr von nvidia unterstützt. Der nvidia-Treiber ist proprietär. Es gibt noch einen weiteren FOSS-Treiber, der steckt aber meines Wissens nach noch ziemlich in den Kinderschuhen.

hmm, eins fällt mir noch ein...

Mach doch mal ein
Code: [Select]
ls -ls /etc/X11 und schau mal nach ob du dort von deinen vorangegangenen Versuchen vielleicht noch eine xorg.conf liegen hast. Wenn ja, umbenennen in xorg.conf.old oder so. Nicht das Verzeichnis xorg.conf.d wo deine 20-nvidia.conf liegt. Das brauchst du noch :)

Es ist möglich daß nvidia-settings noch die alte xorg.conf benutzt. Deshalb -falls existent- zuertst die xorg.conf löschen und rebooten. Wenn deine Auflösung dann stimmt ist alles in Ordnung. Wenn nicht -dann erst die nvidia-settings zum Ändern der Auflösung benutzen und, falls dies klappt und nach dem Speichern dann wieder eine xorg.conf existieren sollte, diese entweder in Ruhe lassen oder in die xorg.conf.d/20-nvidia.conf übernehmen.

Gruß
ayla

Phoenix

  • Guest
Ich hoffe, ich hab' jetzt alles...
« Reply #26 on: 2010/11/11, 20:17:43 »
Hallo,

folgendes habe ich jetzt ermittelt (ohne es schon anzuwenden):

Quote
file:///usr/share/aptosid-manual/de/hw-dev-mon-de.htm#mon-res

Ändern der Bildschirmauflösung
xrandr
Unterstützte Grafikkartentreiber

...
    * nv (ab 2.1) für G80 wie GeForce 8800
...

Als erstes muss man nur xrandr eingeben, um festzustellen, ob das Programm unterstützt ist. ...

Nutzer_3@aptosidbox:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       50.0*    53.0     54.0     55.0     56.0     57.0     58.0  


Die Auflösung des primären Bildschirms kann man bei Unterstützung durch xrandr folgendermaßen ändern:

xrandr --output VGA --mode 1440x900   würde >>
xrandr --output VGA --mode 1680x1050


@ seagull
   
Quote
Bevor ich den Treiber von der Nvidia-Web-Seite installiere, würde ich mal versuchen mit dem von aptosid zur Verfügung gestellten zurecht zu kommen.
Eine Möglichkeit ist eine sogenannte "mode-line" zu berechnen und in der 20-nvidia.conf einzutragen.
hwinfo --monitor kann falsche Angaben machen, deshalb ist die technische Bezeichnung vom Monitor wichtig (Handbuch, Geräterückseite).

Mit den korrekten Monitordaten kannst du mit Hilfe eines "Modeline Calculator" eine mode-line berechnen und in die 20-nvidia.conf eintragen.


Die Daten lt. Hersteller aus dem Netz sind: http://www.aoc-europe.com/de/monitors/phased_out/22_2216Sa.php?navid=161
Quote

Maximum Resolution    1680x1050@60Hz


Modeline Calculator

http://www.arachnoid.com/modelines/
Code: [Select]
# 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
Modeline "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync


Leider habe ich im Moment keine Idee, was ich davon in die 20-nvidia.conf eintragen müßte. Weißt Du da mehr? Oder wäre alternativ die zuerst genannte Methode per xandr gefahrloser?

STOP
Ich nehme alles zurück und behaupte was anderes. Ayla hatte das richtige im Petto, das habe ich erst "zwischendurch" gesehen.

@ ayla:

die xorg.conf existiert(e) noch. {12 -rw-r--r-- 1 root root 10809  8. Nov 00:28 xorg.conf} Ich hab die jetzt erst einmal umbenannt in xorg.conf_alt.
"NVIDIA X Server Settings" hab ich mittlerweile auch gefunden. Die hatte ich gestern schon mal gesehen, aber rein garnicht beachtet.
Sieh mir bitte nach, daß ich ein wenig herumrudere; die Einstellerei bei Aptosid hat fast überhaupt nichts mehr mit den von mir bisher gewohnten Linux- Arbeitsweisen zu tun. Nur ermöglicht mir die Arbeit mit 2 Systemen auf 2 Festplatten immer noch eine Weiterarbeit, wenn (mal wieder aus Unkenntnis) etwas Systemwichtiges schiefläuft.

Neustart- und Überraschung: alles kleiner, also: die Auflösung ist verändert. Demnach müßte es die xorg.conf. verhindert haben, daß alles nach den Anpassungen noch nicht richtig dargestellt wurde. Die NVIDIA X Server Settings zeigen jetzt auch die korrekte Einstellung.

Fazit: jetzt habe ich eine korrekte Darstellung mit Hilfe eines Treibers, der nicht vom GraKa- Hersteller stammt. Wieder was gewonnen...:shock:

Nochmals vielen Dank an alle Mitstreiter (hoffentlich haben Mitleser auch was davon)
:wink:

Phoenix

Offline ayla

  • User
  • Posts: 1.744
gelöst : nvidia treiber installation
« Reply #27 on: 2010/11/11, 20:31:43 »
Quote
Fazit: jetzt habe ich eine korrekte Darstellung mit Hilfe eines Treibers, der nicht vom GraKa- Hersteller stammt. Wieder was gewonnen...Shocked


ahem.

Der nvidia-Treiber ist der Treiber des Herstellers oder auch proprietärer Treiber genannt.

Er wird nur lediglich durch ein deb.-Paket von der Herstellerseite geladen und installiert und bei einem neuen Kernel muß das Kernelmodul auch neu gebaut werden. Dafür hast du dmakms installiert, das diesen Prozess automatisiert.

Du benutzt lediglich nicht den neuesten nvidia-Treiber sondern einen der sich als stabil erwiesen hat.

Zumindest hab ich das so verstanden, laß mich aber auch gern eines Besseren belehren.

Freut mich daß es jetzt klappt :)

Gruß
ayla

seagull

  • Guest
gelöst : nvidia treiber installation
« Reply #28 on: 2010/11/12, 02:18:56 »
Beispiel für eine 20-nvidia.conf mit modeline:

Code: [Select]
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
    Option         "DontZap" "0"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "EIZO L671"
    HorizSync       27.0 - 80.0
    VertRefresh     50.0 - 75.0
    # Modeline aus calculator für L671 Monitor
    ModeLine       "1280x1024_50.00" 89.380 1280 1352 1488 1696 1024 1025 1028 1054 -hsync +vsync
    Option         "DPMS"
EndSection

Section "Device"
#   BoardName      "GeForce 7050 PV / nForce 630a"
    Identifier     "nvidia_graka"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "nvidia_graka"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
#    Option         "metamodes" "1280x1024_60 +0+0" # "1280x1024_60 +0+0; 1280x1024_50 +0+0"
    Option         "Coolbits" "1"
    Option         "AddARGBGLXVisuals" "true"
    Option         "TripleBuffer" "false"
        #BusID "PCI:0:18:0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
#


Diese 20-nvidia.conf läuft bei mir. Einträge sind z.T. aus nvidia-settings generierter xorg.conf (blind) übernommen.

Phoenix

  • Guest
gelöst : nvidia treiber installation
« Reply #29 on: 2010/11/12, 19:22:51 »
Hallo seagull,

anhand Deiner 20-nvidia.conf mit modeline wüßte ich jetzt wenigstens, wo und wie ich die Angaben einfügen müßte - wenn ich das noch brauchen würde... Ich hoffe aber, daß jemand anders das gut gebrauchen kann.

Jetzt ist mein Aptosid mehrmals gestartet, ohne das sich die Einstellungen verändert hätten. Das kann erstmal so bleiben.

Hallo Ayla,

Quote
"ahem.

Der nvidia-Treiber ist der Treiber des Herstellers oder auch proprietärer Treiber genannt.

Er wird nur lediglich durch ein deb.-Paket von der Herstellerseite geladen und installiert und bei einem neuen Kernel muß das Kernelmodul auch neu gebaut werden. Dafür hast du dmakms installiert, das diesen Prozess automatisiert.

Du benutzt lediglich nicht den neuesten nvidia-Treiber sondern einen der sich als stabil erwiesen hat.

Zumindest hab ich das so verstanden, laß mich aber auch gern eines Besseren belehren."


Das ist alles ein wenig undurchsichtig. Ich hab natürlich wieder recherchiert...
http://www.oszine.de/node/10961
http://wiki.ubuntuusers.de/Grafikkarten/Nvidia
http://wiki.ubuntuusers.de/nvidia-settings
http://de.opensuse.org/NVIDIA
http://debianforum.de/forum/viewtopic.php?f=2&t=120734
http://de.wikipedia.org/wiki/Nouveau  
bieten etwas zum Nachlesen. Deine Hinweise habe ich direkt nicht gefunden; diese klingen aber durchaus plausibel. Klar, daß ich zunächst nur eine Darstellung wollte, die mich zufriedenstellt. Das Hintergrundwissen ist mir aber genauso wichtig.

Danke vielmals für Dein Mithelfen; allein hätte ich das nie hinbekommen.

Schön wäre, wenn bolum als Threadstarter mitteilen könnte, ob er auch etwas brauchen kann. Er könnte den Thread auf gelöst setzen wenn er mag.

Schönes Wochenende

Phoenix