Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: PHP8.1 may break Nextcloud 23  (Read 665 times)

Offline qord

  • User
  • Posts: 30
PHP8.1 may break Nextcloud 23
« on: 2022/01/06, 02:13:13 »
Hi!
I updated from PHP7.4 to PHP8.1 via apt full-upgrade and it looks like this upgrade can break Nextcloud 23.

At the moment, I get this messagers from my nextcloud instance:
Quote
This version of Nextcloud is not compatible with > PHP 8.0.
You are currently running 8.1.1.
So far I have not done much troubleshooting on this, just maybe delay the PHP upgrade if you run Nextcloud.

-Cord

Offline qord

  • User
  • Posts: 30
Re: PHP8.1 may break Nextcloud 23
« Reply #1 on: 2022/01/06, 11:16:10 »
Nextcloud PHP requirements recommend 8.0 & I am getting the same error message as above when I try a fresh install - so apparently this should not be read as "8.0 or higher"...

Quote
PHP Runtime
   7.3
   7.4
   8.0 (recommended)

Offline qord

  • User
  • Posts: 30
Re: PHP8.1 may break Nextcloud 23
« Reply #2 on: 2022/01/06, 11:41:16 »
OK, downgrading PHP does not look like a route I want to go... will try to move my NC installation to a docker container for now.