Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: unklarer on 2021/11/11, 09:58:45

Title: [gelöst]new package with win-win situation
Post by: unklarer on 2021/11/11, 09:58:45
Jetzt beim DU soll ein neues Paket installiert werden, was diesen Fehler bringt:

Code: [Select]
System:    Host: sidukde Kernel: 5.15.1-1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.23.3
           Distro: siduction 16.1.0 Patience - kde - (201702251051)

ich bin schon beim von apt vorgeschlagenen

Code: [Select]
apt --fix-broken install
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Abhängigkeiten werden korrigiert … Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  node-slice-ansi
Die folgenden NEUEN Pakete werden installiert:
  node-slice-ansi
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 19 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen 8.060 B an Archiven heruntergeladen werden.
Nach dieser Operation werden 31,7 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
Holen:1 http://deb.debian.org/debian unstable/main amd64 node-slice-ansi all 5.0.0+~4.0.0-3 [8.060 B]
Es wurden 8.060 B in 0 s geholt (54,1 kB/s).
Laden der Fehlerberichte … Erledigt
»Found/Fixed«-Informationen werden ausgewertet … Erledigt
serious Fehler von node-slice-ansi (→ 5.0.0+~4.0.0-3) <Ausstehend>
 b1 - #998886 - node-string-width,node-slice-ansi: both ship /usr/share/nodejs/is-fullwidth-code-point/*
   Zusammengeführt mit: 998911
Zusammenfassung:
 node-slice-ansi(1 Fehler)
Sind Sie sicher, dass Sie die oben genannten Pakete installieren bzw. ein Upgrade von ihnen durchführen wollen? [Y/n/?/...]
Title: Re: new package with win-win situation
Post by: towo on 2021/11/11, 10:05:45
Kann es sein, dass Du den Fehler nicht gepostet hast?
Und btw.

Code: [Select]
towo:Defiant> apt policy node-slice-ansi
node-slice-ansi:
  Installiert:           (keine)
  Installationskandidat: 5.0.0+~4.0.0-3
  Versionstabelle:
     5.0.0+~4.0.0-3 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://deb.debian.org/debian unstable/main i386 Packages
     5.0.0+~4.0.0-2 500
        500 https://deb.debian.org/debian testing/main amd64 Packages
        500 https://deb.debian.org/debian testing/main i386 Packages

Bei mir gibts das Paket nicht.
Title: Re: new package with win-win situation
Post by: unklarer on 2021/11/11, 11:17:21
Danke towo, entschuldige, das ist schon durch...  Ich habe das mit dem serious Fehler verwechselt.

aus dem log
Code: [Select]
Start-Date: 2021-11-11  09:36:08
Commandline: apt dist-upgrade
Install: node-slice-ansi:amd64 (5.0.0+~4.0.0-2, automatic)
...
...
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2021-11-11  09:38:04

nodejs müßte bei mir einen Zusammenhang mit Conky-Konfigurationen haben...   ???
Wobei (5.0.0+~4.0.0-2, automatic) doch testing ist, was es hier nicht gibt und er auch

Code: [Select]
apt policy node-slice-ansi
node-slice-ansi:
  Installiert:           (keine)
  Installationskandidat: 5.0.0+~4.0.0-3
  Versionstabelle:
     5.0.0+~4.0.0-3 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages

unstable installieren "würde".   ::)

Title: Re: new package with win-win situation
Post by: unklarer on 2021/11/11, 19:00:42
@towo,

der Fehler war (aus term.log)
Code: [Select]
Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-h0pfnl/85-node-slice-ansi_5.0.0+~4.0.0-2_all.deb (--unpack):
 Versuch, »/usr/share/nodejs/is-fullwidth-code-point/index.d.ts« zu überschreiben, welches auch in Paket node-string-width 4.2.3+~3.0.0+~9.2.2-1 ist

durch ein apt install -f konnte ich das Problem auflösen
Code: [Select]
Vorbereitung zum Entpacken von .../node-slice-ansi_5.0.0+~4.0.0-3_all.deb ...
Entpacken von node-slice-ansi (5.0.0+~4.0.0-3) ...
node-slice-ansi (5.0.0+~4.0.0-3) wird eingerichtet ...
node-string-width (4.2.3+~9.2.2-1) wird eingerichtet ...

Alles paletti   :)